tkellogg

Where is the PMDG 737NGX Installer to update P3D Version 3 to Version 4

Recommended Posts

First let me say I love the 737NGX. I have looked everywhere and cannot find where to download the new installer for the 737NGX for version 4 of P3D. Can someone provide the link or give instructions on where I can find the installer? Another issue I have is that I have been patiently awaiting the arrival of the update and had been checking PMDGs website daily yet no mention of the update. It was only when I was checking on the availability of addons for Version 4 did I come across information the the 737NGX for version 4 was available. I cant understand why this was not on PMDGs home page. Any help would be much appreciated. Thanks in advance for your help. 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just download the existing P3D installer from the PMDG website. It has been updated to to include the ability to install into version 4. 

I agree that it would be helpful if the download page included wording to make it clear that the installer is now useable with both P3DV3 and V4.

At the moment (Sat 15 July at 20:30Z), only the NGX 800/900 base installer has been updated. The 600/700 is still to come.

Share this post


Link to post
Share on other sites
10 minutes ago, tkellogg said:

First let me say I love the 737NGX. I have looked everywhere and cannot find where to download the new installer for the 737NGX for version 4 of P3D. Can someone provide the link or give instructions on where I can find the installer? Another issue I have is that I have been patiently awaiting the arrival of the update and had been checking PMDGs website daily yet no mention of the update. It was only when I was checking on the availability of addons for Version 4 did I come across information the the 737NGX for version 4 was available. I cant understand why this was not on PMDGs home page. Any help would be much appreciated. Thanks in advance for your help. 

Log into your PMDG account and download the installer.

Share this post


Link to post
Share on other sites

It is confusing since most folks are used to separate installers for different product versions, they went a slightly different route but here you go:

Go to PMDG's website, home page.

Upper right hand corner, click "Register | Login".

Log in using your email account and password that you used for your initial purchase and  download.

Click CONTINUUE.

Click "View Previous Orders"

On the Order # link, choose your product you'd like to download.

Scroll down to the bottom of the page and you'll have your own personal download link

Click on that "Download URL"

Save it some where on your hard drive

Once done, navigate to that folder, right click on the file to unzip it to the same folder

Once done double click on the .exe that now exists.

It will ask if you want to install the product for V3 or V4, with the option of installing to both.

Good Luck!

Mark Trainer

 

 

Share this post


Link to post
Share on other sites
13 minutes ago, mtrainer said:

It is confusing since most folks are used to separate installers for different product versions, they went a slightly different route but here you go:

 

 

 

Nothing confusing about it at all. I think is simpler having just one installer!

Share this post


Link to post
Share on other sites

Many thanks. I looked at that but I didn't know if that was the correct version until I downloaded it and it asked if I wanted to install to V3 or V4 or both.

Share this post


Link to post
Share on other sites

Hi guys, does anyone know if this installer works also with P3D v2.5? or is mandatory to have p3d v3 or v4?

Thanks

Share this post


Link to post
Share on other sites
3 hours ago, riccardo74 said:

Hi guys, does anyone know if this installer works also with P3D v2.5? or is mandatory to have p3d v3 or v4?

Thanks

Why not check the product page from PMDG instead of asking here, where you will certainly get opinions but here is the official word: http://www.precisionmanuals.com/pages/product/P3D/ngx8900.html

Note it says v3 and v4 only.

Share this post


Link to post
Share on other sites

I checked downscc, this is the reason I asked for.

btw I didn't note this:

*Product tested with Lockheed Martin Prepar3D v3 and v4. NOT COMPATIBLE WITH PREPAR3D 2.x..

Share this post


Link to post
Share on other sites

As Dan said and as it is written on the product page "This is compatible only with Lockheed Martin's Prepar3D. (v3 and v4)"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now