captflyby

Prepar3d v4 will not run after installing PMDG 777-200LR/F

Recommended Posts

Well this is interesting.

Just purchased & installed PMDG 777-200LR/F to Prepar3d v4.  It ran fine.  Saved custom views. Saved scenario.

White trying to figure out where the PMDG options is (still can't find that one) to unlock the captain's PFD protection, I had to shut down to attend to another matter.

I came back 20 minutes later and started prepar3d.  It would not come up, but shut down. 

Rebooted computer.  Then it shows it is running in task manager, but no sim on desktop.

I go into simobjects, remove the PMDG aircraft (both) and the sim boots fine.

Does anyone have any idea why this PMDG is causing Prepar3d to crash / not function?

______________________________________________

I reinstalled / repaired the PMDG.

Same thing.

Removed the PMDG 777-200LR aircraft from simobjects then ran Prepar3d v4 again as administrator.

 

Box came up:

"Vehicle initialization has failed for PMDG 777-200LR PMDG House

You will now be placed in visualization-only mode.

OK"

 

Even though the PMDG 777-200F is still in simobjects, it does not show up under the Vehicle list.

 

__________________________________________________________________

 

I next removed both PMDG from the simobjects / airplanes folder

Ran Prepar3d

At initialization screen - no PMDG under vehicles as you would expect

While Prepar3d is running - cut/paste the two PMDG 777 airplanes back into the Simobjects/airplanes folder

Now they both show up under the vehicles list AND I selected one and it loaded fine.

_____________________________________________________________________

 

I cannot cut/paste these planes in/out of Prepar3d each time I run it.

As PMDG no longer answers calls for help, I am left with my good neighbors here at the forum.

 

I'm sure more information is needed - will supply it if I can.

 

Any help you can offer would surely be appreciated.

Richard Jeffries

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

7 hours ago, captflyby said:

Does anyone have any idea why this PMDG is causing Prepar3d to crash / not function?

Did you set the 777 as the default aircraft/flight in the sim?

Share this post


Link to post
Share on other sites
7 hours ago, captflyby said:

As PMDG no longer answers calls for help, I am left with my good neighbors here at the forum.

All calls for help can be directed via the link in Kyle's signature :laugh:

Share this post


Link to post
Share on other sites
2 hours ago, scandinavian13 said:

Did you set the 777 as the default aircraft/flight in the sim?

I had the default set to whatever it was at install.  I did however, save a scenario with the 777. I will try changing the default to another stock airplane and see what happens.

As I mentioned earlier, I did save the 777-200LR in a scenario with custom camera windows.  Could the custom cameras be a factor?  I cannot check at the moment but will report my findings.

 

Richard Jeffries

Share this post


Link to post
Share on other sites
57 minutes ago, PMDG777 said:

All calls for help can be directed via the link in Kyle's signature :laugh:

Ok, thank you.  Who is Kyle and where may I find his signature.  I appreciate your help.

 

Richard Jeffries

Share this post


Link to post
Share on other sites
16 minutes ago, captflyby said:

Ok, thank you.  Who is Kyle and where may I find his signature.  I appreciate your help.

 

Richard Jeffries

scandinavian13, the guy above my post. He's a PMDG developer and general forum master.

Share this post


Link to post
Share on other sites
1 hour ago, PMDG777 said:

scandinavian13, the guy above my post. He's a PMDG developer and general forum master.

Now the "sign your posts" rule is coming back to me.  Thanks very much.a

Sorry Kyle,  I did not intend any disrespect.

I think your 777 is a marvelous airplane.  I am retrofitting my cockpit just for this bird.

 

Richard Jeffries

Share this post


Link to post
Share on other sites
35 minutes ago, captflyby said:

Sorry Kyle,  I did not intend any disrespect.

None taken, no worries.

Were you able to solve the issue by removing the 777 from the default load scenario?

Share this post


Link to post
Share on other sites

I thing I have the same problem, since I loaded the 777 update last night everything was working find, now I cannot get prepar3d v4 to load. I get the first screen and without any error message I never get to the second screen. I did check in the task manager and the Prepar3d apps is running. I have tried to uninstalled the 777, but it seems that the delete process doesn't delete the PMDG 777 folders and the sim did not work either. So I decided to repair prepar3d and that didn't fix the problem. I didn't save any scenario's or event load the plan in the sim. Before I re-install everything, do you have any advices? 

Share this post


Link to post
Share on other sites

Pierre,

Find your dll.xml back it up or by renaming it or by moving it somewhere else. Delete it and restart P3d. Check if is working now.

Share this post


Link to post
Share on other sites
3 hours ago, scandinavian13 said:

None taken, no worries.

Were you able to solve the issue by removing the 777 from the default load scenario?

Not yet.  I plan on doing some more diagnostic on it after work, this evening.  I will keep you posted. 

 

I'm thinking it has to be something I adjusted in Prepar3d v4, following install of PMDG, because it fired right up after installing PMDG the first time.  And since I have repaired the PMDG install, and nothing was effected, I'm thinking it must have been some setting in Prepar3D v4 that is making this happen.  Just a guess for now.

 

Richard Jeffries

Share this post


Link to post
Share on other sites
3 hours ago, PierreFSX said:

I thing I have the same problem, since I loaded the 777 update last night everything was working find, now I cannot get prepar3d v4 to load. I get the first screen and without any error message I never get to the second screen. I did check in the task manager and the Prepar3d apps is running. I have tried to uninstalled the 777, but it seems that the delete process doesn't delete the PMDG 777 folders and the sim did not work either. So I decided to repair prepar3d and that didn't fix the problem. I didn't save any scenario's or event load the plan in the sim. Before I re-install everything, do you have any advices? 

I can tell you with mine, I went into the Simobjects/airplanes folder and deleted the two PMDG airplane folders.  Then Prepar3D v4 would start normally, however it gave an error message indicating it was unable to install the PMDG airplane.

With the planes in the folder, file manager shows Prepar3D v4 running in processes, but there is no visible sign of the program running at all.  Blank screens, no audio.

Are you, were you, by any chance using customer camera settings?  I was, at the time the problem started, but do not know yet, it that was a cause or contributing factor.

 

Richard Jeffries

Share this post


Link to post
Share on other sites
3 hours ago, Olympic260 said:

Pierre,

Find your dll.xml back it up or by renaming it or by moving it somewhere else. Delete it and restart P3d. Check if is working now.

Will do, and I'll let you know.

 

Richard Jeffries

Share this post


Link to post
Share on other sites

Just to put closer on this, I just re-load the PMDG 777 update and the same thing happened, P3D stop working after the first screen. I rebooted and rename the DDL.XML and restart P3D and now everything seems to work.

So again thanks.

Share this post


Link to post
Share on other sites
5 hours ago, Olympic260 said:

Pierre,

Find your dll.xml back it up or by renaming it or by moving it somewhere else. Delete it and restart P3d. Check if is working now.

Did not work.

 

Richard Jeffries

Share this post


Link to post
Share on other sites

To answer your question about the camera, no i was not using customer camera setting. I am loading all i have to a new pc i just got. I got this problem when i loaded the patch for the PMDG 777, that was the last addons i was planning to load. 

Share this post


Link to post
Share on other sites
6 hours ago, scandinavian13 said:

None taken, no worries.

Were you able to solve the issue by removing the 777 from the default load scenario?

OK, as long as I leave the default in Prepar3D v4 where is was originally - F22 I think is what it is, then all works fine.  Thank you for your assistance with this. 

I know there must still be some type of bug that does not allow PMDG to work as default when starting up, but as long as it runs, that's ok.

I am going to my other thread now.  Have problems bringing up the captain's PFD and undocking it.

Thanks again.

Share this post


Link to post
Share on other sites
4 hours ago, captflyby said:

OK, as long as I leave the default in Prepar3D v4 where is was originally - F22 I think is what it is, then all works fine.  Thank you for your assistance with this. 

I know there must still be some type of bug that does not allow PMDG to work as default when starting up, but as long as it runs, that's ok.

It's not really a bug, to be precise. There's a long narrative in the Intro Manual about it, in which we specifically warn against this. I would definitely suggest reading it.

Share this post


Link to post
Share on other sites
40 minutes ago, scandinavian13 said:

It's not really a bug, to be precise. There's a long narrative in the Intro Manual about it, in which we specifically warn against this. I would definitely suggest reading it.

Hi Kyle,

Sorry for the incorrect terminology.

I have begun the reading.

Thank you again for your help with this.  You knew right away what to do.

Share this post


Link to post
Share on other sites

Make sure that there is a dll.xml and is corrcty populated. You can check the current one with the one from the backup. It seems that the original dll.xml was corrupted somehow 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now