ChuckOman

Is MCE 2.7.35 compatible with P3D v4.1?

Recommended Posts

Just updated my Win7 P3D Pro v4 to version 4.1.  Installed MCE 2.7.35, which I think is the latest version.  MCE 2.7.35 runs fine with my FSX and P3D Pro v3.4 sims.  But with my P3D Pro v4.1, MCE connects to the simulator, but then never gets beyond "Please Wait for Your Copilot to Board". 

The v4.1 install in P3Dv4.1 appears ok; fsinsider64.dll, fsinsider.ini, and MCE.dlls folder are all there.  I've run the wizard (works normally) and tried full uninstall/reinstall, but copilot won't board v4.1.  Is MCE 2.7.35 compatible with P3Dv4.1 ? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It is, using as we speak! Reinstall, try a different plane, check if your are running all as admin...!

Share this post


Link to post
Share on other sites

Thanks for suggestions.  I've tried reinstalling; each time MCE works with FSX and P3Dv3.4, but not with P3Dv4.1.  Have run the Wizard, and also verified that both MCE and P3Dv4.1 are set to run as admin.  Tried several different stock and PMDG v4.1 airplanes (that ran MCE OK under v4.0) but after MCE launches it still gets stuck on copilot boarding phase.

Share this post


Link to post
Share on other sites

Fully compatible since about 2 weeks after P3D V4 was released.

Very likely missing <MCE dlls> folder (with 64 bit dlls. Do not copy these from the other P3D V3.4 installation). See this thread

 

 

Share this post


Link to post
Share on other sites

Hello Gerald,

 

where can I download the MCE 2.7.35? I see on the website still MCE 2.7.34, thanks

Share this post


Link to post
Share on other sites
1 hour ago, johnliem said:

Hello Gerald,

 

where can I download the MCE 2.7.35? I see on the website still MCE 2.7.34, thanks

Ignore the listed version, just download latest if you are way behind.

 

Share this post


Link to post
Share on other sites

Gerald - thanks for link to

Re my copilot not boarding problem,  I tried uninstalling MCE 2.7.35, then deleted the MCE.dlls folder in the P3Dv4.1 root.  Reinstalled MCE 2.7.35, and confirmed that a new MCE.dlls folder had been reinstalled in P3Dv4.1 root.  Relaunched MCE, but copilot still wouldn't board. 

Just to be certain, I deleted all the contents of MCE.dlls and replaced  them with contents of \Resources\Files\FSX\ MCEdllsx64 folder.  Unfortunately same result.

I recall MCE was running with my P3Dv4.0 using MCE v2.7.2.0, the first v4.0 compatible release.  By any chance was v2.7.2.0 also v4.1 compatible ? 

Can you suggest anything else to try ?

Chuck

Share this post


Link to post
Share on other sites
24 minutes ago, ChuckOman said:

Gerald - thanks for link to

Re my copilot not boarding problem,  I tried uninstalling MCE 2.7.35, then deleted the MCE.dlls folder in the P3Dv4.1 root.  Reinstalled MCE 2.7.35, and confirmed that a new MCE.dlls folder had been reinstalled in P3Dv4.1 root.  Relaunched MCE, but copilot still wouldn't board. 

Just to be certain, I deleted all the contents of MCE.dlls and replaced  them with contents of \Resources\Files\FSX\ MCEdllsx64 folder.  Unfortunately same result.

I recall MCE was running with my P3Dv4.0 using MCE v2.7.2.0, the first v4.0 compatible release.  By any chance was v2.7.2.0 also v4.1 compatible ? 

Can you suggest anything else to try ?

Chuck

2 different scenarios.

If you're getting the freeze, it's the 64 dlls that aren't where they should be.

Dlls are expected in \Prepar3D v4\MCE dlls\ folder. Make sure folder is correctly named

If It's MCE not being able to connect to P3D...

Set "prepar3D.exe" to run as administrator.

When Windows UAC is enabled, and we don't recommend disabling it, you MUST install MCE to default C:\Program Files (x86)\Multi Crew Experience\ folder.

No need to fiddle with anything else.

 

Share this post


Link to post
Share on other sites
13 hours ago, FS++ said:

Ignore the listed version, just download latest if you are way behind.

 

Thanks

Share this post


Link to post
Share on other sites
15 hours ago, FS++ said:

2 different scenarios.

If you're getting the freeze, it's the 64 dlls that aren't where they should be.

Dlls are expected in \Prepar3D v4\MCE dlls\ folder. Make sure folder is correctly named

If It's MCE not being able to connect to P3D...

Set "prepar3D.exe" to run as administrator.

When Windows UAC is enabled, and we don't recommend disabling it, you MUST install MCE to default C:\Program Files (x86)\Multi Crew Experience\ folder.

No need to fiddle with anything else.

 

Hi Gerald and Ben -

My MCE problem may not be similar to that of the other posters.  MCE isn't freezing.  When I launch MCE 2.735 it first says "detecting flight simulator" then, "trying to connect to flight simulator", then "please wait for your copilot to board..." indefinitely.  The MCE UI never appears in the sim.  After 30 seconds or so, if I click on the MCE "please wait..." dialog box, MCE quits.

My prepar3d.exe is installed in E:\Lockheed Martin\Prepar3D v4 and set to run as administrator.  (Always was).  My MCE is installed in C:\Program Files (x86)\Multi Crew Experience, the default location, and is also set to run as administrator.  MCE boards normally with my FSX (installed at top of C;) and P3Dv3.4 (installed at top of E:, alongside P3Dv4.1).  However running MCE with P3Dv4.1 the copilot never boards.

I noticed when I uninstalled MCE 2.735 that it did not remove MCE's fsinsider.dll, fsinsider.ini and MCE dlls folder in the P3Dv4 root,  and a dll-MCE.xml in appdata.  Is that normal ?

To be sure I wasn't using old MCE files, I repeated the uninstall, deleted these residual MCE files and folders.  To reset the list of .dlls, I reran P3Dv4 to regenerate an MCE-less dll.xml, then quit and reinstalled MCE 2.735.  The reinstalled MCE yet again.  The MCE v2.735  installer put versions of fsinisder.dll, fsinsider and the MCE dlls folder back in the P3Dv4.` root folder and a new dll-MCE.xml back in the appdata folder.  To be certain the MCE installer put the proper x64 dlls into the P3Dv4.1 root, as you guys suggested, I replaced the entire MCE dlls folder contents with the dlls in \Resources\Files\FSX\MCE dlls x64.  Then I launched P3Dv4 again, and MCE reappeared in appdata dll.xml, as it should.  So I think the MCE installer is putting the correct files in the correct places.  Finally, I reran the MCE wizard. 

I was optimistic when I launched MCE, but unfortunately still encountered the same problem : MCE reports that it connects to the sim, but remained stuck in "please wait..." mode indefinitely. 

Since everything seems to be where it should be, and up to date, I'm guessing my problem may be different than the one encountered by other posters.

I can't revert to P3Dv4.0, but is there an earlier version of MCE prior to 2.735 that is also P3Dv4.1 compatible that I should try reverting to ?  Anything else you can suggest trying ?

Thanks

Chuck

Share this post


Link to post
Share on other sites
4 hours ago, ChuckOman said:

Hi Gerald and Ben -

My MCE problem may not be similar to that of the other posters.  MCE isn't freezing.  When I launch MCE 2.735 it first says "detecting flight simulator" then, "trying to connect to flight simulator", then "please wait for your copilot to board..." indefinitely.  The MCE UI never appears in the sim.  After 30 seconds or so, if I click on the MCE "please wait..." dialog box, MCE quits.

My prepar3d.exe is installed in E:\Lockheed Martin\Prepar3D v4 and set to run as administrator.  (Always was).  My MCE is installed in C:\Program Files (x86)\Multi Crew Experience, the default location, and is also set to run as administrator.  MCE boards normally with my FSX (installed at top of C;) and P3Dv3.4 (installed at top of E:, alongside P3Dv4.1).  However running MCE with P3Dv4.1 the copilot never boards.

I noticed when I uninstalled MCE 2.735 that it did not remove MCE's fsinsider.dll, fsinsider.ini and MCE dlls folder in the P3Dv4 root,  and a dll-MCE.xml in appdata.  Is that normal ?

To be sure I wasn't using old MCE files, I repeated the uninstall, deleted these residual MCE files and folders.  To reset the list of .dlls, I reran P3Dv4 to regenerate an MCE-less dll.xml, then quit and reinstalled MCE 2.735.  The reinstalled MCE yet again.  The MCE v2.735  installer put versions of fsinisder.dll, fsinsider and the MCE dlls folder back in the P3Dv4.` root folder and a new dll-MCE.xml back in the appdata folder.  To be certain the MCE installer put the proper x64 dlls into the P3Dv4.1 root, as you guys suggested, I replaced the entire MCE dlls folder contents with the dlls in \Resources\Files\FSX\MCE dlls x64.  Then I launched P3Dv4 again, and MCE reappeared in appdata dll.xml, as it should.  So I think the MCE installer is putting the correct files in the correct places.  Finally, I reran the MCE wizard. 

I was optimistic when I launched MCE, but unfortunately still encountered the same problem : MCE reports that it connects to the sim, but remained stuck in "please wait..." mode indefinitely. 

Since everything seems to be where it should be, and up to date, I'm guessing my problem may be different than the one encountered by other posters.

I can't revert to P3Dv4.0, but is there an earlier version of MCE prior to 2.735 that is also P3Dv4.1 compatible that I should try reverting to ?  Anything else you can suggest trying ?

Thanks

Chuck

I suggest you open "dll.xml" for P3D V4, then add or change the loading process. Set all to manual

<ManualLoad>True</ManualLoad> except for PMDG aircraft, FSUIPC.

Initially, just load fsInsider64.dll without the others.

If it works OK, enable the others one at a time.

 

Share this post


Link to post
Share on other sites

Thanks Gerald.

Assume you mean the appdata version. 

(When my program data dll.xml gets called, it has calls only for the PMDG interface, RAASPRO and HUD; standard stuff.. so I left the program data dll.xml as is).

My appdata dll.xml is listed below and is just FSUIPC & MCE and HiFi's new 64 bit AS4 dll.

<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>FSUIPC 5</Name>
    <Disabled>False</Disabled>
    <Path>Modules\FSUIPC5.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Multi Crew Experience</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>fsInsider64.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_connect_64.dll</Path>
  </Launch.Addon>

</SimBase.Document>

I assuming the AS4 dll was the prime suspect I edited out the call (bolded above) and resaved (as utf-8 of course).  Then launched P3Dv4.1 and retested MCE.  BTW only P3Dv4.1 and MCE were running; no simconnecting apps like Chaseplane.

Unfortunately no improvement in MCE copilot boarding; disabling the AS dll made no difference.

 

Chuck

Share this post


Link to post
Share on other sites
42 minutes ago, ChuckOman said:

Gerald - was last diagnostic done ok ?  What should I try next ?

Chuck

There is a patch for ASN. Install it.

Shouldn't be an issue for it running alongside fsInsider64.dll provided it is patched to be V4.1 ready.

fsInsider64.dll is already V4.0 & V4.1 aware

Can you post a screenshot of the <MCE dlls> folder inside <Prepar3D v4> folder. With folder showing all dlls.

 

Thanks

 

 

Share this post


Link to post
Share on other sites

Thanks Gerald.

My ASN has the 6497 patch - installed just after it appeared on 10/17.

 Will email you the screenshot at support@multicrewxp.com.

 

Chuck

Share this post


Link to post
Share on other sites

i have the same problem here.

I am using P3DV4.1 and PMDG B737 NGX. I can start P3DV4.1 without MCE.

After the aircraft has loaded i open MCE and it only reaches the point where it is written "Wait for copilot to board" and then P3D freezes - MCE keeps klickable.

Also when doing it the other way round (MCE first and then P3D) it has the same behaviour - also with all other planes (default). 

i am using version 2.7.5.4 and did the things which are written above (looked in the dll.xml - changed die .dll files) but nothing worked.

does anybody know how to fix this problem? really looking forward for a workable perfect programm (also using it in xplane 11 where it workes fine) 

Share this post


Link to post
Share on other sites
1 hour ago, kalleffm said:

i have the same problem here.

I am using P3DV4.1 and PMDG B737 NGX. I can start P3DV4.1 without MCE.

After the aircraft has loaded i open MCE and it only reaches the point where it is written "Wait for copilot to board" and then P3D freezes - MCE keeps klickable.

Also when doing it the other way round (MCE first and then P3D) it has the same behaviour - also with all other planes (default). 

i am using version 2.7.5.4 and did the things which are written above (looked in the dll.xml - changed die .dll files) but nothing worked.

does anybody know how to fix this problem? really looking forward for a workable perfect programm (also using it in xplane 11 where it workes fine) 

Definitely working for many months now.

What you're reporting is typical behaviour when <MCE dlls> 64 bit dlls are missing in \Prepar3D v4\ installation folder. Do not copy dlls from FSX or P3D V3.4 installation folder.

If you have just installed P3D V4, you need to download latest MCE version here

Latest is V2.7.4.3

Please read this thread

 

Share this post


Link to post
Share on other sites

Sorry, my mistake. The Version installed is 2.7.4.3. I only have P3DV4(.1) installed here, nothing else (a complete new pc setup).

I tried removing MCE - deleting MCE DLL folder in PD4 - reinstalled but nothing changes. it stops working while P3D is starting up (after selecting aircraft and airport)

Share this post


Link to post
Share on other sites
1 hour ago, kalleffm said:

Sorry, my mistake. The Version installed is 2.7.4.3. I only have P3DV4(.1) installed here, nothing else (a complete new pc setup).

I tried removing MCE - deleting MCE DLL folder in PD4 - reinstalled but nothing changes. it stops working while P3D is starting up (after selecting aircraft and airport)

got it working by now but MCE doesnt react to my voice commands. Have gone through the training programm but at the end of the configuration, where you have to say something like "select heading one fifty" it doesnt respond to anything, nothing happens there. Any idea what this could be?

Windows voice training went well so far

Share this post


Link to post
Share on other sites
2 hours ago, kalleffm said:

got it working by now but MCE doesnt react to my voice commands. Have gone through the training programm but at the end of the configuration, where you have to say something like "select heading one fifty" it doesnt respond to anything, nothing happens there. Any idea what this could be?

Windows voice training went well so far

Very likely a case of MCE not setting the speech engine on the correct audio device.

Run the "Assign sound device tool"

Start->All Apps->Multi Crew Experience->Assign sound device.

Select correct "Audio IN" and "Audio Out", then click OK and let the wizard make automatic adjustments if required.

With the sim and MCE running, go to <About> tab in the user interface and check you have "Sound In" and "Sound Out" on the correct audio device.

Are you using a USNB headset or a conventional one.

If not USB, what audio chip do you have on your motherboard? Realtek? Creative Labs??

 

Share this post


Link to post
Share on other sites

it is a Realtek chip on my motherboard.

In the "About" tab it says "Sound output: Lautsprecher (Realtek High Defi   -> the rest is missing

Sound input: Mikrofon (Realtek High Definiti    -> then it is missing

 

but when i open AppData/Roaming/Multi Crew Experience and open the mce.ini file it looks like this:

AudioIn=

AudioOut=

they are both empty and do not show anything.

Share this post


Link to post
Share on other sites

so, i bought an USB headset from Sennheiser, pluged it in and... it doesnt work!

for testing purposes i tried out windows speech recognition where it works perfectly, also in the voice training programm everything looks good but inside MCE and opened P3D nothing happens - no commands are beeing recieved by FO... any idea now?

MCE.ini and MCE programm "about" tab show now:

AudioIn=Mikrofon (2- Sennheiser USB hea
AudioOut=Lautsprecher (Realtek High Defi

Share this post


Link to post
Share on other sites
1 hour ago, kalleffm said:

so, i bought an USB headset from Sennheiser, pluged it in and... it doesnt work!

for testing purposes i tried out windows speech recognition where it works perfectly, also in the voice training programm everything looks good but inside MCE and opened P3D nothing happens - no commands are beeing recieved by FO... any idea now?

MCE.ini and MCE programm "about" tab show now:

AudioIn=Mikrofon (2- Sennheiser USB hea
AudioOut=Lautsprecher (Realtek High Defi

You should also set the Audio Out to USB headset. 

Run the "assign sound device" tool.

Start->All Apps->Multi Crew Experience->Assign sound device.

Select Audio In and Audio Out then click OK and let the wizard make automatic adjustments.

Check <About> tab after that

 

Share this post


Link to post
Share on other sites

I selected both on the USB headset now, but still not working.

I hear the sound when pressing the green triangle and on startup when the program says "okay" but thats all. he doesnt react to my voicecommands i am giving.

As said, in windows voice recognition works perfect, also when doing the speech practice but inside MCE it doesnt work as it should.

Share this post


Link to post
Share on other sites
6 hours ago, kalleffm said:

I selected both on the USB headset now, but still not working.

I hear the sound when pressing the green triangle and on startup when the program says "okay" but thats all. he doesnt react to my voicecommands i am giving.

As said, in windows voice recognition works perfect, also when doing the speech practice but inside MCE it doesnt work as it should.

Are you hearing a continuous humming background without pressing any button?

If that's the case, temporarily disconnect your joysticks. There could be one of those "always ON" buttons detected as PTT switch down causing MCE to switch to ATC mode, where all commands for interaction with FO are suspended.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now