Jump to content
Sign in to follow this  
caleb1

FSX-SE Elevator Not Moving Whole Way

Recommended Posts

In FSX-SE, when flying a mission (maybe in Free Flight too, don't know how to really test it since it happens part way through the flight, and I usually don't do my flying in FSX (I use P3D for that)) the elevators will mess up.  Part way through the flight (it worked fine for the start of the flight) the full 100% movement of my Saitek yoke is only maybe 5-10% moment of the aircraft's elevators in the sim.

 

Does anyone have any ideas as to why this is happening and how to fix it?

 

Thanks very much.  This is very mysterious to me.

Edited by caleb1

Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites

Since you are flying in a Mission..,I'll avoid the common question...does it happen with all aircraft?  What aircraft exactly does it happen with?  No A/P on?  I've noticed this mainly with the Airbus aircraft and there are some switches to turn off killing the fly-by-wire, if that is the case.


Charlie Aron

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:

                                     

 

Share this post


Link to post
Share on other sites

No autopilot.  Happens in both the default F-18 and default 747, I would imagine many other aircraft.  The missions are the 747 test flight mission and the rocket launch guard mission.

 

Thanks

Edited by caleb1

Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites

I am also curious about the Fly by wire switch...  Is there a key command that turns it off?  Maybe I hit something by accident on the keyboard...  Would you know where the switch might be in the 747?

 

Thanks very much.


Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites
4 minutes ago, caleb1 said:

I am also curious about the Fly by wire switch...  Is there a key command that turns it off?  Maybe I hit something by accident on the keyboard...  Would you know where the switch might be in the 747?

 

Thanks very much.

No fly-by-wire in the Boeing aircraft. Are you sure your yoke is calibrated correctly?

  • Upvote 1

Charlie Aron

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:

                                     

 

Share this post


Link to post
Share on other sites

Thanks,

I have checked and it is calibrated correctly.

Any other ideas?

Thanks


Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites
27 minutes ago, caleb1 said:

Thanks,

I have checked and it is calibrated correctly.

Any other ideas?

Thanks

I'm running out of ideas.  How about your rudder and ailerons?  Do they operate fully or partially?


Charlie Aron

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:

                                     

 

Share this post


Link to post
Share on other sites
14 hours ago, charliearon said:

I'm running out of ideas.

I can understand that.  This seems very mysterious.  I might reinstall FSX-SE...

14 hours ago, charliearon said:

How about your rudder and ailerons?  Do they operate fully or partially?

The ailerons and rudder work fine.

 

Thanks


Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites
1 hour ago, caleb1 said:

I can understand that.  This seems very mysterious.  I might reinstall FSX-SE...

The ailerons and rudder work fine.

 

Thanks

Before re-installing, try Verifying the integrity. It acts like a Repair.

To verify your game files please do the following:

1. Load the Steam platform and log into your account
2. Click the Library tab in the menu at the top of the screen
3. Click the List View from the view options on the top right of the screen
4. Right click on Microsoft Flight Simulator X: Steam Edition to bring up a popup menu
5. Click on Properties from the popup menu to bring up another popup box
6. Click on Local files from the popup box menu
7. Click on Verify integrity of game cache from the Local file options
8. Wait for the progress bar to finish verifying your files. Additional files may download
9. Restart Steam
10. Restart Microsoft Flight Simulator X: Steam Edition


Charlie Aron

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:

                                     

 

Share this post


Link to post
Share on other sites

Verifying the integrity found many mussed up files and reacquired them.  That did not fix it nor did a reinstall... Crazy!

Thank you very much for your help.  I think I will use the boxed FSX until I get this fixed with FSX Steam.


Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites

Also, now it seems as if the ailerons mess up up along with the elevators.  I didn't think it was that way before...


Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites
38 minutes ago, caleb1 said:

That did not fix it nor did a reinstall... Crazy!

Have you always had this problem in FSX or is this something that's just started recently?

39 minutes ago, caleb1 said:

I think I will use the boxed FSX until I get this fixed with FSX Steam.

I'd be surprised if installing the boxed version would make any difference as this is the first time I've heard of this problem in FSX that wasn't related to the autopilot.


 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites
4 hours ago, vortex681 said:

Have you always had this problem in FSX or is this something that's just started recently?

It worked fine the first day, then not all the following days.

4 hours ago, vortex681 said:

I'd be surprised if installing the boxed version would make any difference as this is the first time I've heard of this problem in FSX that wasn't related to the autopilot.

The only reason I mentioned the boxed was because I was stating that I would fly my missions in it, instead of using FSX Steam, until I got this fixed.  I do not think that installing the boxed will have any effect on this problem in SE.

 

Thanks


Caleb Byers

PC: HP Envy 750, Intel Core i7 6700 @ 3.4 GHz (max 4.0 GHz), 24GB RAM, Nvidia GeForce GTX 745 with 4GB Memory, 2TB SSHD Windows 10 Home 64 bit.

Simulators:  Prepar3D v3.4, Prepar3D v4.5, FSX:SE, FSX:Gold Edition

Using the FSX Deluxe Edition SDK SP2 for development.

Share this post


Link to post
Share on other sites
1 hour ago, caleb1 said:

It worked fine the first day, then not all the following days.

Does your yoke work OK with P3D? Have you tried ALL of the other default aircraft (in free flight) in FSX to see the problem occurs with all of them? Did you install any add-ons into FSX after the first day (when it originally worked)?


 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Controller wearing out? If equipped with potentiometers they could be giving up.. 
When the elevator/aileron problems start to arise go to windows calibration and see if the controller is moving in full travel. 
If not, it's time for repair or new controller.


20AUG21_Avsim_Sig.png?dl=1  FS RTWR   SHRS F-111   JoinFS   Little Navmap 
 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...