johnbla

No voices in drop down menu

Recommended Posts

Posted (edited)

Hi

After downloading the demo, I click on config then voices and I do not have any voices displayed in the drop down menu. P2ATC connects to the simulator and says Simulator connected, Recognition engine installed and Grammars loaded. I have default speech set to US. The strange thing, I have VOXATC and the speech engine works fine. Any help greatly appreciated.

Thanks

John

Edited by johnbla

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi

Make sure you have the 64 bit voices as P2A will not even recognize the 32 bit voices.

 

Ken

Share this post


Link to post
Share on other sites

Yes, they are 64 bit. Even the Microsoft ones do not show up.

Share this post


Link to post
Share on other sites

P2A creates the list of voices for the drop-down boxes by querying Windows for all usable desktop voices.  There may be some problems with the voice definitions/installations on your system that prevent them from being seen.

What version of Windows do you have and is it a 64 bit version of the OS?

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Dave

I am running Windows 10, 64 bit. Like I stated previously, I am running VOXATC and that is recognizing all my voices, default and add on.

Thanks

John

Edited by johnbla

Share this post


Link to post
Share on other sites

The only thing I can think of is that some security setting or software is preventing P2A from accessing the installed voices.  When you start P2A, I queries windows for installed voices and if Windows doesn't respond that would cause there to be no voices in the drop-downs.  You should at least see the Microsoft voices that came with the Windows 10 installation unless there is an access issue.

You can try running the program as administrator by right-clicking the program icon or file and selecting "Run as administrator" from the menu.

If that doesn't do it, then check your security settings, etc. 

Share this post


Link to post
Share on other sites
Posted (edited)
On 05/04/2018 at 12:30 PM, krono said:

Hi

Make sure you have the 64 bit voices as P2A will not even recognize the 32 bit voices.

 

Ken

Strange. I recently purchased a couple of Nuance bundles, 6 voices in each, and it turned out half in each pack were 32 but (not obvious before purchase!), yet all were recognised and played in test mode in P2A.

Maybe it depends more on the make? Also I am using Win7 not Win10.

Pete

Edited by Pete Dowson

Share this post


Link to post
Share on other sites

Thanks for that information Pete, thats something I definitely did not know.

Ken

Share this post


Link to post
Share on other sites

John,

I thought of something else to try.  The problem could be due to a missing Speech component in P2A. Reinstall the program and it might fix it.

Let me know if that helps.

Dave

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now