Pete Dowson

Keyboard hotkeys don't appear to work?

Recommended Posts

I've assigned Ctrl+F1 to PTT and Ctrl+F2 to "SayIt". But neither seem to do anything. Well, not that I can see.

Should there be any feedback on these hotkeys, such that one can see it is working -- eg the PTT button lighting its green border when the key combo is pressed? Because at present I can't work out what is wrong.

On my cockpit installation I've not even got as far as getting clearance! :-(

Pete

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Pete.

That's strange.  I saw your comment on the other PTT post that the assigned key press doesn't work using the keyboard directly attached to the P2A machine. 

I just tested on my system and assigning Ctl-F1 to the PTT HotKey worked.

In order for it to work, though, I had to be connected to the SIM so the program knows the radios are available.

Dave

Share this post


Link to post
Share on other sites
Posted (edited)
32 minutes ago, Dave-Pilot2ATC said:

In order for it to work, though, I had to be connected to the SIM so the program knows the radios are available.

It was definitely connected, or at least the connected box bottom centre indicated so.  And the PTT button did illuminate with a green box when pressed with the mouse.

I’ll try other key assignments, maybe something else is stealing that one.

Are they proper Windows hotkeys, or needing focus on P2A?

Pete

 

Edited by Pete Dowson

Share this post


Link to post
Share on other sites

P2A does not need to have focus.  I just tested and the HotKey works regardless of which program on my system has the focus.

Dave

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now