tasso1988

Nvidia driver 397.93 DXGI error

Recommended Posts

Hello, have anyone experienced the following issue with the new Nvidia 397.93 driver? 

The P3D v 4.2 crashes to desktop midflight with the following message:  DXGI Error Device Removed. 

I have experienced this several times with this driver, dont have such problem in other applications or with the previous versions of Nvidia drivers. 

Specs - i7-7000k OC at 4.6 Ghz, EVGA Geforce 1080 ti SC2 (not overclocked), 16 GB RAM. 

I run 1080p resolution and use Nvidia inspector 1/2 refresh rate vsync function and fps limiter of  30,5 fps. 

 

 

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had this problem and ended up going back to earlier version of the Nvidia driver and problem resolved.

Share this post


Link to post
Share on other sites

https://www.youtube.com/watch?v=5FWAVe1km_g

HTH,

Greg

Share this post


Link to post
Share on other sites

Hi

just yesterday I had this problem. I removed the driver, cleaned shader folder and reinstalled it ( same driver). Have not tried P3d yet.

i have GTX 1080Ti

hi demar55 which driver are you using ? 

 

Thanks

Share this post


Link to post
Share on other sites

Thanks. I installed  394.93 after the DXGI issue.

Share this post


Link to post
Share on other sites

I kept getting the same error with 397.93. Even the new ones that came out today (398.11) do this unfortunately. Rolling back to any version before 397.93 fixes it.

What I find very interesting is that we are using the exact same nvidia inspector settings. "1080p resolution and use Nvidia inspector 1/2 refresh rate vsync function and fps limiter of  30,5 fps." This is precisely what I use. I'm wondering if it has to do with the 1/2 refresh rate sync.

Share this post


Link to post
Share on other sites

Hi all,

I had the same issue, same settings in nvidia inspector but my vsync is off. Maybe the limiter to 30.5 fps

Share this post


Link to post
Share on other sites
Posted (edited)

Found this post because I was having the same issue.  It’s related to the profile inspector frame rate limiter.  After extensive testing I found that the profile inspector frame limit was clashing with nvidia control panel vsync.  Once I set vsync to “off” in nv control panel I was able to use the frame rate limiter from profile inspector without issue.  Just did a 10 hour flight with no hiccups.  So to summarize, this setup gets me the smoothest experience without any crashing;

nvidia control panel - vsync off

nvidia profile inspector- 30.5 (or whatever you want)

p3d vsync - off

p3d internal frame limit - unlimited

Edited by deimos256

Share this post


Link to post
Share on other sites

Interesting. Although I have set NVIDIA control panel Vsync to "use program setting". When I turn VSync off in P3D I get nasty screen tearing. I will try the new driver with these settings.

Share this post


Link to post
Share on other sites

Tested various configurations. I do believe there is some truth to the fact that the FPS limiter is conflicting with VSync, but its not just Nvidia control panel VSync. I'm getting it with P3D Vsync as well.

I'm running on a laptop, so I can't change much with my display. I have to use VSync in P3D or else my screen tears every half second. Will probably just rollback drivers again and hope it's fixed in a future driver update.

Share this post


Link to post
Share on other sites

Well every system will probably behave slightly different.  I’ve found that in game vsync settings have never given me good results so 99% of the time I force vsync from nvidia control panel.  Give my settings a try, I’d be interested in seeing the results from other systems.  

Share this post


Link to post
Share on other sites

I did, but as I said, disabling VSync in P3D (even if its on or off in Nvidia control panel) makes things unplayable. So yes, system to system will vary, but I think you're right about the frame rate limiter being the culprit.

Share this post


Link to post
Share on other sites

I’m not too sure who develops profile inspector but I believe the latest version is a good 2 years old, so perhaps it’s time for some updating of it.  

Share this post


Link to post
Share on other sites

A download link for the latest nVidia Profile Inspector (early 2018) near the bottom of this page:

https://www.asylab.com/single-post/2018/03/23/NVIDIA-Profile-Inspector-21320

Doubtful that nVidia Control Panel and nVidia Profile Inspector are conflicting with each other... they do the same thing: Set registry flags for the nVidia drivers.  Indeed, making a setting in nVidia Profile Inspector will change the setting in nVidia Control Panel (as long as both settings are in both programs... nVidia Profile Inspector offers far more control of in-game settings).

Greg

Share this post


Link to post
Share on other sites

Thanks I’ll give this a try.  One thing I noticed is my gpu usage was consistently pegged the whole time and naturally the temps were rising.  I wonder if the latest driver has more overhead and it’s loading up the card.  I’ve seen posts suggesting to either raise or lower the voltage to get rid of the error but I haven’t messed with that yet.  

Share this post


Link to post
Share on other sites

Nearly positive I've solved it on my computer by installing the April 2018 Windows Update. It automatically installed the latest NVIDIA 398.11 with it, and haven't had the DXGI crash so far.

Share this post


Link to post
Share on other sites

How many users give feed back to Nvidia on issues, or as likely cant be bothered and roll back to the last driver, I have a do give feedback if I think it may be a driver issue but I have not had one for some time and update my drivers to latest, hence the fact Microsoft never install drivers on my system.

Share this post


Link to post
Share on other sites

Has anyone tried the latest release to see if this still happens?

Share this post


Link to post
Share on other sites

Yes, the latest Nvidia drivers gave me the same error with my GTX970 today.  I still think something with the release of P3D 4.2 is causing this on a wide scale.  People that never received the error prior to 4.2 all of a sudden starting seeing it.

  • Like 2

Share this post


Link to post
Share on other sites

Don’t forget build 1803 of windows recently came out too.  

Share this post


Link to post
Share on other sites

I have used Nvidia drivers (all ok here, never had a DXGI error) with FSX Accel, P3Dv3.4, P3Dv4.2 and Win7-64 Pro:

388.71 (and previous drivers)
390.77
391.24
391.35
387.64
397.93 (as of 5-30-2018)

Share this post


Link to post
Share on other sites
Posted (edited)

One of the Bug fix in 398.11 was the issue with the PC connected through display port 1.2, and another fixed the issue that prevented the user from selecting a bitrate 50Mbps for 4K resolution.  

PS I did not get this in windows update I use Geforce Experiece but do a custom install as you then only install the drivers if you want.

Edited by rjfry

Share this post


Link to post
Share on other sites
On 6/14/2018 at 7:23 PM, Greggy_D said:

Yes, the latest Nvidia drivers gave me the same error with my GTX970 today.  I still think something with the release of P3D 4.2 is causing this on a wide scale.  People that never received the error prior to 4.2 all of a sudden starting seeing it.

 

I agree with your statement above. I have posted this issue on P3D forums.  I do believe it is is a P3D V4.2 issue with what I described and extensively tested and posted in that thread.

 

https://prepar3d.com/forum/viewtopic.php?f=6312&t=129802

  • Upvote 1

Share this post


Link to post
Share on other sites

Why doesn't anyone update to 398.11?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now