Jump to content
Sign in to follow this  
kjjj11223344

Ortho4XP for FSX/P3D

Recommended Posts

In addition to my previous post questions.. im now running into this on the resample.exe process.. the addon folder suddenly isnt being created.. unsure why:

 

Ortho4XP_v130.exe: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath

I saw this ImageMagic mentioned in this thread but unsure what that is .. i did several tiles before this with no issues.. i guess the only changes i made were these:

create_ESP_night=True
create_ESP_summer=True
create_ESP_spring=False
create_ESP_fall=True
create_ESP_winter=True
create_ESP_hard_winter=False

EDIT: i see imagemagik is needed for these above.. looking into adding that and retesting.

And a stupid question, but this 1.30 .. can it be used as the replacement for the old 1.20b to continue to download XP11 tiles as well? (i assume its the same as the 1.30 i saw mentioned in other threads, but never saw a dL link till this thread and p3d).

Edited by theskyisthelimit

P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites

Noticing a problem on my system.. often when its doing the resample process the black window for the process will stick on doing cell process.. to the point if you hit enter it will unpause and keep going.. not sure why.. i left it doing one single tile all night and came in to find it stuck and had to hit enter a few times to keep it moving.

 

 


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites
On 10/4/2018 at 4:30 PM, theskyisthelimit said:

In addition to my previous post questions.. im now running into this on the resample.exe process.. the addon folder suddenly isnt being created.. unsure why:

 

Ortho4XP_v130.exe: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath

I saw this ImageMagic mentioned in this thread but unsure what that is .. i did several tiles before this with no issues.. i guess the only changes i made were these:

create_ESP_night=True
create_ESP_summer=True
create_ESP_spring=False
create_ESP_fall=True
create_ESP_winter=True
create_ESP_hard_winter=False

EDIT: i see imagemagik is needed for these above.. looking into adding that and retesting.

And a stupid question, but this 1.30 .. can it be used as the replacement for the old 1.20b to continue to download XP11 tiles as well? (i assume its the same as the 1.30 i saw mentioned in other threads, but never saw a dL link till this thread and p3d).

Just a foot note unless I did something wrong. Tried these with night fall and winter. Winter and fall didn't really work still looked summer. Night sort of did but is too bright. So for now I guess I'll use night environment and black marble where I can or perhaps I goofed though the inf files showed night, fall, winter etc 


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites

Hi,

Can someone help me?

I did all steps include install Python (Version 3.7) . I have Win10 64 and I guess I have to choose the "64amd" packages ( Pyproj, Numpy, Gdal, Shapely, Rtree, Pillow ). When I tried to install them I got the message "GDAL-2.3.2-cp37-cp37m-win_amd64.whl is not a supported wheel on this platform" The same with the other whl files.

 

When I use the 32whl packages, the install works but I cant open the "Ortho4XP_v130.py" When I try to open it, nothing happens.

I got also this message in the Comand line when I open the Ortho4XP_v130.exe from dist folder -> ERROR: Providers/O4_Custom_URL.py contains invalid code. The corresponding providers won't probably work.

What did I wrong?

Share this post


Link to post
Share on other sites
On 10/6/2018 at 9:33 PM, Sasa2k said:

Hi,

Can someone help me?

I did all steps include install Python (Version 3.7) . I have Win10 64 and I guess I have to choose the "64amd" packages ( Pyproj, Numpy, Gdal, Shapely, Rtree, Pillow ). When I tried to install them I got the message "GDAL-2.3.2-cp37-cp37m-win_amd64.whl is not a supported wheel on this platform" The same with the other whl files.

 

When I use the 32whl packages, the install works but I cant open the "Ortho4XP_v130.py" When I try to open it, nothing happens.

I got also this message in the Comand line when I open the Ortho4XP_v130.exe from dist folder -> ERROR: Providers/O4_Custom_URL.py contains invalid code. The corresponding providers won't probably work.

What did I wrong?

 

If you're just running the .exe, you don't need to install Python, just install the ImageMagick in the dist directory and run the .exe. That error is caused by a problem in that file. 

The syntax of O4Custom_URL.py is not correct (there's a missing code block).

One workaround would be to add a dummy statement after line 19, i.e. "True" according to the below snippet:

def custom_tms_request(tilematrix,til_x,til_y,provider):
    if provider['code']=='*****':
        True
        # do something
        # url = ******
    # etc
    return url

Note that you cannot really use the built-in Notepad in Windows and need to use something like Notepad++ to get the file formatted right. Also, spacing is important, use spaces instead of a tab.

I do not claim to have figured this out myself, I found it on the X-plane forums thread about Ortho4XP by the user Daikan but I'm not sure if I can link that forum from here.

Share this post


Link to post
Share on other sites
On 10/8/2018 at 5:07 PM, fat######79 said:

 

If you're just running the .exe, you don't need to install Python, just install the ImageMagick in the dist directory and run the .exe. That error is caused by a problem in that file. 

The syntax of O4Custom_URL.py is not correct (there's a missing code block).

One workaround would be to add a dummy statement after line 19, i.e. "True" according to the below snippet:


def custom_tms_request(tilematrix,til_x,til_y,provider):
    if provider['code']=='*****':
        True
        # do something
        # url = ******
    # etc
    return url

Note that you cannot really use the built-in Notepad in Windows and need to use something like Notepad++ to get the file formatted right. Also, spacing is important, use spaces instead of a tab.

I do not claim to have figured this out myself, I found it on the X-plane forums thread about Ortho4XP by the user Daikan but I'm not sure if I can link that forum from here.

Ahh! I also saw that I installed the Python 32bit version on my Win64 😄

Thanks for your help! Now its running 🙂

Share this post


Link to post
Share on other sites

Can anyone explain to me when i select as this example, tile +36-077 on the map 
capture3677.jpg

When it processes and downloads the bmp files.. it puts it under a folder called +30-080? 30, 80 would be somewhere in the atlantic east of jacksonville.. i dont understand where that folder name comes from?

Its a problem because i'm converting dds files from the tiles of ortho4xp to bmps and sticking their folders in here to run the esp on them, but if take this example.. isnt put in that folder, it tries to redownload everything because it doesnt see +36-077 in that 30 80 folder.. so how am I to know what naming convention and subfoldering it will do for the rest of the world?

Confused a bit 

 


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites

That's because in X-Plane tiles are grouped into folders of 10x10 degrees and the folder uses the "bottom left" tile coordinate of the group as a convention.

However, this can be configured in the .lay file of the provider i.e. for Bing (BI.lay) simply change line #3 to "imagery_dir=normal".

Edited by d41k4n

Share this post


Link to post
Share on other sites
10 hours ago, d41k4n said:

That's because in X-Plane tiles are grouped into folders of 10x10 degrees and the folder uses the "bottom left" tile coordinate of the group as a convention.

However, this can be configured in the .lay file of the provider i.e. for Bing (BI.lay) simply change line #3 to "imagery_dir=normal".

Awesome info.. thank you.. ill try changing it.. this will make conversion so much easier than trying to figure out the grid thing.


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites

Does anyone know of a fix to eliminate the "freezing/pausing" of the ESP process black command windows that seems to happen from time to time.. only fix is to click one in focus and tap the spacebar.. then the resume.. often find out hours later tiles didnt finish because they pop up then later get stuck.. im using resampleFSXSP2.exe

Edited by theskyisthelimit

P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites

Working great now (after a few hours of hacking files ; see below)  and THANKS !  this is fantastic.  Been waiting for this capability for some time now....GREAT.  

Since I had already installed Oscar's 1.30 for XP11 and therefore Python 3.6.5, I didn't want to change the Python version nor go through the re-install.  This ESP version didn't seem to like Py ver 3.6.5. on this (Win 10 x64) machine for some reason.  So, I opted for your prebuilt .exe file.  I did the edit to the .cfg  (to indicate the proper path for the resample tool) but it didn't 'take hold'. In other words, the tile built successfully but not the bgl conversion process.  Q: does the binary read the .cfg file before execution?   {FIX: since I happen to have an "F:" drive on this machine, I simply created a directory there to match the one in your original .cfg and pasted resample there, with success. Works fine now }  

Also, each instance of execution I get the error "ERROR: Providers/O4_Custom_URL.py contains invalid code. The corresponding providers won't probably work"  as reported by others, but that does not (yet) impede progress.   

Thanks for a great idea and great effort.  

JB

 


8700K OC'd 4.8 Ghz, MSI Z370 M5, 16GB Corsair 3200Mhz, ASUS RTX 2080Ti 11Gb, Samsung SSD's, GoFlight modules, Oculus Rift VR

 

 

Share this post


Link to post
Share on other sites
On 10/25/2018 at 6:27 PM, joby33y said:

Working great now (after a few hours of hacking files ; see below)  and THANKS !  this is fantastic.  Been waiting for this capability for some time now....GREAT.  

Since I had already installed Oscar's 1.30 for XP11 and therefore Python 3.6.5, I didn't want to change the Python version nor go through the re-install.  This ESP version didn't seem to like Py ver 3.6.5. on this (Win 10 x64) machine for some reason.  So, I opted for your prebuilt .exe file.  I did the edit to the .cfg  (to indicate the proper path for the resample tool) but it didn't 'take hold'. In other words, the tile built successfully but not the bgl conversion process.  Q: does the binary read the .cfg file before execution?   {FIX: since I happen to have an "F:" drive on this machine, I simply created a directory there to match the one in your original .cfg and pasted resample there, with success. Works fine now }  

Also, each instance of execution I get the error "ERROR: Providers/O4_Custom_URL.py contains invalid code. The corresponding providers won't probably work"  as reported by others, but that does not (yet) impede progress.   

Thanks for a great idea and great effort.  

JB

 

How have you dealt with the resample.exe processes getting stuck or taking focus?  Mine stick at times and you have to press a key or enter on each black window to keep them moving.. hoping there is a fix for this and/or the fact they steal focus when they run.

Also.. have you tried merging all bgls into a massive scenery directory.. or for that matter putting multiple entries in for each tile in scenery.cfg (on say 500-900GB worth)?  My merging of files i tried to do lead to huge issues (900 gig).. it created a massive slow down or stuck at 99% on reindexing.. had to kill the task of prepar3d.exe multiple times, on one run it did work but took 16 minutes vs the 2 without any ortho.. i'm thinking this is not going to work for anything large unless i had botched something.  Disappointing to say the least.

 


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites
3 hours ago, theskyisthelimit said:

How have you dealt with the resample.exe processes getting stuck or taking focus?  Mine stick at times and you have to press a key or enter on each black window to keep them moving.. hoping there is a fix for this and/or the fact they steal focus when they run.

Also.. have you tried merging all bgls into a massive scenery directory.. or for that matter putting multiple entries in for each tile in scenery.cfg (on say 500-900GB worth)?  My merging of files i tried to do lead to huge issues (900 gig).. it created a massive slow down or stuck at 99% on reindexing.. had to kill the task of prepar3d.exe multiple times, on one run it did work but took 16 minutes vs the 2 without any ortho.. i'm thinking this is not going to work for anything large unless i had botched something.  Disappointing to say the least.

 

I do indeed see a lot process windows open while resample executes, but on mine they seem to auto-close upon completion. Maybe it's a Windows process termination setting ?  Or incorrect resample.exe setting ?   Are  you using py to start Ortho or his prebuilt binary ?   in other words, I have not yet experienced them getting stuck or losing focus and I am using the binary.  However, I limit the number of tiles at any one time to say 3 or 4.  Even with the few number of tiles, resample.exe will spawn a boat load of process windows.  For a few moments, I thought the machine was stuck in a loop....

Yes, I do have one separate drive / directory dedicated to tiles, but not sure about merging 'all .bgls' into a massive directory.  I would rather keep it in smaller chunks for better manageability.  I give each tile a meaningful name (Dublin, Munich, InnsBrck) so that I can determine where it should sit in library given that I have a lot of Orbx stuff (for now) that has to co-exist.  If a given tile doesn't behave or look right, I will delete it and move on.  There is a lot of experimenting going on, but I thing this is the start of great scenery building for the future.  The tile +47-011, when paired with Orbx's LOWI airport, looks absolutely fantastic.  The trains running around the 'real' tracks is a very, very cool thing.  

This weekend, I did indeed end up with P3d (4.3) getting stuck at the opening splash screen after I exited from a flight from within an Ortho area.  Had to rebuild scenery.cfg and 'delete generated files' (you may know the drill if you use P3D v4) in order to regain control.  Not a big deal and all of the Orbx stuff comes right back upon one "verify files" command at FTXCentral - nice touch.  So, to answer your specific question, I have not yet built that much Ortho. I am up to about 10 tiles or so at varying ZL's to try and determine the optimum, acceptable visuals given the type of flying I want to do.  I did ZL16 for an international airport, and ZL14 for the 'surrounding' 8 tiles in the area - and it looks just fine from 10,000 ft on approach- and much, much smaller datasets.  But I don't trust the stability of the software (including P3D v4.3 in general)  to really invest that much time and effort - things will eventually overload or crash and suddenly you're rebuilding again.  Too easy to break stuff with a lot of install and de-installs.  Terrain and or scenery .cfg will get screwed up.  Then you need to know how to quickly rebuild and regain control, lest ye suffer from FSWS (Flight Sim Withdrawal Syndrome).  

cheers  :-)  


8700K OC'd 4.8 Ghz, MSI Z370 M5, 16GB Corsair 3200Mhz, ASUS RTX 2080Ti 11Gb, Samsung SSD's, GoFlight modules, Oculus Rift VR

 

 

Share this post


Link to post
Share on other sites
7 hours ago, joby33y said:

I do indeed see a lot process windows open while resample executes, but on mine they seem to auto-close upon completion. Maybe it's a Windows process termination setting ?  Or incorrect resample.exe setting ?   Are  you using py to start Ortho or his prebuilt binary ?   in other words, I have not yet experienced them getting stuck or losing focus and I am using the binary.  However, I limit the number of tiles at any one time to say 3 or 4.  Even with the few number of tiles, resample.exe will spawn a boat load of process windows.  For a few moments, I thought the machine was stuck in a loop....

Yes, I do have one separate drive / directory dedicated to tiles, but not sure about merging 'all .bgls' into a massive directory.  I would rather keep it in smaller chunks for better manageability.  I give each tile a meaningful name (Dublin, Munich, InnsBrck) so that I can determine where it should sit in library given that I have a lot of Orbx stuff (for now) that has to co-exist.  If a given tile doesn't behave or look right, I will delete it and move on.  There is a lot of experimenting going on, but I thing this is the start of great scenery building for the future.  The tile +47-011, when paired with Orbx's LOWI airport, looks absolutely fantastic.  The trains running around the 'real' tracks is a very, very cool thing.  

This weekend, I did indeed end up with P3d (4.3) getting stuck at the opening splash screen after I exited from a flight from within an Ortho area.  Had to rebuild scenery.cfg and 'delete generated files' (you may know the drill if you use P3D v4) in order to regain control.  Not a big deal and all of the Orbx stuff comes right back upon one "verify files" command at FTXCentral - nice touch.  So, to answer your specific question, I have not yet built that much Ortho. I am up to about 10 tiles or so at varying ZL's to try and determine the optimum, acceptable visuals given the type of flying I want to do.  I did ZL16 for an international airport, and ZL14 for the 'surrounding' 8 tiles in the area - and it looks just fine from 10,000 ft on approach- and much, much smaller datasets.  But I don't trust the stability of the software (including P3D v4.3 in general)  to really invest that much time and effort - things will eventually overload or crash and suddenly you're rebuilding again.  Too easy to break stuff with a lot of install and de-installs.  Terrain and or scenery .cfg will get screwed up.  Then you need to know how to quickly rebuild and regain control, lest ye suffer from FSWS (Flight Sim Withdrawal Syndrome).  

cheers  🙂

I'm also using the .exe window.. not sure what resample setting it would be.. the cfg file has the line pointing to resample.. i didnt think you could configure anything..  it frustrating.. set it to do 6 tiles overnight only to wake to find that it only got part way through (the very long) resample process that needs nudged on every window periodically (but not always).

I found that i was missing bgl's and redid things.. this time painstakingly adding each entry for 933GB worth (on 7200 rpm drive) main SSD is p3d and another for the OS.. old load time test was 2min30 for one location and now 3min 20sec with the ortho enabled.. i guess not horrid for 933GB.


P3D Settings (GEX, UTX, Vector, FTX, REX)

P3D v3.3 VR thread; XP11 SMP vs Default vs XE(video)

Asus Maximus X Hero Z370; 850watt Seasonic psu; SL Delid 8700k 5.1 at 1.39 and avx-1; F4-3200C15D-32GTZ @1.41 and 3400; TT 3.0 Riing Ultimate Water-64C Prime95B(24c ambient)-70c normally; Thermaltake v51 Case; Evga 1080FTW Hybrid Water; VR-Rift/Vive;

Flight-Stew | Tech-Stew

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...