J van E

P3D v4.3 frequently locks up without error message

Recommended Posts

After flying with P3D for years without any problems I suddenly get frequent lockups. Every now and then (like during my last two flights) the screens freezes (while the sound still works) and after a few seconds I am at the desktop. And all that without any warning or error message. P3D just quits.

I am using P3D v4.3 with AS, UTL, ChasePlane, ProATC, FTX Norway, Airports of Norway, PTA, SkyForce (clouds only) and the Majestic Q400. That's all I have installed too. Windows 10. GTX 1080. Latest versions and latest drivers.

Anyone knows how to figure out what's suddenly going on here...? Since there is no error message I have no clue what to look at. I had a look at the Windows logs but they mean nothing to me...

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

No app crash means no error to capture.  I would suggest reverting to an earlier graphics card driver and see if that helps.

Share this post


Link to post
6 minutes ago, TechguyMaxC said:

No app crash means no error to capture.  I would suggest reverting to an earlier graphics card driver and see if that helps.

I'll give that a shot, thanks.

Share this post


Link to post
26 minutes ago, J van E said:

After flying with P3D for years without any problems I suddenly get frequent lockups. Every now and then (like during my last two flights) the screens freezes (while the sound still works) and after a few seconds I am at the desktop. And all that without any warning or error message. P3D just quits.

I am using P3D v4.3 with AS, UTL, ChasePlane, ProATC, FTX Norway, Airports of Norway, PTA, SkyForce (clouds only) and the Majestic Q400. That's all I have installed too. Windows 10. GTX 1080. Latest versions and latest drivers.

Anyone knows how to figure out what's suddenly going on here...? Since there is no error message I have no clue what to look at. I had a look at the Windows logs but they mean nothing to me...

I get these I would say in average 1 in every 10 flights which is annoying.

How are your CPU temps? I saw a thread indicating it may be related to this.

I have a stock i7 4790k which is not overclocked and I get up to the upper 80c. I wonder if this may be the cause.

Share this post


Link to post
15 minutes ago, Shomron said:

I get these I would say in average 1 in every 10 flights which is annoying.

How are your CPU temps? I saw a thread indicating it may be related to this.

I have a stock i7 4790k which is not overclocked and I get up to the upper 80c. I wonder if this may be the cause.

I also have an i7 4790K and it is overclocked to 4.4 but temps usually peak at 60. Next time I will however keep RealTemp running in the background for the entire flight and see if it spikes at the time I get a lockup. Thanks for the tip!

Share this post


Link to post
37 minutes ago, J van E said:

I also have an i7 4790K and it is overclocked to 4.4 but temps usually peak at 60. Next time I will however keep RealTemp running in the background for the entire flight and see if it spikes at the time I get a lockup. Thanks for the tip!

Thanks keep me updated I may need a better cooling system. I can confirm it is probably not related to the GPU since these occured with the 970 before upgrading to the 1080Ti.

Edited by Shomron

Share this post


Link to post

The AVSIM CTD Guide, page 34, has some suggestions that worked for others.  The fsuipc auto-save enabled was the most common reason for the freezes.

Share this post


Link to post

I have had lockups which seem to be related to too many AIs coming to hold position at busy airports waiting for taxi path to get cleared eg at ZGGG. It gives the apphang error of p3d stopped interacting while the static sim sound keeps playing in background.

Share this post


Link to post
11 hours ago, Jim Young said:

The fsuipc auto-save enabled was the most common reason for the freezes.

I don't use fsuipc but I was thinking about using it for autosave LOL but that won't help, I guess. 😉 (It also won't work with ProATC anyway...)

6 hours ago, him225 said:

I have had lockups which seem to be related to too many AIs coming to hold position at busy airports waiting for taxi path

I only fly in Norway and there aren't any busy airports there 😉 so I don't think that's it on my PC.

BTW I did get an update for ChasePlane twice and both times P3D locked up later on during that session. But I also had lockups without a CP update. Yesterday I did notice when turning off my PC that Windows 10 (Home) had an update waiting to be installed. One first conclusion might be that P3D doesn't like updates in the background...

From now on I will make a habit of using the ProATC save option at the start of every next phase of flight. It's annoying but not as annoying as having to do a flight all over again...

Share this post


Link to post

Jeroen,

You tried the simplest one...deleting the Prepar3D,cfg and letting it build a new one.

Share this post


Link to post
22 minutes ago, Dean_EGTC said:

Jeroen,

You tried the simplest one...deleting the Prepar3D,cfg and letting it build a new one.

Of course I didn't. Because I'm stupid. 😎 It'll be the first thing I'll do before starting up P3D the next time.

Share this post


Link to post

And if all else fails, simply remove the over-clock on your CPU and just see how things go.   It's an easy thing to try.

Mark

 

Share this post


Link to post
1 hour ago, J van E said:

Of course I didn't. Because I'm stupid. 😎 It'll be the first thing I'll do before starting up P3D the next time.

Core temps normal?

Share this post


Link to post

Ah,  Overclocking I see.  Yes, set back to Default = first thing.  P3D will easily overstress any weak point in the Hardware.

Share this post


Link to post
1 hour ago, mtrainer said:

And if all else fails, simply remove the over-clock on your CPU and just see how things go.   It's an easy thing to try.

Mark

 

It never gave me any problems during the last 4 years so I can't imagine that is it. Unless my hardware is going down slowly... Besides, P3D will run like word not allowed at default CPU speeds. ;) How many people here run P3D on a non-oc'd PC...?

1 hour ago, Shomron said:

Core temps normal? 

Haven't been able to fly and test this yet. Maybe tomorrow or the coming weekend. I'll keep you posted. ;)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now