Jump to content

Sign in to follow this  
Bnash00

Windows 10 1803 or Greater No Screensaver

Recommended Posts

Hi All,

I was wondering if anyone else out there has experienced an issue with Windows 10 1803 or greater where if they have any type of joystick or game pad plugged into their computer the screensaver will not start. This issue first started with Windows 10 1803. This last weekend I nuked my entire computer and upgraded to Windows 10 1809 and installed Prepar3D v4.4 and all my addons. However I still cannot get the screensaver to start. If I unplug my joystick, rudder pedals, and gamepad the screensaver starts no problem. As soon as I plug them back in, no more screensaver. I just never starts after the allotted time period.

I have a Thrustmaster HOTAS Warthog joystick and throttle, Saitek rudder pedals and I also occasionally use an Xbox 360 game pad for PC. If any one of these devices are plugged in no screensaver. So far I have only found two solutions to this problem. 

1. Unplug all my devices after I'm done flying.

2. Roll back to Windows 10 1709. However this is no good because Windows 10 is so aggressive about automatically updating itself to the latest version. Windows 10 as a service has really worked well for Microsoft. Especially with the train wreck that is the Windows 10 1809 update. (I'm sure you all have read about the deleting of users documents, and the zip handling issues, and the Windows Media Player playback bar issue, and the Intel drivers issues ect... ect..)

Anyways I was just wondering if I'm the only guy experiencing this issue or if its more widespread.

Here is a breakdown of my hardware configuration in case it helps:

Intel Core i7 4960X @4.7GHz

Asus x79-Deluxe motherboard

16GB DDR3 RAM

Nvidia Titan X (Maxwell)

Thrustmaster HOTAS Warthog joystick and throttle

Saitek rudder pedals

xbox 360 game pad for PC

I've checked and installed the latest drivers for all devices. I have the latest chipset drivers installed for my motherboard. Any suggestions or recommendations are most welcome.

    


Benjamin Nash

P3D v5 - Asus x79-Deluxe, Corei7 4960X @4.5GHz, 16GB DDR3 1600, Nvidia GTX Titian X (Maxwell)

 

Share this post


Link to post
Share on other sites

I think you'll find this is caused by Nvidia drivers and Nvidia Control centre not getting on with win 10. I noticed this awhile back  when using Asus Game tweaker, (came with my Asus GTX 1060 GPU) a program that closes a lot of background services so that any game (or Prepar3d) runs better (I found that it does), part of the services closed include most nvidia services that run in the back ground, the Nvidia driver is not affected. To clarify, If I start Win 10 and don't run the Asus Game tweaker my screensaver and power saving/sleep mode  does not kick in, the PC screen just stays in a ready state, however, if I run the Tweaker and not play any games or run Prepar3d, or when I've completed playing them, exiting to desktop, the screensaver and power saving/sleep mode is initiated as per my settings -  because the background services have not been re-started. I gave up trying to get them all to work in harmony.

Edited by JustanotherPilot

steve southey

Share this post


Link to post
Share on other sites

Interesting. I did see a few posts over on Microsoft forums where people were saying the Nvidia "Game Overlay" that comes with Nvidia Geforce Experience application was causing the screensaver to not start. The solution was to disable the Game Overylay. I've done this but still no screen saver. 

I will try to manually stop all Nvidia services and/or programs running in the background to see if that is the cause of my problem. I will report back.

Thank you for taking time to reply to my post. 


Benjamin Nash

P3D v5 - Asus x79-Deluxe, Corei7 4960X @4.5GHz, 16GB DDR3 1600, Nvidia GTX Titian X (Maxwell)

 

Share this post


Link to post
Share on other sites

I've been having the same problem for a couple of weeks or so too.

I suspect it has something to do with the nvidia overlay as well. About the same time I started using it the problem started.

justanotherpilot: I guess the Asus Game tweaker is a card-specific utility then?

I'm just selecting the 'Sleep' setting when I walk away from the computer till I can find a solution. I've checked the "powercfg" reports and don't see any wake requests. A while ago I found that the Chrome browser would keep my computer awake if I had any paused Youtube videos open. 

Such a pain...just work, please 😕

 


Richard Chafey

 

i7-8700K @4.9GHz - 32Gb @3200  - ASUS ROG Maximus X Hero - EVGA GTX1080Ti - CH Fighterstick - CH Pro Throttle CH Rudder pedals

P3D, X-Plane 11

 

Share this post


Link to post
Share on other sites
6 hours ago, JustanotherPilot said:

Not sure, you could try it and see,  https://www.asus.com/us/site/graphics-cards/gpu-tweak-ii/

Hi All,

I manually stopped all NVIDIA windows services and killed all NVIDIA background applications. Still no screen saver. JustanotherPilot, I'm going to try the Asus Game Tweak tool, and see if it helps.

I found this thread on a Microsoft Forum: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/screensaver-and-sleep-mode-not-working-with-game/32299fb3-55ab-45b5-9813-48a9bfeda6cf

Lots of people with the same problem. Looks like a Microsoft bug to me. 

I'm not going to give up on this issue. If I have to write a powershell script to disable/enable my USB joystick, rudder pedals, and game pad, I will.


Benjamin Nash

P3D v5 - Asus x79-Deluxe, Corei7 4960X @4.5GHz, 16GB DDR3 1600, Nvidia GTX Titian X (Maxwell)

 

Share this post


Link to post
Share on other sites

Humour me, but why do you want a screensaver anyway? It was useful in the days of CRTs but doesn't really serve any purpose with an LCD screen: https://www.howtogeek.com/128644/htg-explains-why-screen-savers-are-no-longer-necessary/

Edited by vortex681

 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Hi Vortex,

I will humor you. First off I tend to be a little OCD about this kind of stuff. It really bugs me that I've had to deal with this Windows bug for over a year now. My computer runs 24x7\365. I used to be able to just walk away from my computer, after 30 minutes the screensaver would come on, when I return, I would move the mouse and my workstation would be locked. After an hour Windows would turn off the display which doesn't happen either as long as my joysticks are plugged in. Ever since this bug appeared my computer just sits logged in forever. Granted I could hit the Windows Key + L to lock my workstation and I could press the power button on my display but I don't always remember to do so and I shouldn't have to either. This basic functionality has been built into Windows since Windows 3.1. This issue might seem trivial but it bugs the cr@p out of me. So I'm going to fix it.

I've already written a very simple powershell script which disables my Thrustmaster HOTAS joystick and throttle, Saitek rudder pedals, and xbox 360 game pad. When these devices are disabled the screensaver works as expected and my display turns off as expected. I want to add some logic so whenever I start P3D my devices automatically enable, and when I close P3D they automatically disable. I'm almost finished with it.

I'm convinced this is a Microsoft bug. I'm sure it ranks very low on their list, I'm not even sure it's on their list. I also look at this problem as an opportunity to work with powershell. I want to see if I can produce a solution to work around this problem as sort of personal challenge. 

  • Like 1

Benjamin Nash

P3D v5 - Asus x79-Deluxe, Corei7 4960X @4.5GHz, 16GB DDR3 1600, Nvidia GTX Titian X (Maxwell)

 

Share this post


Link to post
Share on other sites
14 hours ago, Bnash00 said:

I'm convinced this is a Microsoft bug.

I don't use a screensaver (for the reasons listed in the link in my previous post) but I have Windows set to turn of the display after 20 minutes. That said, I've just checked both the screensaver and the "display off" setting and both function normally with my MS FFB2 joystick and my Thrustmaster wheel plugged in (Windows 10, v1809) so it doesn't appear to be a Windows bug. It also doesn't appear to be a problem with the Nvidia drivers or Nvidia Control Panel, as suggested by JustanotherPilot, unless it's related to a particular driver. Perhaps it's something specific to your joystick or its drivers?

Edited by vortex681

 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Benjamin,

Sounds like you are on a path to fix your problem. I'm just wondering if after you installed 1809, you plugged in your stick and pedal to see in the screensaver came on. If if did then you could install things one at a time to see what was causing the problem. Pretty standard troubleshooting stuff. I can appreciate being OCD about something, but so many things computer seem to defy logic. Especially since there are so many configurations out there. Everyone's computer is different. Why 24/7/365 ?

  • Like 1

Bob

i5, 16 GB ram, GTX 960, FS on SSD, Windows 10 64 bit, home built works anyway.

Share this post


Link to post
Share on other sites

Hi Bob,

I have some interesting news to report. Over the last weekend there were two updates that I installed. The first was a Windows update marked KB4471332. If you read the knowledge base article this update fixes two issues: 

1) Addresses an issue that may prevent the use of the Seek Bar in Windows Media Player when playing specific files. This issue does not affect normal playback.

2) Security updates to Windows Authentication, Microsoft Scripting Engine, Internet Explorer, Windows App Platform and Frameworks, Microsoft Graphics Component, Windows Storage and Filesystems, Windows Wireless Networking, Windows Kernel, Microsoft Edge, and Microsoft Scripting Engine.

The second update I installed came from Nvidia in the form of new drivers: (Geforce Game Ready Drivers 417.35 released 12/12/2018) The new drivers brought the following changes:

1) Provides the optimal gaming experience for the release of Deep Learning Super Sampling (DLSS) beta in Final Fantasy XV: Windows Edition

None of the above updates discuss a fix for Windows screensaver, however... After both of these updates were finished installing my screensaver started working again. My screensaver was set to go off after 1 minute because I was still in the process of putting the finishing touches on my powershell script, when all of a sudden the screensaver would go off with all my joysticks and game pad plugged in and enabled in device manager. 

I cant be sure which update fixed my issue but it has to be one of them. It was either Microsoft or Nvidia. I changed nothing on my system except for these two updates. 

If anyone else is experiencing this problem please make sure your running Windows 10 1809 and you install KB4471332 and Nvidia Driver version 417.35. Or better yet, install each update one at a time to see which update actually fixes the issue. Personally I'm afraid to mess with my system because I don't want to break it again. Let me know if one of these updates resolves your problem.

If anything changes on my end like the screensaver stops working again I will update this thread. So far my screensaver AND other power saving features have been working solidly since 12/15/2018.

 

Thank you to all who took the time to respond to this tread, I really appreciate all of your help and suggestions.

 

  


Benjamin Nash

P3D v5 - Asus x79-Deluxe, Corei7 4960X @4.5GHz, 16GB DDR3 1600, Nvidia GTX Titian X (Maxwell)

 

Share this post


Link to post
Share on other sites

Bnash00 et al,

I cannot tell you how much I agree with your reasoning on the merits of a properly working screen saver. It's also a matter of convenient privacy if you have to walk away from your PC, and other people are around.

I had the same experience, but it got fixed somehow NOT because of any OS or video driver update, but rather just because I added another extra 16Gb RAM to my motherboard. Before that the screensaver would NOT start. Why this fixed this, I do NOT know.

However since then, I installed Thrustmaster® T.Flight Rudder Pedals, and guess what - no screensaver again!!!!!

I've tried everything and can attest that disabling any/all NVidia background services, or the GeForce Experience gaming overlay does NOT help. There are a lot of people with HID-compliant game controllers that are having this problem. Check out this bunch of poor frustrated Windows 10 users...Microsoft® Answers NOTHING - Screensaver NOT Working

Really it ought to work given the following output (i.e. nothing keeping the PC awake)...

C:\WINDOWS\system32>powercfg /requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

I reckon it's Microsoft's issue all the way like something going screwy with relevant registry entries or values, that's my guess.

If anyone knows a fix or troubleshooting beyond those 'cut & paste jobs' provided by uninformed 'HB1' employees would be great.

Microsoft® have really dropped the ball since Bill Gates started worrying about the world instead of his corporation.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, GullWings said:

I reckon it's Microsoft's issue all the way like something going screwy with relevant registry entries or values, that's my guess.

If it was a Microsoft issue, why has it worked for me since well before any recent updates? See my previous post above.

Have you tried uninstalling GeForce Experience, rather than just disabling it? I don't have it installed as it causes more problems than it solves.


 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

vortex681,

The thing is I know some people say either getting rid of GEForce Experience and/or disabling the Overlay cures this for. Not for me!

The thing is, my screensaver working fine with BOTH running (I use ShadowPlay to record). This was the case up UNTIL I installed my Thrustmaster® T. Flight Rudder Pedals.

The other thing is that my joystick used to cause this issue too, up until as I said I installed an extra 16Gb RAM! So weird!

Have performed all recommended troubleshooting, but NO JOY so far.

I am also struggling to get decent FPS (>15) near busy airports/autogen areas. I know my ORBX is a killer, but FTX Global and Vector (it's turned it down for only major highways and roads, bridges only) are de rigour.

Perhaps it's my rig that is TOO GOOD :sad:, but I really don't think so...It's pretty lame actually...

Gigabyte® H370, i7-8700 (Turbo 4.2Ghz), 32Gb 2333 MHz RAM, Samsung® 850 Evo 500GB, Asus® NVidia GTX 750Ti, TrackIR 5, Pablo Diaz HD clouds, custom sky and water textures

My CFG includes...

[JOBSCHEDULER]
AffinityMask=4092

[BUFFERPOOLS]
UsePools=0

[GRAPHICS]
HIGHMEMFIX=1

D3D10=0
TEXTURE_MAX_LOAD=1024
NUM_LIGHTS=8
AIRCRAFT_SHADOWS=1
AIRCRAFT_REFLECTIONS=1
COCKPIT_HIGH_LOD=1
LANDING_LIGHTS=1
AC_SELF_SHADOW=0
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
TEXTURE_QUALITY=3
IMAGE_QUALITY=0

[DISPLAY]

UPPER_FRAMERATE_LIMIT=30
WideViewAspect=True

NOTHING SPECIAL TO SEE HERE!

I use the recommended NVI profile settings for Win10/DX9 with 1/2 VSync for my 60Hz WUXGA monitor.

I am GETTING a bit word not allowed off as I used to get great FPS in the 'old' days (pre Build 1803), so seeing all those videos with all manner of addons (like PMDG +ORBX+ASN) running at 60+ FPS is making me ILL.

All I want is to have my sweet and robust 'Boxed FSX + Acceleration' to perform under Win 10 like it used to.

It's a hard road so far.

I really dislike Win10 forced 'feature' updates. Give me back 7 Pro 64 bit please (for FSX anyway) - Oh, I forgot, it's not supported anymore, well very soon anyway.

Frustrating in the extreme!

I have a lovely fleet (hangars and hangers full of all sorts of enjoyable flyable stuff), many custom and hand-crafted XML gauges, merged VC panels, etc.

I am seeing XPlane 11 taking off so I've held off P3Dv4 with FS 2020 coming up so I am hanging fire.

Suggestions to improve my Win10 FSX experience in the meantime are most very welcome.

Gulls,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    14%
    $3,540.00 of $25,000.00 Donate Now
×
×
  • Create New...