0Artur0

Strange image effect when panning around

Recommended Posts

I recently bought a new monitor and GPU. Monitor is "AOC 68,6 cm (27,0") Q2778VQE 2560x1440 1ms VGA DVI HDMI DisplayPort" and GPU is "RTX 2080Ti". Before I had a cheap 21" 1920x1080 monitor and a GTX970. I'm also using TrackIR all the time. Before, when I had lower FPS (like 30 and below), the looking around in VC with TrackIR (panning) was a bit jerky but nothing too distracting. I expected better experience with far superior hardware I got now. But there's one major problem that's frustrating me to no end. Now, when I move my head (or simply pan around with the mouse) every time the FPS is below 60 (which is most of the time when on the ground, of course) the image becomes - it's hard to describe - jerky, kinda blurry but not really blurry... it's not stutters but it's really hard to look at it... during a head movement, it's like my eyes lose focus. When FPS is 60 the panning and looking around is smooth as silk! When FPS drops even on 55 this "effect" creeps in and it's pretty much the same at 55 or at 35 FPS. I don't know why this is happening. It's just because now I have 27" monitor which is substantially bigger than before, is it something else with my new monitor, vsync, GPU drivers,..? Anybody else had the same experience? When I got new hardware I also made a fresh install of P3D v4.4 and all the addons.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Tomaz, most stuttering, not all, is derived from the framerate being different to the refresh rate of the monitor. If your monitor's refresh rate is 60Hz and the framerate drops below that, it will gradually get worse the further apart the two values become. To alleviate this, it's helpful to lock the refresh rate of the monitor to 30Hz and then lock the framerate to 30 in the sim. The trick is to try and maintain the 30fps. If you find this is not possible, then either be a little more conservative with your in-sim settings or reduce the refresh rate and sim frames to say, perhaps, 25. Stuttering can be affected by many things, but this will often have the biggest effect on smoothness. 😊 Let everyone know how you get on. BTW, as you are now running a higher spec monitor, then your system will be using more resources to run the higher resolution. It won't be a big difference, but a difference there will be 😉

Edited by Rockliffe

Share this post


Link to post
32 minutes ago, Rockliffe said:

Hi Tomaz, most stuttering, not all, is derived from the framerate being different to the refresh rate of the monitor. If your monitor's refresh rate is 60Hz and the framerate drops below that, it will gradually get worse the further apart the two values become. To alleviate this, it's helpful to lock the refresh rate of the monitor to 30Hz and then lock the framerate to 30 in the sim. The trick is to try and maintain the 30fps. If you find this is not possible, then either be a little more conservative with your in-sim settings or reduce the refresh rate and sim frames to say, perhaps, 25. Stuttering can be affected by many things, but this will often have the biggest effect on smoothness. 😊 Let everyone know how you get on. BTW, as you are now running a higher spec monitor, then your system will be using more resources to run the higher resolution. It won't be a big difference, but a difference there will be 😉

Thank you but it's not stuttering what I'm experiencing. 

As I said, I didn't get this "effect" with my old monitor and GPU. What I'm experiencing is different. It's like image/my eyes lose focus when I'm panning/looking around. At 60FPS the movements are really fluid and smooth but when FPS falls under it starts to get progressively worse. I know very well what stutters and micro-stutters are but this is not it. Stuters are annoying but they don't make you nauseous. This, what' I'm seeing here, is. I made a video with my phone... it's not the best but the "effect" is there: https://photos.app.goo.gl/n6ExXC8iVq8UaTVo8 (try to watch it in fullscreen).

Edited by 0Artur0

Share this post


Link to post

Set refresh rate to 30hz

In P3D Set vsync checked, fps unlimited, triple buffer if necessary

If you cant maintain 30fps back settings down slightly

Share this post


Link to post

Sure, the big issue I see there is no vsync, you have screen tearing, which is a consequence of no Vsync. As Kevin and I have both suggested the same, perhaps you could try our suggestion? I would also recommend you update your GPU driver, ensuring you only install the driver and not any of the other bits under custom install.

Edited by Rockliffe
  • Like 1

Share this post


Link to post
22 minutes ago, Rockliffe said:

Sure, the big issue I see there is no vsync, you have screen tearing, which is a consequence of no Vsync. As Kevin and I have both suggested the same, perhaps you could try our suggestion? I would also recommend you update your GPU driver, ensuring you only install the driver and not any of the other bits under custom install.

The thing is I do have vsync turned on with triple buffering, FPS on unlimited. I know what tearing is but this is not exactly it... it's more like tearing 100 times a second. I did a clean driver install when I changed GPU. I even did it in safe mode. The installed components of NVIDIA driver are:

1. NVIDIA graphics driver
2. NVIDIA HD audio driver
3. NVIDIA PhysX system software
4. NVIDIA USBC Driver

I know the bigger resolution monitor will use more resources but I went from GTX970 to RTX2080Ti which is a pretty substantial step up. My CPU is 4790K@4.5GHz. I will try your suggestion to go 30Hz but my monitor doesn't have this option out of the box. I will try to force it and see what happens. But again, before, with far worse GPU I didn't experience this. Also, I'm not sure I will like 30Hz with TrackIR but I'll have to try and see about that one before making any judgments. 

Share this post


Link to post
48 minutes ago, Rockliffe said:

As Kevin and I have both suggested the same, perhaps you could try our suggestion? 

 

I tried it! The "effect" is still there. I also tried to make a video but this time the camera is not picking up the effect - when looking with my eyes the "effect" is pretty much the same as before, annoying as hell, but this time it's almost invisible to the camera - it's probably something about the refresh rate or something. 

I did notice an improvement in general sim fluidity though - when I'm not moving my head it's smooth as if it were at 60FPS and besides this "effect" I'm talking about. TrackIR also works fine so I'm keeping 30Hz. But it will be very hard for me to enjoy the sim since it's really hard to look at the screen when panning or moving my head. 

In the video, I posted before, in the first few seconds it really looks like tearing but that's probably due to video quality or something. This "effect" is best seen if you look at the white buttons on the main panel - you can't really focus on them... that's what I'm seeing in the whole image when I make a head movement. It's like motion blur without the blur.

I hope somebody also experienced this at some point and I hope even more there's a solution to this problem. I'm pretty desperate here. 

Share this post


Link to post

I have to admit, it's really difficult to see from the video the issue you are experiencing. It sounds like you did a good job on the driver install, but the only thing I would suggest, is that you uninstall the GPU driver and under custom install, during the installation process ONLY install the driver. 

It maybe a combination of factors....

 A couple of questions: When you see this issue, is your framerate hitting 30? Are you using Nvidia Inspector?  

Edited by Rockliffe

Share this post


Link to post

Interesting. In my case, it's very obvious. This lets me think it's maybe something about the monitor itself - no idea what though. 

My framerate is hitting around 40 most of the time when on the ground (and I use A LOT of addons) with PMDG 737. The only thing about framerate is that if it's not 60 then I see the effect, if it's 60 or above, it's smooth as silk, pure 60Hz experience. I don't use NVI, I didn't even change anything in NVIDIA CP yet. I will try to reinstall the driver only.

Share this post


Link to post

Any kinds of motion smoothing being used? I have nothing to base this on but could some setting be trying to interpolate frames <60?

Share this post


Link to post
3 minutes ago, kevinfirth said:

Any kinds of motion smoothing being used? I have nothing to base this on but could some setting be trying to interpolate frames <60?

Not to my knowledge. I already went through monitor settings and didn't find anything along those lines 

Share this post


Link to post

I installed the driver again, this time the driver only. Same problem. I was also using 30Hz today and the problem was actually a bit worse. When monitor was at 60Hz there was no problem at least when I was getting 60FPS+, with 30Hz the problem is always there. But there are no usual stutters. The thing is, I would take those usual stutters over this mess, every time. I'm seriously baffled nobody ever experienced this. Maybe I just didn't describe the "effect" good enough.

Share this post


Link to post
19 hours ago, 0Artur0 said:

Thank you but it's not stuttering what I'm experiencing. 

As I said, I didn't get this "effect" with my old monitor and GPU. What I'm experiencing is different. It's like image/my eyes lose focus when I'm panning/looking around. At 60FPS the movements are really fluid and smooth but when FPS falls under it starts to get progressively worse. I know very well what stutters and micro-stutters are but this is not it. Stuters are annoying but they don't make you nauseous.

Hi,

I know exactly what you are experiencing, because I have the same behavior with my 60 Hz monitor. I did not find a solution yet. My best result for now is to set P3D at locked 59 FPS, Vsync ON and triple buffering enabled. Don't know why, but at 59 it is smoother than at locked 60. Over 59 FPS, all is smooth as silk. Under 59 FPS the panning is jerky. The sim is always running smooth, it's only the panning that is become jerky under 59 FPS. It's not so bad between 55 and 59 FPS (thanks to triple buffering), but anything below 50, the panning is jerky.

Were you using FSX before with your previous monitor and now running P3D with your new hardware ?  FSX is a true full screen application (can do 1/2 refresh rate) and P3D is a false full screen application (can't do 1/2 refresh rate).

Mike

Edited by Mikelab6

Share this post


Link to post

I came to the conclusion there must be something wrong with my monitor. I will try to get it fixed or get a new one. 

Share this post


Link to post

I found another example of exactly what I'm experiencing: https://www.youtube.com/watch?v=KNTfnuBN-No

This is supposed to have something to do with response time but my monitor is at 1ms which shouldn't be a problem. 

I thought the monitor has a fault or something but now I'm not so sure anymore. I have a plan to take it to repairs but on the other hand, I don't want to waste their time chasing some non-existent fault. Maybe that's just how things are and I just didn't notice it before because I had 21" monitor and now at 27" it's more obvious? Maybe my eyes are getting older? I don't know, I'm too far down this rabbit hole I think, and I lost all sense of objectivity regarding this matter.

 

Share this post


Link to post

If using Windows 10, you could try:

  • Right-click on P3D.exe / Properties
  • Compatibility Tab
  • Check: 'Disable Fullscreen optimizations'
     

Share this post


Link to post
1 minute ago, Egbert Drenth said:

If using Windows 10, you could try:

  • Right-click on P3D.exe / Properties
  • Compatibility Tab
  • Check: 'Disable Fullscreen optimizations'
     

Already done that, same problem. 

Share this post


Link to post

It's not a response time monitor fault, because the problem is not showing over 60 FPS, so it's obviously related to synchronisation and the lack to be able to synchronizes at the 1/2 refresh rate like FSX true full screen mode was.

On ‎12‎/‎28‎/‎2018 at 12:33 AM, Mikelab6 said:

Were you using FSX before with your previous monitor and now running P3D with your new hardware ?  FSX is a true full screen application (can do 1/2 refresh rate) and P3D is a false full screen application (can't do 1/2 refresh rate).

 

Share this post


Link to post
7 hours ago, Mikelab6 said:

It's not a response time monitor fault, because the problem is not showing over 60 FPS, so it's obviously related to synchronisation and the lack to be able to synchronizes at the 1/2 refresh rate like FSX true full screen mode was.

 

Of course, it makes sense. 

I'm trying to determine if there's something wrong with the monitor or maybe that's just how things are and I just didn't notice it because I had a significantly smaller monitor before... or something.

One other option that I didn't consider so far is GPU since I replaced monitor and GPU at the same time. But I made an extensive search on the net about problems people have with RTX 2080Ti and didn't find anything remotely similar. Some of those GPUs have several issues but mine is not one of them. 

Share this post


Link to post

Also, if I lock FPS at 30, for example, the whole thing is unplayable... it becomes a stuttery and blurry mess when panning around. Since a lot of folks here locks their FPS at 30 or even lower and are saying their experience is "smooth", I mean, there must be something wrong on my side. 

Share this post


Link to post
2 hours ago, 0Artur0 said:

Also, if I lock FPS at 30, for example, the whole thing is unplayable... it becomes a stuttery and blurry mess when panning around. Since a lot of folks here locks their FPS at 30 or even lower and are saying their experience is "smooth", I mean, there must be something wrong on my side. 

Eh... there are people here who lock their FPS at 18 or 20 and say it's "smooth." They're basically trying to convince themselves that P3D isn't an unoptimized mess. The fact that you have to buy a monitor capable of doing 30hz to get a smooth experience is laughable and would be unacceptable in any other context. 

Share this post


Link to post

No, they are trying to convince themselves that their hardware can handle unrealistic image quality settings.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now