edetroit

More FS9 support by Uk2000

Recommended Posts

Gary is making two more FS9 sceneries!!!!😀 Whohooo! 👏

"News for FS2004 users, yes I know I said no more FS2004 last summer, but as Bournemouth and Belfast V2 was made using my current system which is compatible with FS2004, I decided to go back on that and Make Bournemouth compatible with FS2004. Belfast V2 will also have a FS2004 version released soon

This neatly finished off the Xtreme range, so all Xtreme Range airports work for FS2004, FSX and P3D." 

Edited by edetroit
  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Neato mosquito!

Thanks for the heads up. Something to look forward too again. 🙂

 

Share this post


Link to post
Share on other sites

That’s wonderful to hear, Ed, and a very commendable move by Gary.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now