Ray Proudfoot

Mystery of the two minute pause solved

Recommended Posts

I’ve had the PMDG737 NGX running for just two days now and have made good progress today in learning the systems all over again.

But one problem was bugging me and it’s not something I’ve come across before in P3D v4. Every two minutes the sim would pause for up to 9 seconds. Surely PMDG wouldn’t have introduced something that affected performance like that.

Then my suspicions turned to Windows 10 but that drew a blank too.

Finally the two minute thing rang a bell. Autosave in FSUIPC5. I checked the save period and it was setup for 120 seconds. Turned it off and no more pauses.

My other aircraft - Xtreme Prototypes Learjet 25 and Carenado PC-12 are far simpler so weren’t affected by autosave. But it is a useful feature.

Is there any sort of workaround to preventing these long pauses?

Finally, I have to take my hat off to the team. Fantastic aircraft to fly. I’m still on a steep learning curve and my flight from Manchester to Glasgow was pretty good with one exception. The front pax door was open for the duration!!! :sad: I won’t make that mistake again!

  • Like 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Ray you mean a workaround so you can use autosave with fsuipc and with autosaves? 

On my fsx system it saves every 2 mins and there is either no pause at all or a stutter like it misses a couple of frames which is only noticeable in a turn or when watching scenery through the windows. Don't know if this is a help but make sure you name the file yourself, just create 1 and overwrite it, use a fast drive or ssd if you can and make sure that there is zero power saving applied to the drive in question. Although it shouldn't go to sleep every 2 mins anyway. You could also try an external USB stick for the save if you can change the directory. This is almost certainly an OS issue not pmdg or p3d issue I'm sure of that. 

Share this post


Link to post
Share on other sites

Wow! That seems like a long pause.  Have you checked the sizes of the resulting autosave files?  If the filesizes have exploded then is there a way to dumb down what is being written?  I say that because recently, with FSX, I had some OOM issues in one rather small particular area.  Thought the influence was a detailed payware airport.  But checked the autosave filesizes and found it was the autosave day ######.wx weather files that had vastly increased in size.  I had recently changed weather engines.  When flying in that area now I revert back to my previous weather engine.

Edited by fppilot

Share this post


Link to post
Share on other sites

Hi Russell,

I can’t imagine there are going to be big differences in performance between FSX and P3D. I’m just going with the default name FSUIPC5 generates. Can’t see the name being an issue.

And it’s saving to a fast M.2 SSD so saving to anything else would take even longer.

Just seen Frank’s post so I’ll check the size of the weather files. System is off now until tomorrow. I’m using Active Sky for P3D.

I’ll have a look on Pete Dowson’s forum too given it’s his routine. Most unusual.

Thanks for your replies.

Share this post


Link to post
Share on other sites

Very common, and would return tons of hits on a search.

Given your other thread, I don't think it's too surprising that we often point to the tool as a potential cause of oddities. It's a GREAT tool in the sense that you can do a lot of stuff with it, and to a very deep level in the sim.

The bad part of that is that the power it has doesn't come with a lot of the protections for the average user to protect themselves from...well...themselves.

  • Upvote 1

Share this post


Link to post
Share on other sites

Ray, mine has been turned off from the beginning and I still have the 9 second pauses.  I always thought it was scenery landing.  But I double and triple checked and FSUIPC autosave is off.  YET, and this is odd, if I look in the saved scenarios screen it always shows one saved by FSUIPC.

Share this post


Link to post
Share on other sites

I had the same problem with my own software's autosave functionality. I excluded the My Documents folders and the P3D/FSX folders and processes from Windows Defender and it went away. This is absolutely an anti-virus issue.

Cheers!

 

Share this post


Link to post
Share on other sites
7 hours ago, Jack_Sawyer said:

Ray, mine has been turned off from the beginning and I still have the 9 second pauses.  I always thought it was scenery landing.  But I double and triple checked and FSUIPC autosave is off.  YET, and this is odd, if I look in the saved scenarios screen it always shows one saved by FSUIPC.

Have you posted about this on Pete's forum?

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Ray Proudfoot said:

Have you posted about this on Pete's forum?

I wouldn't dare, after what he said, it was, well I can PM you if you'd like.  Something I'd never say in polite company.

Share this post


Link to post
Share on other sites
6 minutes ago, Jack_Sawyer said:

I wouldn't dare, after what he said, it was, well I can PM you if you'd like.  Something I'd never say in polite company.

Jack,

I've known Pete for over 20 years and I know he can be to the point but is rarely rude.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now