Recommended Posts

Yesterday my P3D installation messed up in the way it is stuck in very low FPS, we are talking about as low as 0.6 frames per second. No matter what I have done to remedy the issue it is stuck in crappy frames and I've tried everything. It lags on the ground but as soon as I pause the sim my fps returns to normal. It also lags as soon as I take off and start flying.

This started after I installed the FSLabs A319 latest version for P3D v4, I was doing preflight when all of the sudden my framerate dropped to 3-4. I tried to wait it out but then it kept going, then I restarted my sim but it still lagged now it was down between 1-2 frames now. With this framerate it is unplayable.

I have done some experiments so far and I have noticed a few things.

- When AI traffic especially airport ground vehicles is turned off then the framerate returns to normal on the ground but when airborne it lags down to 1 frame per second. By pausing the sim it returns to normal, but as soon as its unpaused then it no longer works.

- Complex aircraft such as the PMDG 747 loads fine all systems initialize properly, however as soon as I switch out to the external view the sim freezes then becomes unresponsive. Once it does become unresponsive again then it down to 1 frame per second.


The sim is currently unflyable at this state, I have deleted the p3d.cfg file and it helped but as soon as I change ANY of the traffic settings it lags down again. The only way to fly the sim is with ALL AI traffic off, so I thought it may have been a few addons I have installed.

One of them is the A_A Sceneries Suvarnabhumi Intl Airport, sadly this is not P4D compatible yet and stupid me decided to install that & the AI traffic installer that comes with it. The AI installer ended up adding a bunch of planes and changing the AI flight plans themselves. So the first thing I did was uninstall the scenery (since it kept crashing) and the AI traffic manager that it came with.

I also noticed I had AI FSLights Reborn, uninstalled that but to no avail. Then I thought the ground vehicles were corrupted so then what I did was uninstall the ones I had from REX Worldwide Airports HD and restore the default ones I had before, but still nothing.

Then while the sim was lagging I was monitoring task manager and I noticed both my CPU is down below 20% and my GPU usage is almost 0%.

So then I went through the regular troubleshooting steps for P3D, Here is what I have tried so far:

- Deleting the generated files such as Prepar3D.cfg, cameras.cfg, and shader caches (Didnt help)
- Deleting/disabling all addons including LSH MD-80, PMDG aircrafts, AS P4D, ASCA, and EZDok. (Didnt help)
- Repairing then reinstalling both the client & content from their installers. (Didnt help)
- Reinstalling P3D completely (Didnt help)
- Repairing all microsoft redistributables (Didnt help)
- Updating my graphics driver to latest versions (Didnt help)
- Running a AV scan with norton (Didnt help)


I am not sure if maybe I got a virus that is interfering with P3D, if I had to guess it must have come from the FSL A319 since I never had any problems with the sim until now.

Here are my specs, it's an MSI gaming laptop I have never had any issue playing games. I have Arma 3 and X-Plane 11 installed on it and they work fine, its only P3D that has this issue.

Hardware:
- NVIDIA GTX 1070 with 8 GB of VRAM
- Intel i7-7700 @ 2.6 GHZ (overclocked by default to 3.4 GHZ)
- SSD 125 GB
- HDD 1 TB, 7000 RPM (this is where P3D is installed since I can't fit it into the C drive)

Software:
- Prepar3D v4.4
- Active Sky for P3D v4
- EZDOK P4D beta (uninstalled)
- PTA for P3D v4
- FS AI Lights Reborn (uninstalled)
- Leonardo Maddog MD-82 & MD-83/88
- PMDG 777-200LR/300ER
- PMDG 747-400/800
- FS2Crew for boththe 747 & MD-80
- TFDI 717
- FSLabs A320/A319 (Uninstalled)

Addon Scenery:
- Imagine Sim KATL (P4D)
- Flightbeam KSFO (P4D)
- Flightbeam KDEN (P4D)
- LatinVFR KRSW (P4D)
- A_A Sceneries VHHH (P4D)
- Kansai Airport (P4D)

I have also tried regenerating the scenery.cfg but again it still lags.

If this is malware, can anyone recommend the best AV to remove it? 

I don;t know what to do I have tried EVERYTHING in the book, I will give more information if requested if that will help with this issue.

Please help, PLEASE its been stressing me out the past day and nothing I have done is helping.

Edited by deltapilot96
Typo

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Is there any way for you to check the vid cards temp, 2) clean your case 3) the most likely culprit is o/c cpu or memory.

Share this post


Link to post
2 minutes ago, FPStewy said:

Is there any way for you to check the vid cards temp, 2) clean your case 3) the most likely culprit is o/c cpu or memory.

I have been using the same factory setting CPU & GPU clock, and my case is clean.

I have been told to use Driver Booster to try and update ALL drives to the latest version & to do a complete reinstall not just uninstalling from the programs menu.

Share this post


Link to post

If it’s a laptop it sounds like it could be a power management issue, I’ve had that on mine occasionally. 

Is it definitely clocking 3.4GHZ when P3D is running? Use CPU-Z to check. Also, download intel extreme tuning tool and check that whilst P3D is running - check power limit or thermal limit throttling isn’t hitting “Yes”

Share this post


Link to post

Try removing things 1 by 1.

I ended up removing EZDOK and have been using the default cameras which work well.

 

Cheers

bs

Share this post


Link to post

Super low frame rates in conjunction with low CPU/GPU utilization might mean you are out of physical memory and are using virtual memory that is paging to disk.  What else is running on the computer?  Is it possible your antivirus or another utility is running in the background?

You mention a possible nexus to traffic...are you using a traffic add-on of any kind?

With a 7700 (non-K), and default turbo boost, it is VERY unlikely you are anywhere near 3.4GHz when running P3D...the factory turbo only goes to its rated speed with a single core loaded up...P3D will generally load up all four cores, sometime heavily, and especially so on a slower CPU. 

Regards

  • Like 1

Share this post


Link to post

Ok so I just tried X-Plane and I noticed it said the sound system was not working properly, do you think that could have anything to do with it?

Share this post


Link to post
15 hours ago, deltapilot96 said:

Ok so I just tried X-Plane and I noticed it said the sound system was not working properly, do you think that could have anything to do with it?

It could.  Or not. 

Sounds like a driver reinstall for the sound device might be in order...and if that doesn't work, remove the device in Windows control panel, and then let Windows rediscover the device and reinstall the driver.

Regards

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now