Jump to content

Sign in to follow this  
mattf98

Trouble with speech recognition

Recommended Posts

For some reason I am having trouble P2A not recognizing my voice. When I am in the grammar help window it works perfectly fine; however, when I try to do it normally it doesn't catch anything.

Share this post


Link to post
Share on other sites

Since it's working with grammar Helper, the microphone setup must be correct.

In order for it to work via the radio, you must have all the following:

  • Connected to SIM, including valid Internet Connection
  • Power Indicator at bottom left must be Green
  • Radio tuned to a valid ATC Controller Frequency like Ground or Tower.  
  • Proper Call Sign set - The default of Beech N431VB is a good one to try

You also will want to be sure the PTT button is working or use the on-screen PTT button for testing.

Dave

 

 

Share this post


Link to post
Share on other sites

I have done all of those and even changed my call sign to that one to see if it was just the call sign. Same thing happens where the grammar help will hear it just fine, but the normal ATC does not. I do sometimes get the notification that ATC heard me correctly with the sound notification, but nothing goes in the text box and ATC does not respond.

Share this post


Link to post
Share on other sites

Have you tried bringing up the SayIt window, find a phrase that is valid for the tuned controller, and then say that phrase?

Or just say "Say Altimeter".  All controllers can recognize that one.

 

Share this post


Link to post
Share on other sites

I have similar problem.  Pilot2atc clips my speech into the mic, catching only part of words.  This does not happen with the microsoft grammar program or other computer programs requiring mic input.  Any suggestions where to check for the problem?  It's almost like a squelch setting where the voice is clipped unless speaking each syllable with high volume.  Normal speech isn't recognized very well.  I've tried 3 different mics.

Share this post


Link to post
Share on other sites

I'm interested to see the responses to this question. I've noticed that more and more apps have access to the microphone and potentially could interfere with P2ATC's use of the mic. No one so far has said which sim they are using, but P3d4 definitely has access to the mic, as do some add-ons. 3rd party sound cards tend to mess up voice recognition also.

You already tried 3 mics, but generally speaking a wired analog mic is the best, followed by a wired USB mic and lastly a wireless mic. MS recommends not to use a wireless mic for voice recognition.

You should also try  as a test, temporarily turning on  the OS's voice recognition. Then calibrate the microphone and try dictating something in Notepad. 


Jay Bloomfield

Share this post


Link to post
Share on other sites

If the clipping is occurring at the beginning or ending of a phrase, then likely you are starting to speak too soon after pressing the PTT button or you are releasing the PTT button a little too early.

If you go to the Grammar Help screen and practice saying some of the phrases, you can press the Replay button and listen to what P2A is hearing.  That should help determine how to prevent the clipping, especially if it is related to the PTT button.

And yes, there are some programs that "steal" the mic.  Lately several users have had to remove a program called Sonic Studio to get their mic to work properly.

Another culprit is not having the latest driver for the microphone.  But these last two tend to make the mic inoperative rather than poor quality.  The Replay button will again help you hear what P2A is hearing.

Dave

 

Share this post


Link to post
Share on other sites

Thanks Dave,

The clipping of words occurs even after appropriate pauses before or after speaking.  Of course, I trained in pilot2atc with the grammar function extensively and used the listen feature. The clipping occurred during that training as well.  It did not occur, however, when using the windows speech recognition training feature outside of pilot2atc.  I haven't seen clear instructions how to find and isolate mic stealing programs, but will stooge around for a solution.  Fyi, I am using X-plane.  Thanks again.

Share this post


Link to post
Share on other sites

Are you using the most recent Win 10 build (1903)?  With the last few OS builds you can see what apps have access to the microphone:

http://maxedtech.com/fix-microphone-not-working-in-windows-10-1803/

Build 1903 also displays a microphone icon in the taskbar area when an app accesses the microphone.

You didn't say how the mic is connected. If it's USB it could be either a hardware conflict or a power issue. 


Jay Bloomfield

Share this post


Link to post
Share on other sites
Posted (edited)

Jabloomf1230,

  Thanks for your note.  My mike/headset connects via cable to the earphone/mic jack on the computer.  I am running X-plane.

   I haven't found the build history, so unable to verify build 1903.  Windows update shows Windows 10 Pro ver. 1809 installed 1/19/2019.  

  With helpful suggestions on this thread, I was able to remove some programs' access to the mike function.  The "clipping" of words has improved, I sense, although there remains a noticeable difference with the pilot2atc processing of speech versus the native Windows speech recognition without pilot2atc running.  

  It's a new program for me, so I'm hopeful I can acquire the skill to maximize its utility.  Thanks again.

Edited by pleader
Describe headset connection mode and flt sim used.

Share this post


Link to post
Share on other sites
8 hours ago, Dave-Pilot2ATC said:

Make sure Windows speech recognition is turned off when you run Pilot2ATC.

Dave

Yeah, that's why my recommendation was to turn it on temporarily just to test.


Jay Bloomfield

Share this post


Link to post
Share on other sites

  I would be interested to see if anyone else experiences the chopping or clipping of words in pilot2atc and their solution.  Maybe I have a mic adjustment set incorrectly in the Windows system.  I have tried all the suggestions, above, and the P2A instructional pdf without much positive affect: turned off other speech programs, all settings in P2A comply with operating instructions, trained extensively in the Windows speech program (without hearing the word clipping), and trained and listened to replay in pilot2atc where the clipping is noticeable and, of course, the program misinterprets my spoken words.  It's as though there is a squelch setting that's set too high, cutting off bits and pieces of spoken words, if there is such a mic setting either in Windows or pilot2atc.  I do recall a boost adjustment to a high setting in the Windows mic setup.  Again, I have a wired headset connection and use X-plane, with Windows build 1803, 64bit.  

  I have considered buying a pc converter hard wired to computer for my Zulu 3 aviation headset, but doubt it's a headset problem given that my speech is recorded cleanly using a computer headset with the Windows speech recognition, the Com1 communication training CDs for general aviation pilots, and speech to dictation in Windows.  Seems like a wonderful program, just wanting to have some success with it.

Share this post


Link to post
Share on other sites
Posted (edited)

It is possible to have the Windows Microphone Gain setting so high that it results in distortion.  This would be noticeable in the Windows Sound Settings on the "Listen" tab.  From the Settings-Sound screen, select Sound Control Panel on the right side and then select the microphone device and press Properties.

The Microphone Properties has the Levels adjustment and on a separate tab, the Listen tab, you can check the listen to this device option.  Then go back to the Levels tab and make adjustments until you get a nice clear sound without distortion or echo/feedback.  I have my Boost set to +10dB and volume set to 90%, but it will vary depending on your mic.

Also, while you're on the Sound tab, check the Communications tab and be sure the Do Nothing option is checked.  

Dave

Edited by Dave-Pilot2ATC

Share this post


Link to post
Share on other sites

I had a hard time to find the right setting for speech recognition, not that much with Pilot2ATC (altough I had to repeat 2-3 times some of the commands), but more with VoiceAttack.

I recently discovered that I have to have a very low mic volume to have the best experience. My mic volume is currently set to 80% with 0 dB gain (note that I have a headset microphone). When I test the microphone I have only one green bar, and they barely move when I speak. However I have 99.9% success with this setting.

Also, on Win10, ensure that Windows does not auto correct the volume.

Hope this helps.

Fabrice


Fabrice Lambert

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...