Jump to content

BiologicalNanobot

Does Just Flight DC-10 work on Prepar3D v5?

Recommended Posts

3 hours ago, R Smith said:

Got this installed today looks brilliant, got a couple of small things though, when i turn the range and mode knobs on the ND it also moves the heading and course settings too.

Also turning up the center pedestal lights is making the night lighting for the lettering on the FMC from the original texture to overlap the new ones at the same time.

Is this normal as its a work in progress or have i got something wrong?

Normal-ish.  I mentioned in my update that the FMC backlighting is a known issue.  The fix for it currently means unpacking and repacking the entire CLS gauge CAB file, which takes a fair bit of work.  I'm trying to find a more elegant solution.  As for the mode and range knobs, my initial testing revealed that the animation for those knobs in the VC is tied to their original function of course and heading bugs for the HSI.  So the revised gauge can be set to either update those (with LNAV enabled, it's of little consequence) and have the knobs turn, or fix it so the course/heading remain the same but the knobs do not animate.

Share this post


Link to post
53 minutes ago, MammyJammy said:

Normal-ish.  I mentioned in my update that the FMC backlighting is a known issue.  The fix for it currently means unpacking and repacking the entire CLS gauge CAB file, which takes a fair bit of work.  I'm trying to find a more elegant solution.  As for the mode and range knobs, my initial testing revealed that the animation for those knobs in the VC is tied to their original function of course and heading bugs for the HSI.  So the revised gauge can be set to either update those (with LNAV enabled, it's of little consequence) and have the knobs turn, or fix it so the course/heading remain the same but the knobs do not animate.

Ah ok, missed the thing about the back lighting and as you said about he knobs it's not a major issue, just done a flight with the set up, works and look great!


Richard Smith

Share this post


Link to post

Hello everyone,

This is just an announcement. I don't want to hijack this thread so please don't comment on this message.

I just want to let everybody know that I have made a UPS repaint of the CLS DC10 now available in the Avsim Library.

My next project is the  Western Global CLS DC10 so stay tuned.

If you have any comments or questions you can either pm me or use my email address wich is included in the readme.txt file.

Enjoy.

Edited by celin101
  • Like 1
  • Upvote 1

Cees van der Linden

Share this post


Link to post
1 hour ago, celin101 said:

Hello everyone,

This is just an announcement. I don't want to hijack this thread so please don't comment on this message.

I just want to let everybody know that I have made a UPS repaint of the CLS DC10 now available in the Avsim Library.

My next project is the  Western Global CLS DC10 so stay tuned.

If you have any comments or questions you can either pm me or use my email address wich is included in the readme.txt file.

Enjoy.

Awesome thanks,  I'll download it today, any chance of doing a DHL livery?


Richard Smith

Share this post


Link to post

Thanks @MammyJammy for this update. Unfortunately I still can not make the sound and the panel states work with FSUIPC installed via the addon.xml method. Regardless I am enjoying this aircraft. I wish I could do a manual start but I have not been suscessful.

Great work. Thank you.

Share this post


Link to post
14 minutes ago, Samaritano said:

Thanks @MammyJammy for this update. Unfortunately I still can not make the sound and the panel states work with FSUIPC installed via the addon.xml method. Regardless I am enjoying this aircraft. I wish I could do a manual start but I have not been suscessful.

Great work. Thank you.

I also have FSUIPC installed via the add-on.xml method, however the FSUIPC6.dll and FSUIPC6.ini files are still placed in the /Modules folder inside the P3D root.  Where exactly on your PC are those files?  I'll dig into the FSUIPC documentation, but I believe the three .lua files need to be placed in the same directory as the DLL and ini files.

Share this post


Link to post
35 minutes ago, MammyJammy said:

I also have FSUIPC installed via the add-on.xml method, however the FSUIPC6.dll and FSUIPC6.ini files are still placed in the /Modules folder inside the P3D root.  Where exactly on your PC are those files?  I'll dig into the FSUIPC documentation, but I believe the three .lua files need to be placed in the same directory as the DLL and ini files.

Went I installed FSUIPC6 it defaulted to the Prepar3d v5 Add-ons folder and the FSUIPC6.dll and FSUIPC6.ini files reside inside the FSUIPC6 folder. I do have the three LUA files placed inside that folder but unfortunately I don't get any panel sounds or panel states.

I went ahead and did a cut and paste of 2 FSUIPC (key and dll) files into my main P3D moldules folder along with the 3 LUA files. I'm about to test it now.

Also when I press CTRL-SHIFT F12 it brings up the GSX menu. Is that a possible duplication of your assign panel state key combination and GSX?

Share this post


Link to post
1 hour ago, Samaritano said:

Went I installed FSUIPC6 it defaulted to the Prepar3d v5 Add-ons folder and the FSUIPC6.dll and FSUIPC6.ini files reside inside the FSUIPC6 folder. I do have the three LUA files placed inside that folder but unfortunately I don't get any panel sounds or panel states.

Hmm.  If you open the add-on.xml for FSUIPC, what does it say is the path to the DLL?  It is the <path> element inside the <addon.component> that points to FSUIPC.DLL.  Whatever folder is listed on the path, try putting the Lua files in the same directory.

Just double-checking:  You did add the [auto] section to your FSUIPC.ini file as described in the doc?

Also, if you open the FSUIPC6.log file, there will be a line near the top that reads something like "Reading options from "D:\p3dv5\Modules\FSUIPC6.ini".  This is the config file that should contain the [auto] section and where the .Lua files should reside.

As for the Ctrl-Shift-F12, I can change that easily.  Any requests for non-conflicting key combo?

Share this post


Link to post

Hi @MammyJammy congratulations, this is a brilliant piece of work and I can't wait to try your guide. I have a couple of questions though:

I'm still using FSUIPC 5, I believe it has the required functionality or do you think version 6 is mandatory?

The Ctrl+Shift+F12 assignment is used by GSX, is there a way to change the panel states to Ctrl+Shift+F10?

Thanks and regards

Share this post


Link to post
13 hours ago, GentleGroove said:

I'm still using FSUIPC 5, I believe it has the required functionality or do you think version 6 is mandatory?

You may be able to use FSUIPC5, but I have done zero testing with it.  I'm also unsure if there have been any material changes to the offsets, event controls, or Lua library with version 5 vs. 6.

13 hours ago, GentleGroove said:

The Ctrl+Shift+F12 assignment is used by GSX, is there a way to change the panel states to Ctrl+Shift+F10

I must have changed mine in GSX to just Ctrl-F12.  I can make it any key combo that works for the crowd.  Any other suggestions beyond Ctrl-Shift-F10?

Share this post


Link to post
On 2/3/2021 at 5:29 PM, MammyJammy said:

You may be able to use FSUIPC5, but I have done zero testing with it.  I'm also unsure if there have been any material changes to the offsets, event controls, or Lua library with version 5 vs. 6.

I must have changed mine in GSX to just Ctrl-F12.  I can make it any key combo that works for the crowd.  Any other suggestions beyond Ctrl-Shift-F10?

The current key binding -- CTRL+Shift+F12 works fine for me.

GSX is just CTRL+F12 so it all works, no conflicts.

@R Smith are you using a non-default GSX binding?  Mine is CTRL+F12 and I don't think I ever changed it.  Maybe I did.  I can't remember.


Rhett

i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post


Link to post
28 minutes ago, Mace said:

The current key binding -- CTRL+Shift+F12 works fine for me.

GSX is just CTRL+F12 so it all works, no conflicts.

@R Smith are you using a non-default GSX binding?  Mine is CTRL+F12 and I don't think I ever changed it.  Maybe I did.  I can't remember.

I'm using ctrl f12 for gsx also, I suggested he uses ctrl  f 9 as I don't know  of any other program using it.

Edited by R Smith

Richard Smith

Share this post


Link to post
On 2/3/2021 at 11:29 PM, MammyJammy said:

You may be able to use FSUIPC5, but I have done zero testing with it.  I'm also unsure if there have been any material changes to the offsets, event controls, or Lua library with version 5 vs. 6.

Thanks. I'll try it with FSUIPC 5 and then give some feedback if it works or not.

On 2/3/2021 at 11:29 PM, MammyJammy said:

I must have changed mine in GSX to just Ctrl-F12.  I can make it any key combo that works for the crowd.  Any other suggestions beyond Ctrl-Shift-F10?

Apparently not you. From what I've read, it looks like some people have the GSX binding with "Shift" and others not, it appears to have been changed by the developer at some point. Anyway, if the GSX assignment can be changed, that is excellent.

I can suggest also Ctrl+F10 for your binding, that way some folks will have:

Ctrl+F10 - DC-10 panel states

Ctrl+F11 - Active Sky

Ctrl+F12 - GSX

Cheers 🙂

Edited by GentleGroove
Typo

Share this post


Link to post

I'd really prefer CTRL+F12 and CTRL+Shift+F12.  That way everything is on the far right and I don't have to move my hand much.  I'm getting a bit lazy I guess.

I've never used Ctrl+F11 with ActiveSky after years of use, that's a new one on me.  I'll have to see what that does.

-- --

As for the VNAV with the ISG gauges in P3Dv5...I did some testing this weekend and it is definitely not performing as it did in P3Dv4.x.  I don't know what the reason for that is, and I haven't tested the ISG with another airplane, but I know I'm having all sorts of weird behavior with VNAV and the ISG in v5.  It's possible I could "fool" the ISG VNAV into working by careful placement of waypoints with custom-set altitudes stepping up or down, but that's not really feasible.

One other note, the "LNAV" button which has been placed in the AP area with this mod, doesn't seem to work for me.  I had to resort to using my existing LNAV popup.  It's possible the LNAV button calls the lua script but I don't know for sure.  If it does, I think the script is loaded, but don't know how to determine this, other than its presence inside the FSUIPC6.ini file.


Rhett

i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,435.00 of $25,000.00 Donate Now
×
×
  • Create New...