Sign in to follow this  
Taildragger

Error: not enough memory...?!?

Recommended Posts

Today I fooled around a bit with the various settings in FS X. Everything looked fine. I settled for some high, medium and low settings, nothing extraordinary. Traffic is at the Medium low option (which is quite low...!), Clouds are one notch higher than the lowest option, Scenery isn't too high either, well, nothing outrageous.But since changing these settings I get an error and FS X locks up! After a few hours of testing I suddenly got a usefull error (instead of just a lock up):http://i14.tinypic.com/44i36zr.jpgBut... I've got 2 Gb of ram and a 8800GTX... Shouldn't that be enough to play with everything high?!? (Let's forget about fps there... ;) ). I mean, how much more memory does an average computer have?I use Vista Home Premium 32 bits. Is there some sort of setting for virtual memory I should change...? My partition with the OS has 13 Gb free and my datadisk even 200 Gb...!When SP1 is released and let alone the DX10 patch I want to use a lot higher settings than I do know!!!EDIT:Here asre my settings. http://i14.tinypic.com/2vdqi42.jpghttp://i13.tinypic.com/48dt79f.jpghttp://i19.tinypic.com/4i6qpm1.jpghttp://i13.tinypic.com/2cxt6a8.jpghttp://i18.tinypic.com/2zznas7.jpgApart from the scenery objects nothing too bad. I had those scenery objects this dense before: I mainly only turned the traffic up higher. I really can't imagine a brand new computer with 2 Gb ram and a 8800GTX shouldn't be able to handle this...! As I said, if SP1 is released I really hope to set some options even higher...!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Make sure to remove the BufferPools section from your fsx.cfg (if you've added it).You could also check if your pagefile is alright.Your settings look alright even though you could optimize it further.Traffic is a HUGE hit on fps and you could probably set your water on low 2x without a big or any fps hit.What kind of cpu do you have?FS is way more cpu bound then anything else.

Share this post


Link to post
Share on other sites

It appears many of us are receiving this error. I recently responded to another individual having the same problem with the following:"I'd like to throw in my 2 cents worth since I had the same issue. FSX worked great in XP but I received the out of memory error about 10-15 minutes after starting the sim after I installed VISTA. The graphics would blur and hitting Alt/Tab I would find the FSX error msg stating I ran out of memory and FSX must close and suggested I lower my FSX settings. I did a lot of research on this and I have come to the conclusion that the problem is not Vista or FSX but the 8800 video card drivers. I have a pretty powerful system with Duo2 core processors E6800X overclocked to 3.5GHz, 4 gigs of memory, and 2 8800 GTX video cards with 768megs of memory. One thing I did was check my virtual memory settings. It was set by default to "Automatically manage paging file size for all drives". I changed this to "System Managed Size". I also turned off SLI management as I understand it doesn't really work with FSX anyway. With these changes I was able to fly a little longer (from KLAX to KSFO). This time I was able to start landing at SFO before the error msg cropped up. I then went into my FSX settings and lowered them just a little (all scenery sliders were pretty much maxed out to the far right). I moved each down one step and now I do not encounter the error msgs any longer. I did everything possible to create the error msg again (like turning on max weather, max traffic, etc.) but I can't get FSX to crash any longer. I'm knocking on wood and hope the problem has been fixed. I also hope NVIDIA creates better drivers soon so all enhancements on the 2 8800 cards I have can eventually be used. I am also upgrading to the 64 bit version of VISTA (it only costs $9.95 to upgrade) as I understand the 64 bit version handles memory for systems with more than 2 gigs much better. Hope this helps."Best regards,Jim

Share this post


Link to post
Share on other sites

EDIT: First of all: I am not hellogoodbye but I am the starter of this topic: the inital post was posted while my son was logged in, which I didn't notice, so... ;) I'll try to remember this the next time. ;)Okay, so this might be a driver thing...I have an E6600 so that's not too bad, I think. ;)I haven't edited anything in the cfg files, so that shouldn't be the problem. I could indeed 'optimize a bit further', but really... firehakw44 had everything maxed out! I can't see I maxed out that much, on the contrary...! I will look at the pagefile settings tomorrow (if I can find it in Vista...) and set it to System managed size. (I guess that's the setting where I say how big the pagefile has to be...? How big should it be under Vista with 2 Gb ram...? I know the XP numbers but I guess they are different...?)

Share this post


Link to post
Share on other sites

"and set it to System managed size. (I guess that's the setting where I say how big the pagefile has to be...? How big should it be under Vista with 2 Gb ram...? I know the XP numbers but I guess they are different...?)"I set mine at "System Managed Size" as I stated earlier. However, you might read the Vista guide (http://www.tweakguides.com/TGTC.html) where the author recommends memory settings based on the memory in your system. Your FSX cfg settings seem low. I went down one setting from the max. Under the graphics tab, global settings are high; under Aircraft, medium high; under Scenery, High; and Weather and Traffic, high. I have yet to encounter the OOM error since I changed these settings. You might check one more thing should you encounter more OOM messages, under the Scenery tab, make sure the "Level of Detail Radius" is set to Medium. I set mine to High and started getting the out of memory errors again. Lowered it to Medium and they stopped. However, I can't see how this setting could have caused the OOM messages alone. Hope this helps.Best regards,Jim

Share this post


Link to post
Share on other sites

>Today I fooled around a bit with the various settings in FS>X. Everything looked fine. I settled for some high, medium and>low settings, nothing extraordinary. Traffic is at the Medium>low option (which is quite low...!), Clouds are one notch>higher than the lowest option, Scenery isn't too high either,>well, nothing outrageous.>>But since changing these settings I get an error and FS X>locks up! After a few hours of testing I suddenly got a>usefull error (instead of just a lock up):>>http://i14.tinypic.com/44i36zr.jpg>>But... I've got 2 Gb of ram and a 8800GTX... Shouldn't that be>enough to play with everything high?!? (Let's forget about fps>there... ;) ). I mean, how much more memory does an average>computer have?>>I use Vista Home Premium 32 bits. Is there some sort of>setting for virtual memory I should change...? My partition>with the OS has 13 Gb free and my datadisk even 200 Gb...!>>When SP1 is released and let alone the DX10 patch I want to>use a lot higher settings than I do know!!!>Try backing down your Level of Detail Radius and/or Autogen Density.-Doug

Share this post


Link to post
Share on other sites

I have an E6600 system with 2GB of ram and an 8800 GTS 640MB graphics card on XP Pro. I run with just about the same settings as you have above except that my air traffic is set at between 70 and 100% (default traffic only), Mesh complexity 100%, Mesh density 19m, and the autogen is at dense to very dense instead of extremely dense. I have never run out of memory. I have run FSX for up to 10 hours at a time per session.However ...I was told by Adam Szofran of ACES at the AVSIM conference last year that it is possible to force FSX to run out of memory. The amount of data being thrown around is incredibly massive, and, no, the 2 GB limit of 32 bit operating systems is not enough space to be able to manipulate it all when sliders are all the way to the right.ACES had a choice:1. Set up the sliders so that users can choose a balance of sliders today and even 3 to 6 years from now to optimize those parts of the system that are most important to them. The thought was that users would understand this concept and realize they would have to make a choice about what is most important to them and set up the sliders appropriately. Even 6 years from now, this will still be a problem for 32 bit operating systems. Unfortunately, 64 bit operating systems are not common enough to justify exclusive development for them.2. Cripple FSX so that users could move the sliders all the way to the right and feel like they are getting the best performance possible (a lie).Granted, your settings are not nearly maxed out across the board, but, given the limitations of operating systems available today, and the wide variety of systems available to most users, which choice would you make as a developer?Thomas[a href=http://www.flyingscool.com] http://www.flyingscool.com/images/Signature.jpg [/a]I like using VC's :-)N15802 KASH '73 Piper Cherokee Challenger 180

Share this post


Link to post
Share on other sites

I used to constantly get these types of errors, as well as unable to read memory errors. I traced the problem to a bad memory stick using memtest, since I replaced it I haven't gotten one error since! I would lean to checking for bad memory! FSX (As well as FS9) seem very sensitive to any errors.My SystemIntel C2D E6700Intel 975X Chipset2GB Mem DDR2 667MhzATI X1950XTX Crossfires

Share this post


Link to post
Share on other sites

I'm not trying to start an argument here so all those waiting to pounce on people who might have an opposite opinion just relax.According to the MS documentation on the MS site, Windows XP's upper memory limit is 4Gb - not 2Gb. I run XP Pro on my system and I have 4Gb and the memory is used quite efficiently.There are several very important concepts that folks must remember. First, it is the front side bus (FSB) speed that determines whether or not your memory will perform to your expectations. Not all motherboards support higher rates of FSB nor is memory all rated at the same speed. Make sure you match your motherboard capabilities to the FSB speed of your memory.Second, it is critical that you obtain memory sticks that are of the highest quality and match the motherboard you have. I know it is very attractive to buy "cheap" memory - especially when you're populating above 1Gb. However, sometimes it is better to bite the bullet and purchase better memory. I had a rough time with a certain brand of inexpensive memory and I could not get it to work properly in my system. I changed to Corsair with a matched set of sticks for 4Gb of RAM and performance on my system skyrocketed.fb

Share this post


Link to post
Share on other sites

"I used to constantly get these types of errors, as well as unable to read memory errors. I traced the problem to a bad memory stick using memtest, since I replaced it I haven't gotten one error since! I would lean to checking for bad memory! FSX (As well as FS9) seem very sensitive to any errors."Tom,Thanks for your input. I have thoroughly checked my memory sticks several times (a long and tedious process) and all sticks passed. What OS do you have? J van E and myself (and many others) are having OOM problems with Vista Premium and the NVIDIA 8800 video cards and lots of memory. I see you have an ATI video card installed in your system. Having read several other threads on AVSIM and other FS websites, I see the most common setup with the FSX OOM errors is VISTA, lots of memory, and the NVIDIA 8800 video cards. I had absolutely no memory problems with the XP OS and the 8800 video cards with XP drivers. If you had the XP OS and received the errors, you were fortunate to resolve the problem by replacing some bad memory. In any case, it was a good suggestion and appreciate your input. I still think it's a NVIDIA video card driver problem but I'm extremely happy with the great graphics/FPS I am receiving with my FSX config settings set one notch down from the max under each tab. Best regards,Jim

Share this post


Link to post
Share on other sites

Well, dig this: I have UPPED some settings even more (see the screenshots below, showing only the ones that have changed), but set Level of detail radius to medium (and Autogen to Very dense) and... that did the trick! I just did a 2 hour flight without any problems.http://i12.tinypic.com/2cymbg4.jpghttp://i11.tinypic.com/2gtnecl.jpghttp://i14.tinypic.com/2hrik20.jpgI even tested with crazy settings (everything completely ultimate high and Traffic all to 50%, but Level of detail radius to Medium) and although it DID end with the well known error, it took longer than it did yesterday with the settings from my opening post. BTW The settings shown above give me an fps of about 15 to 20, which isn't too bad imho (with drops to 5 at big airports though...). But I didn't start this topic or change any settings with fps in mind, so... I'm a happy pilot now. ;)

Share this post


Link to post
Share on other sites

If you are using fast slewing or time compression above 2x, either of these can gobble up memory at an alarming rate. It acts as if new scenery is being loaded into memory faster than the old scenery is being discarded.You can see the drop in available memory clearly in Performance Monitor (Memory -- Available MBytes). If it gets dangerously low, minimize FSX. After a few seconds the memory will recover enough to resume flying.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this