Jump to content
Sign in to follow this  
kerosene31

Constant crashing help

Recommended Posts

A month and a half ago I got a new PC and was flying great.  Suddenly the past couple weeks, I get a crash to desktop within a couple minutes of starting a flight.  I'm at my wits end as to what to do.  I play lots of other games and have zero issues on my PC.  I've taken the following steps and still a generic cessna starting on any generic airport crashes.  The system itself is fine, MSFS 2020 just crashes and goes to desktop.  I actually loaded up another game without rebooting and the system was fine, so I really don't see a hardware issue.  I actually just finished RDR2 on there with all the graphics cranked up.

-This issue happened before and after WU7 so it didn't impact it. 

-Community folder is completely empty.  Nothing.

-I uninstalled everything from the MS Store other than official stuff.  Last thing I installed was the Reno Air Races thing (I was able to fly those no problem in the past)

-I've tried a couple of nvidia drivers and all seem to have the same problem (might roll back to a much older version).  Drivers are up to date on my system and hardware diagnostics come back clean.

-I load up a flight to any airport and sit.  Within 1-2 minutes the system crashes when I start moving the view around.  No errors on screen.  It isn't like I should be stressing the system.  I just set things on the 2nd highest graphics setting, not even the highest. 

-I've reinstalled once and will try that again but I'm really running out of ideas.  Just throwing this out there in a desperate search for answers.  Just running dx11, no dx12, I never messed around with the beta builds for MSFS2020.  I'm running out of ideas to throw at it. 

  • Like 1

-------------------------

Craig from KBUF

Share this post


Link to post
Share on other sites

Have you ever checked the event viewer after the crash happened?


Nvidia 4090 | AMD 5950X | 128GB DDR4 3200 | LG C1 48"
TCA Boeing Yoke | Honeycomb Bravo | TPR Rudders | Stream Deck XL | Tobii 5

Share this post


Link to post
Share on other sites

Check the Events Log Viewer and if it's an ntldll.dll crash, try this. Worked wonders for me after weeks of frustration!

https://forums.flightsimulator.com/t/ctd-fix-info/471880

  • Like 2

13900K@5.8GHz - ROG Strix Z790-E - 2X16Gb G.Skill Trident DDR5 6400 CL32 - MSI RTX 4090 Suprim X - WD SN850X 2 TB M.2 - XPG S70 Blade 2 TB M.2 - MSI A1000G PCIE5 1000 W 80+ Gold PSU - Liam Li 011 Dynamic Razer case - 58" Panasonic TC-58AX800U 4K - Pico 4 VR  HMD - WinWing HOTAS Orion2 MAX - ProFlight Pedals - TrackIR 5 - W11 Pro (Passmark:12574, CPU:63110-Single:4785, GPU:50688)

Share this post


Link to post
Share on other sites
1 hour ago, kerosene31 said:

A month and a half ago I got a new PC and was flying great.  Suddenly the past couple weeks, I get a crash to desktop within a couple minutes of starting a flight. 

It couldn't hurt if you gave some indications of your hardware. Also no new hardware before the crashes, no change of configuration ? No overclock ?

When you reinstalled are you sure that nothing was left, like in the the users/.../appData/roaming folder ?

  • Like 1

Dominique

Simming since 1981 -  4770k@3.7 GHz with 16 GB of RAM and a 1080 with 8 GB VRAM running a 27" @ 2560*1440 - Windows 10 - Warthog HOTAS - MFG pedals - MSFS Standard version with Steam

 

Share this post


Link to post
Share on other sites

Welcome to my World !

Idem like you, can't play can't update, uninstall, install, account change .......

Today i am trying to update after adding pagefile.sys to my SSD drive, before it was deactivated.

Finger cross !


Frédéric Giraud

Share this post


Link to post
Share on other sites

I was experiencing similar issues back when I first built this system. I have an Asus Z490 motherboard. I have a program from Asus called "AI suite 3" that I downloaded from their web site support page for my MB. AI Suite has a page called "EZ Update" in it that updates all of the on board device and chipset drivers to their latest versions. I ran it, and all of my problems went away.

If you do not remember specifically installing the "Chipset driver" for your particular motherboard from the manufacturer's web site, then I would highly recommend that you do so. It's even better if you can use AI Suite or a similar app for your brand of MB to update all of the onboard devices as well.


 i9-10850K, ASUS TUF GAMING Z490-PLUS (WI-FI), 32GB G.SKILL DDR4-3603 / PC4-28800, EVGA GeForce RTX 2080 Ti BLACK EDITION 11GB running 3440x1440 

GONE BOATING - It's like fishing, but with a clean deck.

Share this post


Link to post
Share on other sites

System specs:

i7 12700KF
GeForce TRX 3070
16gb RAM
Win 11

No overclocking at all.  All latest drivers from manufacturer. 

I will maybe do an uninstall and manually check every folder.  That's my best guess at this point.  Don't think it is my system, but maybe a bad install or something.  It is just weird the way it crashes almost immediately with just default.  Maybe an add-on messed with some default files or something. 

I'll check the event log, but last time I checked there was nothing that stood out.

Thanks to everyone for suggestions, I've got many more things to try for sure.  Any suggestions are super helpful and give me more to try. 


-------------------------

Craig from KBUF

Share this post


Link to post
Share on other sites

Try deleting rolling cache, if it has been used.
I also read elsewhere, that deleting registry files within MSFS2020, helps, but I need to Google that again, think I saw the tip in a ORBX forum.

  • Like 1

i9 10900KF
RTX 3080
32gb ram
SSD

Share this post


Link to post
Share on other sites
4 hours ago, odourboy said:

Check the Events Log Viewer and if it's an ntldll.dll crash, try this. Worked wonders for me after weeks of frustration!

https://forums.flightsimulator.com/t/ctd-fix-info/471880

This worked for me, many thanks for the heads up.

  • Like 1
  • Upvote 1

AMD Ryzen 7 3700X 4.2 32 gig ram, Nvidia RTX3060 12 gig, Intel 760 SSD M2 NVMe 512 gig, M2NVMe 1Tbt (OS) M2NVMe 2Tbt (MSFS) Crucial MX500 SSD (Backup OS). VR Oculus Quest 2

YouTube:- https://www.youtube.com/channel/UC96wsF3D_h5GzNNJnuDH3WQ   ProATC/SR and BATC FB Group:- https://www.facebook.com/groups/1571953959750565

Flight Simulator First Officer User Group:- https://www.facebook.com/groups/564880128522788 ProATC/SR and Flight Sim First Officer (FSFO) Beta tester

Reality Is For People Who Can't Handle Simulation!

 

Share this post


Link to post
Share on other sites

Just wanted to give a quick update and say a big thank you to everyone for all the help.  I've made 2 flights now and no crashes.  I reinstalled the entire sim again and all my add-ons and things seem much improved. 

Long story short, I ended up reinstalling every single system driver and that seems to have done the trick.  I'm pretty sure this link helped a ton as well, as it found some problems and seems to have fixed them.  https://forums.flightsimulator.com/t/ctd-fix-info/471880

Anyway, thanks again, one last question.  What is the recommended setting for rolling cache?  I have really good internet (2oomb download).  Should I just turn it off completely?  It seems to cause more problems. 

 

Edited by kerosene31

-------------------------

Craig from KBUF

Share this post


Link to post
Share on other sites

That's great news! Glad you got it sorted.

I usually get my drivers directly from the manufacturers of the devices in my system, including the ones on the motherboard. I was using the generic Intel z490 chipset drivers. Windows and every driver checker that I trust said I was A-Okay and up to date. When I ran the Asus AI Suite, I was expecting to see the same. It surprised me when it replaced at least 5 or 6 drivers for some of the onboard devices. It surprised me even more when I realized that it actually did make things better,


 i9-10850K, ASUS TUF GAMING Z490-PLUS (WI-FI), 32GB G.SKILL DDR4-3603 / PC4-28800, EVGA GeForce RTX 2080 Ti BLACK EDITION 11GB running 3440x1440 

GONE BOATING - It's like fishing, but with a clean deck.

Share this post


Link to post
Share on other sites
22 hours ago, kerosene31 said:

What is the recommended setting for rolling cache?

I did a few tests recently and found (for me) it's best to be turned off.
Lots of glitches, popups and scenery not displaying at all in the area(s) that's supposed to be cached ... 

Edited by teletom
  • Like 1

Nvidia 4090 | AMD 5950X | 128GB DDR4 3200 | LG C1 48"
TCA Boeing Yoke | Honeycomb Bravo | TPR Rudders | Stream Deck XL | Tobii 5

Share this post


Link to post
Share on other sites

The steps I linked work well as a 'try these first' before one attempts a complete uninstall/reinstall. It is also recommended to do them after Windows updates. It's also a good idea after updating the GPU to use disk cleanup and clean the Direct X cache then reboot PC. i also recommend the OP to get at min 32GB RAM MSFS20 eats up RAM.

Edited by udidwht

Win10Pro 22H2-19045.4474/IntelCorei7-3770K/GigabyteGA-Z68XP-UD3/32GBGSkillCL7-8-8-24/AsusRTX2070OC8GB/1TBCrucialMX500SSD/2 TB PNY CS900/(x3)1TBRAWMushkinSSDs/LGBlueRayBurner/RosewillChallengerTowerBlack/CorsairRM750wPSU/X56HOTAS/TtesportsCommanderKeyboardMousecombo/TrackIR5Pro/34inUltraWideScreenLG2560x1080p/TM2xMFDCougar/OculusQuest2/InateckKU5211PCIe3.2/LTERIVERPCIeG2S4/TMobileHomeInternet5G

MSI Codex Series R2 B14NUC7-095US/Windows 11 Home 22H2 22631.3593/i7 14700F/MSI Pro B760 VC Wifi II/RTX 4060/32GB DDR5 5600mhz/650w Gold PSU

Share this post


Link to post
Share on other sites

I'm also currently unable to complete a flight without the sim crashing. I've tried most of what has been suggested on this thread but no joy, so I'm going to try reinstalling next.

11th Gen i9-11900K @ 3.5GHz | nVidia GeForce RTX 3080 | Corsair 64 GB RAM | Samsung 970 EVO Plus 2TB | Asus 27" RoG G-Sync

Track IR5 | Thrustmaster Warthog | CH Products Pedals

 


11th Gen i9-11900K @ 3.5GHz | nVidia GeForce RTX 3080 | Corsair 64 GB RAM | Samsung 970 EVO Plus 2TB | Asus 27" RoG G-Sync

Track IR5 | Thrustmaster Warthog | CH Products Pedals

Share this post


Link to post
Share on other sites
54 minutes ago, Virtualwombat said:

I'm also currently unable to complete a flight without the sim crashing. I've tried most of what has been suggested on this thread but no joy, so I'm going to try reinstalling next.

11th Gen i9-11900K @ 3.5GHz | nVidia GeForce RTX 3080 | Corsair 64 GB RAM | Samsung 970 EVO Plus 2TB | Asus 27" RoG G-Sync

Track IR5 | Thrustmaster Warthog | CH Products Pedals

 

Have a look in Windows event viewer and see what it shows then copy and paste it up here.

 

You tried 'most' but not all?

Edited by udidwht

Win10Pro 22H2-19045.4474/IntelCorei7-3770K/GigabyteGA-Z68XP-UD3/32GBGSkillCL7-8-8-24/AsusRTX2070OC8GB/1TBCrucialMX500SSD/2 TB PNY CS900/(x3)1TBRAWMushkinSSDs/LGBlueRayBurner/RosewillChallengerTowerBlack/CorsairRM750wPSU/X56HOTAS/TtesportsCommanderKeyboardMousecombo/TrackIR5Pro/34inUltraWideScreenLG2560x1080p/TM2xMFDCougar/OculusQuest2/InateckKU5211PCIe3.2/LTERIVERPCIeG2S4/TMobileHomeInternet5G

MSI Codex Series R2 B14NUC7-095US/Windows 11 Home 22H2 22631.3593/i7 14700F/MSI Pro B760 VC Wifi II/RTX 4060/32GB DDR5 5600mhz/650w Gold PSU

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...