Jump to content
Sign in to follow this  
d.tsakiris

From FullHD To 4K

Recommended Posts

So, the 4K arrived, and while I haven't done a full flight yet, first tests were somewhat ambivalent. The higher resolution is great for the VC and airports, but not so much for the surrounding scenery. It does also look better, but the autogen draw distance is much more discernable. Plus the GPU usage doubled, and I also will have to reduce the maximum texture resolution.

Additionally, the device can display HDR material correctly. At night, that's great. It's the first time I've noticed autogen lights seem to be of the dynamic variety... But in the virtual daytime, the coloring seems more washed out.

But I don't want to sound negative here, I'm definitely keeping the new display, and I'm sure after some tweaking here and there, it will be great!


Best regards, Dimitrios

Share this post


Link to post

After some more testing and one real flight, I seem to have a problem: As soon as the mouse pointer is displayed and in/over the P3D windows, my FPS tank to way under 20 (and CPU usage is higher). After a few seconds, the mouse pointer disappears, and the FPS go back to normal (lower CPU usage). It also is okay if I move the point out of the P3D window. Interestingly, it happens in the VC, and also when viewing from outside (F11). I see it with an add-on, and with a default aircraft. I reset the prepar3d.cfg, and reverted to FHD resolution, but that didn't resolve the issue.

Any ideas?

On the bright side, it was relatively easy to adjust the settings so that the colors look pretty good...


Best regards, Dimitrios

Share this post


Link to post

Have you deleted your prepar3d.cfg file and let it get rebuilt?


Gigabyte Z97X-UD5H-BK, Blk Ed MB; Intel I7-4790K CPU (@4.5 Ghz); Deepcool 240 AIO Cooler; 16 Gb G.Skill RAM (F3-2400); Win10 Pro (P3D V5.3HF2); 2 Samsung 1Tb SSDs;Toshiba 3Tb hard drive; Gigabyte Aorus Extreme 1080ti 11Gb VRAM; Toshiba 43" LED TV @ 4k; Honeycomb Bravo.

 

Share this post


Link to post

Yeah, I tried that. I've also deleted the shaders cache.


Best regards, Dimitrios

Share this post


Link to post
2 hours ago, d.tsakiris said:

Yeah, I tried that. I've also deleted the shaders cache.

Post your JobScheduler settings and your CPU details including if you have Hyperthreading enabled.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Hi Ray, I have a Ryzen 5900X, SMT (^=HT) is deactivated. I normally do have custom job scheduler settings, which I will post later. But with the reset of the .cfg, those were also changed to default, but to no avail...


Best regards, Dimitrios

Share this post


Link to post
37 minutes ago, d.tsakiris said:

Hi Ray, I have a Ryzen 5900X, SMT (^=HT) is deactivated. I normally do have custom job scheduler settings, which I will post later. But with the reset of the .cfg, those were also changed to default, but to no avail...

It’s quite possible the default settings are not correct. Have you looked through this topic and used the calculator?


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Yes, the calculator is very useful. Later I will post my and the default settings. At the moment I am suspecting my NCP and P3D settings concerning FPS limits etc. have to be adapted somehow to the new screen. That's just a gut feeling, though.


Best regards, Dimitrios

Share this post


Link to post

Looking back in this discussion you haven’t said what your 4K display is. TV or monitor? Capable of 30Hz? A link to the model would help.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

It's a TV: Hitachi U42K5302 42 inch. Capable of 30, or even 25 or 24 Hz. Like my old screen (a 42 inch Funai TV), I couldn't bear using it with the refresh rate set to anything under 50 Hz, so I limited P3D to 25 FPS with Nvidia's control panel (RTSS didn't work, and P3D's internal limiter had too much of an overhead). I will remove this config and see what happens.


Best regards, Dimitrios

Share this post


Link to post

Try living with 30Hz on the TV with VSync enabled for a few days. I was sceptical at first but it gives the smoothest experience. Panning isn’t the best but you don’t spend a lot of time panning.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

I use TrackIR, so I do pan a lot. But doing so with 25 FPS in the sim wasn't a problem. It's using the operating system with 25 Hz that I didn't like. But I will try (almost) everything 🙂


Best regards, Dimitrios

Share this post


Link to post

Make sure that the NVidia Global profile and P3D profile (3D settings Restore/Apply) are both defaulted to factory settings before testing and making settings. When making changes there only set the P3D profile.

The few options are:

Setting the TV to 25 or 30Hz refresh and setting VSync=on, in the P3D display settings set unlocked on the slider and TP=off. NVidia profiles at factory settings.

Setting the TV to highest refresh frequency it can do and setting NVidia Control panel P3D profile to limit fps with P3D set to VSync=off, unlocked, TP=off.

Setting the sim to output at 1920x1080 and when in full screen it will be upscaled to fit.

By he way, with SMT enabled and a custom AM you can't improve frame rate but it will improve the rate at which the scenery and objects are collected and processed which might help improve some graphics features, would need testing.

 


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
29 minutes ago, d.tsakiris said:

I use TrackIR, so I do pan a lot. But doing so with 25 FPS in the sim wasn't a problem. It's using the operating system with 25 Hz that I didn't like. But I will try (almost) everything 🙂

That’s because it’s being controlled artificially. As Steve suggests setting the display to 30Hz with VSYNC on and unlimited for fps means it’s controlled naturally. Big difference.


Ray (Cheshire, England).
System: P3D v5.3HF2 & v3.4, Intel i7-8086K o/c to 5.0Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

So, these are my job scheduler settings:

AffinityMask=4094
P3DCoreAffinityMask=4092
MainThreadScheduler=9
RenderThreadScheduler=1
FrameWorkerThreadScheduler=6

I put the main thread scheduler on the core the Ryzen Master tool deems the "best". The default settings, set by Prepar3D, were as follows:

AffinityMask=4095
P3DCoreAffinityMask=4095
MainThreadScheduler=0
RenderThreadScheduler=2
FrameWorkerThreadScheduler=4

I am now in the process of testing after resetting NVI and NCP settings to default. For now I'm leaving the screen refresh rate to 50 Hz, and the setting in P3D to "Unlimited". Maybe RTSS will work with this screen, it didn't with my old screen.


Best regards, Dimitrios

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...