Jump to content
Sign in to follow this  
d.tsakiris

From FullHD To 4K

Recommended Posts

Posted (edited)

First test result: 50 FPS with mouse NOT active in P3D window, 8 FPS with mouse active. This is with the Aerosoft A333, with the default Mooney Bravo it changes to 70+ and 13 FPS.

Another thing I've noticed: When the mouse pointer is active in P3D, there is a lot of flickering in other programs, like the Task Manager or ASP3D - but only if P3D has to render something. Loaded scenario, or start screen, or aircraft selection screen: Flickering with active mouse pointer. No active mouse pointer, or P3D settings: No flickering.

Edited by d.tsakiris

Best regards, Dimitrios

Share this post


Link to post

What mouse are you using? I remember something similar with large FPS drops when moving the mouse cursor within P3D and the only way to minimise it was to reduce the USB polling rate for the mouse. 

I had got a new Logitech gaming mouse which was using a 1000Hz polling rate and had to reduce it to 125Hz in the Logitech G.Hub software - any other setting would cause these FPS drops in P3D (but not in any other games).

Just an idea 🙂

Share this post


Link to post
19 minutes ago, d.tsakiris said:

So, these are my job scheduler settings:

AffinityMask=4094
P3DCoreAffinityMask=4092
MainThreadScheduler=9
RenderThreadScheduler=1
FrameWorkerThreadScheduler=6

I put the main thread scheduler on the core the Ryzen Master tool deems the "best". The default settings, set by Prepar3D, were as follows:

AffinityMask=4095
P3DCoreAffinityMask=4095
MainThreadScheduler=0
RenderThreadScheduler=2
FrameWorkerThreadScheduler=4

I'm guessing you have a 12 core SMT disabled.

Your AM setup puts the main thread on core 11 (counting from 1 to 12) and also there are problems with P3D when not keeping the three main tasks in order.

With 12 core CPU with SMT (or HT) disabled and core 9 being the "best" you need to put the main task on core 9 and keep the order of the other two like this:

AffinityMask=4095
P3DCoreAffinityMask=4095
MainThreadScheduler=9
RenderThreadScheduler=10
FrameWorkerThreadScheduler=11

However, that's not going to cure the fps drop but it will keep things running better.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
3 minutes ago, krich said:

What mouse are you using? I remember something similar with large FPS drops when moving the mouse cursor within P3D and the only way to minimise it was to reduce the USB polling rate for the mouse. 

I had got a new Logitech gaming mouse which was using a 1000Hz polling rate and had to reduce it to 125Hz in the Logitech G.Hub software - any other setting would cause these FPS drops in P3D (but not in any other games).

Just an idea 🙂

Now this is interesting, as I did also get a new mouse. Didn't occur to me at all that could be a problem! I will check different settings, and the old mouse.

 

4 minutes ago, SteveW said:

Your AM setup puts the main thread on core 11 (counting from 1 to 12) and also there are problems with P3D when not keeping the three main tasks in order.

Actually, it puts in on core 12 of 12. I've never heard there are problems with an out-of-order mask. I will try your suggestion, but as I have masked away 2 of the 12 cores for P3D to use itself, 9 is now the highest core. I have to assign the threads to 7, 8 and 9. And since core 6 is - according to Ryzen Master - a good one, I will assign them to 6, 7 and 8.


Best regards, Dimitrios

Share this post


Link to post
11 minutes ago, SteveW said:

AffinityMask=4095
P3DCoreAffinityMask=4095
MainThreadScheduler=9
RenderThreadScheduler=10
FrameWorkerThreadScheduler=11

Sorry, brain still in numbering from1..12 mode -  I should have said 8,9,10:

AffinityMask=4095
P3DCoreAffinityMask=4095
MainThreadScheduler=8
RenderThreadScheduler=9
FrameWorkerThreadScheduler=10

since numbering is from 0..11

Certain out of order patterns can cause CTD's.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Posted (edited)

i think thats a driver version issue, I dont get that and Im on a driver from January. Ive also changed the colour of the mouse from white to dark red. 

Edited by adam77

Share this post


Link to post
13 minutes ago, SteveW said:

since numbering is from 0..11

..that is because I believe the Ryzen tool counts from 1..12 but the P3D AM thread locations are counting from 0..11, and count only the ones in the AM so thread 8 would be core 9 when using 4095=111111111111


Steve Waite: Engineer at codelegend.com

Share this post


Link to post

Same behavior with 30 Hz. Disabled fullscreen optimizations and testing...


Best regards, Dimitrios

Share this post


Link to post

Nope, that wasn't it, either. Running out of ideas...


Best regards, Dimitrios

Share this post


Link to post
1 hour ago, d.tsakiris said:

Unfortunatly, the problem persists with the old mouse. According to this website: https://www.clickspeedtester.com/mouse-polling-rate-checker/ both devices have a polling rate of 125 Hz. Back to square one...

Next test: Screen refresh rate 25 Hz.

Shame that didn't help - I just tried and can straight away reproduce the same issue on my system if I change the polling rate (it is called Report Rate Per Second in the Logitech software) to anything other than 125.

Share this post


Link to post

Does the website I posted report the correct rate when you change it in the Logitech software, could you please check that for me?


Best regards, Dimitrios

Share this post


Link to post
2 minutes ago, d.tsakiris said:

Does the website I posted report the correct rate when you change it in the Logitech software, could you please check that for me?

No it didn't - it is showing massive spikes at all settings so I don't know how accurate it is. It is most accurate at 125, but when I tried 1000, the website was showing spikes to 3000 and above which shouldn't be happening.

Share this post


Link to post

Okay, thanks. For me and my two mice, it always showed exactly 125 Hz. I guess it might be severely limited at higher polling rates.

  • Like 1

Best regards, Dimitrios

Share this post


Link to post

As a cross-check I set up my old TV today. No visible drop in the FPS with active mouse pointer, (unlimited) framerates of 45 to 65 (hard to tell with P3D's display). Other programs don't flicker, the cores loads don't go up and down with or without an active pointer. Why does my setup struggle this much with a mouse pointer over a 4K screen? 🤔


Best regards, Dimitrios

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...