Sign in to follow this  
Guest uncyden

Blue 2d Blocks on water at night

Recommended Posts

I am having problems with aqua-blue 2d blocks appearing over water at night .They usually appear where their is light reflection on the water and autogenerate around coastal land area moving with plane. I installed sp1 over some minor tweaks in fsx.cfg(since reversed) and autogen (reduced trees. not reversed) files. Trying to avoid re-install as current config is all good. ANY IDEAS.I have since discovered that they only appear when you manually set to "night" in Time and Season.Please check out attachment......cheers Dennis

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I noticed those yesterday. I rarely do night flying and that was my first one in FSX.

Share this post


Link to post
Share on other sites

Yes Victor I rarely fly at night and only noticed it a week or so after installing sp1. I'm convinced it's not the minor tweaks I made pre-sp1 and believe it hasn't recieved more posts because most people don't fly at night. I don't get the effect if I fly the dusk to dark transition as I mentioned. Let me know if you get anywhere.....Dennis

Share this post


Link to post
Share on other sites

It's a bug that's been in the sim since RTM. I don't know exactly what causes it but it seems to be some sort of clash between coastal water and landclass, possibly the water's bump/specular maps, and the land detail textures. It seems the detail textures from land are overlapping into the water when they shouldn't be. You can get rid of it by turning off detail textures in your scenery display settings, but doing so will cause some alpha blending problems with taxiway lines and you'll lose the fine striations on grass textures etc. The bug is much more noticable with a full moon. Try it with a new moon, probably won't see it.I was hoping SP1 would fix that but I guess they didn't notice or it was too minor to bother with.

Share this post


Link to post
Share on other sites

Haldir..Thanks for confirming that it's a known bug.I only happened to notice it because I was flying at night under a full moon.Maybe they will patch it at some time in the future...Dennis

Share this post


Link to post
Share on other sites

I've only noticed them in the pseudo-tropical waters off Florida myself. Lake Erie and Pamlico Sound (North Carolina) seemed fine.

Share this post


Link to post
Share on other sites

I too have noticed this bug, and it was present before SP1.I am curious now...do we all have nVidia cards?RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

This looks very much a bug with the Shader, I have never experienced it myself but I don't suppose you have Shaders disabled on your video card?Also you wouldn't happen to be using a 7800 would you?Regards,Chris Norris

Share this post


Link to post
Share on other sites

Hi,I came across this tip at http://fsx-tweaks.4t.com/texture_folder.html1. Go to your FSXTexture folder and create 2 new folders:Temp_hold_bump.dds and Temp_hold_specular.dds2. Now right click the 'Texture' folder and select 'Search'3. In the 'All or part of the file name:' field type *specular.dds4. Once the search is completed, select all the objects found (except for the 2 new folders you created) and 'Move' them to the Temp_hold_specular.dds folder.5. Try your night flight again.(6). Do the same for all the *bump.dds files and, as a bonus, you may notice an improvement in frame rates.Try it, you never know it might help.Mike

Share this post


Link to post
Share on other sites

Hi, I don't have noticed the problem yet. I run FSX with a ATI Radeon 9800XT and XP. Could you give me a specific Date / Time / Location to verify this problem. Jan-Paul

Share this post


Link to post
Share on other sites

I noticed it before SP1 as well, I think flying from Ascension Island at night. FX7600GS.

Share this post


Link to post
Share on other sites

>I too have noticed this bug, and it was present before SP1.>>I am curious now...do we all have nVidia cards?>>Rhett>I have. 7900GT.

Share this post


Link to post
Share on other sites

I am getting this problem too and it has only recently started. I never had it with the original FSX, or even the SP1 version, but I suspect one of the graphics tweaks has triggered it. I also get it in daylight and not just at night.

Share this post


Link to post
Share on other sites

This is what I am seeing in daylight - exactly the same blocks in purplepurple2.jpgpurple1.jpg

Share this post


Link to post
Share on other sites

>This looks very much a bug with the Shader, I have never>experienced it myself but I don't suppose you have Shaders>disabled on your video card?>>Also you wouldn't happen to be using a 7800 would you?>>Regards,>>Chris NorrisLook at my sig to see that I use a 7800.I don't have shaders disabled.RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

So, everyone who has this problem has an nVidia 7xxx series card?If so, THAT is pretty interesting...RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

In the Shaders for FSX I came accross this comment:if (fIntensity < -fMedianLine) { fIntensity = fMinIntensity + (fMedianIntensity - fMinIntensity) * ((1 + fIntensity) / (1.0001 - fMedianLine)); // The "1.0001" in the line above is a hack to fix a bug // observed on some nVidia hardware (a 7800). Even though // the else branch of this if/else was taken a divide by // zero in this branch (when fMedianLine is 1.0) caused // the whole shader to go crazy. } else { fIntensity = fMedianIntensity + (1 - fMedianIntensity) * ((fIntensity + fMedianLine) / (1 + fMedianLine)); }I wonder if the 7 series has a general problem with some implementations of Shader 1.1 HLSL.

Share this post


Link to post
Share on other sites

Yep, same here 7600GS card. I do wonder about the Shader implmentation. Have you guys also noticed funny stuff happening when you view bloom effects? Sometimes it works, sometimes it doesn't and that is outside views as well as I know some bloom effects don't work in the VC.Steve

Share this post


Link to post
Share on other sites

the fact that the same shader runs on ATI, and NV 5x, 6x, and 8x without problems - points to this being a driver issue on NV 7x hw.what about reverting to older drivers?

Share this post


Link to post
Share on other sites

>the fact that the same shader runs on ATI, and NV 5x, 6x, and>8x without problems - points to this being a driver issue on>NV 7x hw.>>what about reverting to older drivers?Well I'm running the 91.47 drivers but I don't do a lot of night flying (if any).

Share this post


Link to post
Share on other sites

Yup, Nvidia here as well, 7900GTO. I get this problem pretty much everywhere coastal at dawn, dusk, and night. It happens regardless of driver, tried every single one there is, tweaked and standard, between 84.xx and the 100 series. Never a change in this problem. I haven't disabled any shaders. I sent a few emails to tell_fs about it with screenshots shortly after FSX was released as well. I think they know about the bug but it was too far down in the list of things to fix in SP1.I believe the culprit is the file: OceanHeight20FieldLayer.dds.I tried making it monochrome in photoshop and the problem went away, but it messes up reflections with mid-max 2x water. Those particular blue/purple values in the file are essential it seems to allow the terrain reflections to place correctly.

Share this post


Link to post
Share on other sites

I have a 7950GT and fly alot at night and never seen this problem. Maybe it's just with the 7600/800/900 cards.

Share this post


Link to post
Share on other sites

We are running the GeForce 7950 GX2 and we get the blue boxes at night over water also. Did this pre and post SP1.

Share this post


Link to post
Share on other sites

Yep! I'm also running a NVIDEA GEFORCE 7950GT.....Dennis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this