Archived

This topic is now archived and is closed to further replies.

jaje

ILS landings suddenly not working - NEED HELP

Recommended Posts

Hi,I have been doing ILS landings ever since I got FSX and there has been no problems so far. Then, all of a sudden, the last three times I have been trying to do an ILS landing, the aircraft pitches to an angle of attack of some 60 degrees resulting in a stall!! It happens when I turn on the APP button on the autopilot. The NAV1 freq is configured correctly.I follow the instructions given by the ATC, my speed is as it has always been - no changes to my ordinary routine.What should I do? Try a reapir of FSX? Any suggestions?Thanks in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

is the altitude hold button disengaging as soon as you press the APP? If that be the cause, try engaging it again, quickly. I dont know the exact cause, but that happened with me on an addon aircraft.Hope that helps

Share this post


Link to post
Share on other sites

Look at your trim wheel before you engage the AP. You are probably way out of trim in respect to the elevators.

Share this post


Link to post
Share on other sites

have you checked your airspeed? flaps? have you done an approach checklist procedure? which aircraft are you flying? normally, there are airspeeds to be maintained during some stages in an ILS approach.. that depends on which aircraft you are using...normally for B747-400 (in FSX), once you are about 20NM from the airport, you should slow down to about 210k to 215k @flaps 20...then once your aircraft reaches G/S (when the aircraft starts to decend, full flaps, the set Vspeed to 160k +5. this is not 100% correct, but this is what do even for visual approaches. as long as i see the PAPI with two red lights on, then i start to reduce airspeed.... :)there are also times that and add-on aircraft (mostly freewares) would act strangely during flights...

Share this post


Link to post
Share on other sites

This is a very simple suggestion, based on a similar experience I've had. Make sure that you've got your Nav selector turned to Nav, rather than GPS. This simple move stopped me going 60 degrees climb. Dunno, might work for you!Jaje

Share this post


Link to post
Share on other sites

Hello - moved on a few years i know, and i have found this post because i now have this problem recently developed.I've been very happily doing ILS landings for months and now things have changed.I'll look at the NAV /GPS thing, but do you chaps think that settings may have an influence?What i mean is that my settings may be pushing the computer. I've had some OOM crashes at the end of a flight and i was wondering id the computer, instead of giving up on the graphics when pushed,is now giving up on the ILS stability first?Any ideas anyone?TIA

Share this post


Link to post
Share on other sites

4 and a half years. Well, I think the best way to describe a not working ILS situation is a screenshot of the whole panel and some description on e. g. the location you were trying.

What i mean is that my settings may be pushing the computer (..) is now giving up on the ILS stability first?
Not from my experience, but you never know. Maybe use the default scenery for testing and then some default plane. If that combination doesn't give you valid ILS signals, then one may have to dig deeper. As said, screenshots are welcome and tell more than 1000 words.

Share this post


Link to post
Share on other sites