Sign in to follow this  
McCrash

Scenery popping Arrrrrrrrrghhhhh!!!

Recommended Posts

Can anyone help me with popping scenery? While I'm flying (VFR) trees and buildings pop into view like popcorn popping and it really spoils the realism.I have tried some tweaks in FSX.CFG (too many to recall) non of which were the "magic bullet" as I still get popping trees and buildings. My setup is fairly advanced so that may be part of the problem. Here's my hardware:Intel Core 2 duo 6600 @ 2.4Ghz2GB RAMWin XP Pro with SP2ASUS P5N32E-SLI motherboard with NVidia chipsetASUS NVIDIA 880GTS 640 Mbyte graphicsMatrox Triplehead2go and3 Samsung 940N 19" monitorsCurrent FSX.CFG (I took out the obviously irrelevant stuff)[Display]ChangeTime=4.000000TransitionTime=4.000000BLOOM_EFFECTS=0SKINNED_ANIMATIONS=1TEXTURE_BANDWIDTH_MULT=60UPPER_FRAMERATE_LIMIT=20WideViewAspect=True[bufferPools]PoolSize=10000000[Main]ProcSpeed=6777PerfBucket=7[PANELS]IMAGE_QUALITY=1DEFAULT_VIEW=1[Weather]WindshieldPrecipitationEffects=1MinGustTime=10MaxGustTime=500MinGustRampSpeed=1MaxGustRampSpeed=200MinVarTime=5MaxVarTime=50MinVarRampSpeed=10MaxVarRampSpeed=75TurbulenceScale=1.000000WeatherServerAddress=fs2k.zone.comWeatherServerPort=80WeatherGraphDataInDialog=0AdjustForMagVarInDialog=1DynamicWeather=2DownloadWindsAloft=0DisableTurbulence=0CLOUD_DRAW_DISTANCE=3DETAILED_CLOUDS=1CLOUD_COVERAGE_DENSITY=8THERMAL_VISUALS=0[DISPLAY.Device.NVIDIA GeForce 8800 GTS.1]Mode=3840x1024x16AntiAlias=1TriLinear=1[CONTROLS]Controls_Default=StandardControls_Current=StandardJOYSTICKS=1KBDAIL=64KBDELEV=64KBDRUD=64Stick_Sensitivity_mode=0;[DynamicHeadMovement]LonAccelOnHeadLon=-0.020000LonAccelOnHeadPitch=-0.010000RollAccelOnHeadLat=0.010000YawAccelOnHeadLat=-0.100000RollAccelOnHeadRoll=0.100000MaxHeadAngle=5.000000MaxHeadOffset=0.300000HeadMoveTimeConstant=1.000000[VirtualCopilot]VirtualCopilotActive=0[GRAPHICS]SHADER_CACHE_PRIMED=1693428480TEXTURE_MAX_LOAD=3072NUM_LIGHTS=8AIRCRAFT_SHADOWS=1AIRCRAFT_REFLECTIONS=1COCKPIT_HIGH_LOD=0LANDING_LIGHTS=1AC_SELF_SHADOW=0EFFECTS_QUALITY=1GROUND_SHADOWS=0TEXTURE_QUALITY=3IMAGE_QUALITY=0See_Self=1Text_Scroll=1[uSERINTERFACE]OpenATCOnCreate=1SHOW_MISSION_CAPTIONS=0PAUSE_ON_LOST_FOCUS=0PROMPT_ON_EXIT=0Map_Orientation=2[Trusted][RWW_WEATHER_MAP]SHOW_AIRPORTS=0SHOW_VORS=0SHOW_NDBS=0SHOW_APPROACHES=0SHOW_INTERSECTIONS=0SHOW_VICTOR=0SHOW_JET=0SHOW_AIRSPACE=0SHOW_FLIGHTPLAN=1SHOW_WEATHERSTATIONS=1SHOW_WEATHERSYSTEMS=1SHOW_DATATAGS=1SHOW_TERRAIN=1[PointOfInterestSystem]CycleSetting=0[sCENERY]LENSFLARE=1DAWN_DUSK_SMOOTHING=1IMAGE_COMPLEXITY=5[TrafficManager]AirlineDensity=0GADensity=0FreewayDensity=0ShipsAndFerriesDensity=0LeisureBoatsDensity=0IFROnly=0AIRPORT_SCENERY_DENSITY=0Smallpartrejectradius=4[TERRAIN]LOD_RADIUS=4.500000MESH_COMPLEXITY=100MESH_RESOLUTION=25TEXTURE_RESOLUTION=29AUTOGEN_DENSITY=2DETAIL_TEXTURE=1WATER_EFFECTS=3TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2000[REALISM]PFactor=1.000000Torque=1.000000GyroEffect=1.000000CrashTolerance=1.000000General=1.000000UnlimitedFuel=FalseTrueAirspeed=FalseAutoCoord=FalseRealMixture=TrueStressDamage=TrueGEffect=TrueManualLights=TrueGyroDrift=FalseCrashWithDyn=TrueCrashDetection=TrueAutoTrim=False[sIM]SYSCLOCK=1[Misc]Com_Rate=7Any takers? Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

>Can anyone help me with popping scenery? While I'm flying>(VFR) trees and buildings pop into view like popcorn popping>and it really spoils the realism. Unfortunately there isn't a "cure" for the scenery "popping", I do not believe. I seem to recall a post by Phil Taylor some time ago that addressed this issue and saying that it was a result of the new way FSX handled scenery loading, etc, and was a result of optimizing the whole process for "performance". Unfortunately this compromised "realism"... I've had to just come to accept this shortcoming of FSX. When I built up a new machine with a Q6600 and eVGA 8800GTS 640MB card the "popping" was reduced somewhat, but is always present :( It would sure be nice if there was a "magic bullet" for this problem as I too find it's impact on the suspension of disbelief to be a large drawback in light of all else. Paul

Share this post


Link to post
Share on other sites

I read in one of Phil's blogs that SP2 reduced popping somewhat. I haven't tested it yet to see how true that is or what he meant by what he said. I had the impression from what he said that SP2 "improves" the popping issue, but doesn't actually fix it. But that was just my impression of what he said.Thomas[a href=http://www.flyingscool.com] http://www.flyingscool.com/images/Signature.jpg [/a]I like using VC's :-)N15802 KASH '73 Piper Cherokee Challenger 180

Share this post


Link to post
Share on other sites

Ummm... I was afraid you were going to say that.Thanks anyway guys:-beerchug

Share this post


Link to post
Share on other sites

In FS9 they used a technique called alpha fade which worked pretty well.I remember Phil Taylor mentioning it was on the list of possibles to re-introduce to FSX through the service packs. It didn't make SP1, and as I haven't got SP2, don't know whether it's still an issue.Stu

Share this post


Link to post
Share on other sites

I can confirm, SP2 reduces the autogen popping to a level where it is hardly noticable :-), but still marginal present :-(. But at least I can fly now with autogen on medium or high, and trees and buildings do not jump out of nowhere just under my plane, but far ahead.I remember it being a big problem with FSX SP1 (trees and buildings would pop in focus when I was practically on or already past them).ACEs introduced a different technique for autogen in SP1 to improve FPS and terrain loading (Phil can answer this better), and improved on it in SP2.Jan

Share this post


Link to post
Share on other sites

Hello Scott,You have exacerbated the problem with this line:Smallpartrejectradius=4This prevents objects from displaying until they are x pixels large, in this case 4, thus making the popping worse.Eliminate that line and your popping will be slightly reduced.In general, many of the "tweaks" of the fsx.cfg file will make performance either less stable or worse. FS already determines the best settings for the system when first launched, any modifications will probably be best done through the sliders.Best regards.Luis

Share this post


Link to post
Share on other sites

Futz'n with the 'fsx.cfg' file might make the sim run worse.Maybe an 8800GT with newer drivers would help.Have you tired letting fsx build a new fsx.cfg file?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this