Sign in to follow this  
Guest mirand

Dep Crash after SP2

Recommended Posts

I am disapointed!!!!! After install the SP2 I am unable to start FSX. Windows Vista 32 shows an error message about DEP. Is there a solution or just uninstall SP2????My systen: Intel quad core, 4 GB memory, Nvidea 8800GTS driver 169.06ThanksFernando

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

LOL, this would be Odd, but if you are not joking, try to disable DEP (run "cmd.exe" as Admin and execute "bcdedit.exe /set {current} nx AlwaysOff").

Share this post


Link to post
Share on other sites

Unfortunately this thread does not change the error. I am uninstaling SP2!!!!ThanksFernando

Share this post


Link to post
Share on other sites

>Unfortunately this thread does not change the error. I am>uninstaling SP2!!!!>Thanks>FernandoThat's the spirit! Throw up your hands and not even look for the problem... You spent what - almost a whole hour looking for a solution? :-lol

Share this post


Link to post
Share on other sites

DEP can help protect your computer by monitoring your programs to make sure that they use system memory safely. If DEP notices a program on your computer using memory incorrectly, it closes the program and notifies you. I believe your problem is with your video card display drivers conflicting with FSX. Recommend you uninstall, then use a driver cleaner, and reinstall. Also make sure you have the latest Vista Updates, especially the hotfixes related to memory (a search on this forum using hotfix as a keyword will pull up threads relating to these hotfixes and possible links). Best regards,Jim

Share this post


Link to post
Share on other sites

>>Unfortunately this thread does not change the error. I am>>uninstaling SP2!!!!>>Thanks>>Fernando>>That's the spirit! Throw up your hands and not even look for>the problem... >>You spent what - almost a whole hour looking for a solution?>:-lol Well, gee, I think many of us spend most of our flight time just trying to get FSX to run efficiently and correctly.

Share this post


Link to post
Share on other sites

>>>Unfortunately this thread does not change the error. I am>>>uninstaling SP2!!!!>>>Thanks>>>Fernando>>>>That's the spirit! Throw up your hands and not even look for>>the problem... >>>>You spent what - almost a whole hour looking for a solution?>>:-lol >>>Well, gee, I think many of us spend most of our flight time>just trying to get FSX to run efficiently and correctly.And many of us don't. It just works.Here's a little piece of logic test for you: If you and I are running the exact same FSX installation (and we are)... and yet FSX doesn't work on your system but it works fine on mine... where does the most probable fault lie?

Share this post


Link to post
Share on other sites

Fernando,you restarted your system? Sorry, i forgot to mention this, because it's self-evident for me, but perhaps not for you, because after disabling of DEP, there should be at least no DEP error occur anymore.Here you can get the hotfix, which Jim mentioned: http://www.nvidia.com/object/windows_vista_hotfixes.htmlWindows Update is also very important and the latest Nvidia driver (from the Nvidia page, not from Windows Update), if you are using a GF8 card. With "bcdedit.exe /set {current} nx AlwaysON" you can enable DEP again, but a few 3rd party add-on installer are having problems with DEP.

Share this post


Link to post
Share on other sites

Yes!!!I instaled all the hotfix (some of then are not applicable to my systen) and disabled DEP. After reboot the problem persist.ThanksFernando

Share this post


Link to post
Share on other sites

You cannot disable DEP for FSX underneath Vista. FSX requires DEP to be enabled.Are you overclocking your PC?? The most common problem I've seen is that your overclocked abit higher than your system can actually handle (even if your system appeared to work fine prior to SP2). If your overclocking try reducing your overclock and see if that fixes the problem.Another possible cause could be corrupt scenery.

Share this post


Link to post
Share on other sites

Can you please post the error message and the event log?Thanks!

Share this post


Link to post
Share on other sites

Why should FSX require DEP? When i used Vista32, i had disabled it without any problems.Now i'm using Vista64, which doesn't allow the full disabling of DEP.

Share this post


Link to post
Share on other sites

Nils,I have no idea. But I'm running Vista 32 Ultimate and it does not allow full disabling of DEP either and if you try to include FSX on the "disable list" Vista will say that it cannot disable DEP for this application it is required to be enabled.

Share this post


Link to post
Share on other sites

NilsAfter disable DEP, there is not a message error or log. The windows shows a message that the program need to stop and close FSX. No message, no DEP message!!!!!!Fernando

Share this post


Link to post
Share on other sites

Hm, do you load any dlls with FSX? I would disable all Dlls in the DLL.XML (you can find it, where your FSX.cfg is and edit it: True ). Also move your "Modules" folder (if you have one, it doesn't exist by default) to your desktop (don't delete it, only move it outside the FSX folder).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this