Sign in to follow this  
n4gix

SP2 & DX10

Recommended Posts

Hello.Hopefully someone will be able to answer this for me.I have installed SP2 for FSX (the install went fine) but DX10 was not installed with it. If I run dxdiag it still stays 9.0c and I do not have the checkbox in the Graphics area of FSX to enable the preview option (or whatever it is). Can anyone tell me why this might be?Any help would be appreciated.Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your graphics card is not DX10-capable (most likely reason). What video card do you have?

Share this post


Link to post
Share on other sites

DX10 is only available on Vista.Even then, you need:1) a DX10 GPU ( nv 8xxx series, ATI 2xxx series )2) a DX10 driver for the GPU3) a DX10 app like FSX-SP2.if you dont have all of these, you dont get the checkbox.

Share this post


Link to post
Share on other sites

Are u running Xp or Vista?What Video card do you have as only Vista and a few Video Cards can run Direct X 10.e.g Nvidia Ge Force 8800 series.

Share this post


Link to post
Share on other sites

I just went through all of this with someone here a couple of weeks ago regarding the SP2 update.The video card is DX10 cable (Nvidia 8800) and was told the even though the computer is running XP there was still going to be some benefit (although obviously not all) from installing SP2 and that the option to enable the DX10 Preview mode (in the sim) would still be available.However, it doesn't look like DX10 was even installed because dxdiag is still showing 9.0c.

Share this post


Link to post
Share on other sites

There are indeed benefits to running SP2. Whether you choose to have DX10 enabled or not is dependant on the three criteria Phil Taylor outlined above. Running Windows in any flavor other than Vista will prevent you from seeing the DX10 preview. Regards,Jim Karn

Share this post


Link to post
Share on other sites

>DX10 is only available on Vista.>>Even then, you need:>1) a DX10 GPU ( nv 8xxx series, ATI 2xxx series )>2) a DX10 driver for the GPU>3) a DX10 app like FSX-SP2.>>if you dont have all of these, you dont get the checkbox.Phil Taylor... It appears that I have all of the above but I still don't get the checkbox. Is there some way I can verify the SP2 installation on FSX via a version number or similar, and if so where would it be located?With thanks,Chris Porter:-outtaPerthWestern Australia

Share this post


Link to post
Share on other sites

>There are indeed benefits to running SP2. Whether you choose>to have DX10 enabled or not is dependant on the three criteria>Phil Taylor outlined above. Running Windows in any flavor>other than Vista will prevent you from seeing the DX10>preview.> >Regards,>Jim KarnOkay, two questions...1) So it's normal that DX10 did not install with the SP2 update?2) If that's true, I am still getting some benefit to the SP2 update without the DX10 Preview checkbox available in FSX. Is that right?

Share this post


Link to post
Share on other sites

let us make sure we are talking the same thing.the DX10 runtime is present by default in Vista, it is part of the default OS.the fact that DXDiag does not show DX10 as present indicates a problem with either your OS or your hardware driver.FSX-SP2 is just the last of the requirements, a DX10 application. it has nothing to do with what DXDiag shows as part of your OS.to understand what is in SP2, please see my blog post back in October.

Share this post


Link to post
Share on other sites

1. DX10 installs with the Operating System (Vista) not SP2. If you are running Vista you have DX10. If you're running XP you have DX9 and will never have DX10.2. Yes, the non-DX10 benefits of SP2 are present with DX9 also.Doug

Share this post


Link to post
Share on other sites

If DXDiag is reporting only DX9.0c, then there is an issue with your OS or with your GPU/driver. And that is likely what is preventing FSX from detecting the presence of DX10 and offering the checkbox.The Help->About dialog contains the FSX version number string, what does it say.

Share this post


Link to post
Share on other sites

"Phil Taylor... It appears that I have all of the above but I still don't get the checkbox. Is there some way I can verify the SP2 installation on FSX via a version number or similar, and if so where would it be located?"Chris,I believe Phil is on vacation this week and is answering some posts so he may not get back to you but I believe I have the answer for you. Find your FSX.exe application in the main FSX folder, right click and select Properties. Hit the Details Tab and you should see the version in parenthesis after "Product Version". I have Xpack installed so it states I have the Version 10.0.61637.0 (FSX-Xpack 20070926-1....). If you're not getting the DX10 preview to show up, then you might check the FSX Display settings and make sure your video card is shown. If not, you'll need to reinstall your video card display drivers. To make sure you have DX10 properly installed, you should click on the Start menu, click on Run and type in dxdiag and select OK. Hope this helps.Jim

Share this post


Link to post
Share on other sites

I think you guys are missing one important point. I am not running Vista. I am running XP.I know the Vista is required to get the full benefits from DX10 & FSX SP2, but, from what I was told before I thought that DX 10 would still get installed.As far as the FSX application intself goes, yes, the version number says SP2. I know that part worked okay. It's the DX10 issue that I was wondering about. Like I said, I thought even though I am running XP that DX10 would still be installed but perhaps that is not the case. I guess that's what I am trying to find out for sure.

Share this post


Link to post
Share on other sites

You have misunderstood.Vista is required to use DX10.Yes, FSX-SP2 offers some benefits to DX9 users on XP.

Share this post


Link to post
Share on other sites

Jim,Looks like it was my mistake :-( I installed the SP2 SDK rather than the SP2 application, all is good now and the results are pretty darn amazing.Thanks for your help, and thanks ACES, a job well done.Cheers,Chris Porter:-outtaPerthWestern Australia

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this