Sign in to follow this  
Guest UlfB

How do I get rid of Stutters?

Recommended Posts

I thought I got rid of the stutters and reduced my blurres.But for some reason, both have come back... The Stutter is so distracting, I can't continue.My PCCore 2 Duo. OC to 3.3Ghz. 2Gh. have the 3/G switch to get rid of the OOM errorsGTX 8800FSX and all scenereis are in a Defragged (last night) 2 X Raptor in RAID 0. Win XPThese are the all the fSX.cfg changes I had made to reduce my stutter and blurries problem. If I remove all of these changes... I get blurries and all those neon color textures.1. FIBER_FRAME_TIME_FRACTION=0.602. SWAP_WAIT_TIMEOUT=603. MipBias=64. TEXTURE_BANDWIDTH_MULT=305. AffinityMask=2//where// n num of cores scheduled//1 = 1 core 0001//3 = 2 cores 0011//7 = 3 cores 0111//15= 4 cores 1111I have limited my FPS to 29 and I get 25FPS.Any ideas?Manny

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Manny,i would suggest you to delete your FSX.cfg and let FSX rebuild a new one. And then try it without any tweaks. You can experiment with:[bUFFERPOOLS]Poolsize=6000000"5. AffinityMask=2"3=dual core. But normally, you don't need this entry. You can experiment with Frames set to unlimited or lock it to 25. And don't maximize your ai-traffic and scenery settings.Good luck!

Share this post


Link to post
Share on other sites

Manny,AffinityMask = 2, is bit mask 0010, which means that FSX will only use one core. Try to comment out the AffinityMask setting or change it to 3 (0011) so that FSX uses both cores. Must be better imo.Ulf BCore2Duo X6800, 4GB RAM, BFG 8800GTXCreative SB X-Fi (Gamer mode)Vista 32 SP1 RC, FSX Acc/SP2

Share this post


Link to post
Share on other sites

I searched my FSX.cfg for these settings but they are not there? Are they settings to add, if so, where please?

Share this post


Link to post
Share on other sites

Manny,I've just been experimenting and find that I get the benefits of a high FIBER_FRAME.. setting without the drawbacks if I set it to the default 0.33, and instead set the LOD_RADIUS seting to a higher number than the defualt 4.5 set by the Scenery Tab (7.5 seems to work well in my case, but I'm using a Quad Core so you'll have to experiment). This seems to cause the ground text to pre-load to greater extent, so its not blurred when you fly over it.PS - Delete the CFG file and let SP2 build a new one before you apply any changes like this (removes any old settings).PPS - I'm also running Unlimited Frame Rate, and have Core Affinity set to 14 (i.e. like your setting it locks out Core 0 - othewise its the stock settings set by SP2).Try Unlimited Frame Rate for a while - I've come to the conclusion that it offers very little (if any) drawbacks in terms of picture quality etc. (In fact, it allowed me to move some of the scenery sliders to the right. Basically, I picked a dense area (New York), loaded up to sliders until the peak frame rate fell to about 40 FPS or so, and then just use those settings everywhere.A few posts here have suggested that this is also a multi-core system phenomena, so again your Core Duo may perform differently to my Quad)Bob,

Share this post


Link to post
Share on other sites

Manny wrote: "I thought I got rid of the stutters and reduced my blurres.But for some reason, both have come back... The Stutter is sodistracting, I can't continue."Manny, somewhere in the past couple of days I read a post similar to yours, the poster had been enjoying good frame rates and no problems, then out of the blue the frame rates dropped. He had made NO changes during the interim, no changes and yet the performance of FSX dropped. The poster had gone to great lengths to un-install, re-install, defrag, re-install all his add-ons, etc. No luck he said...still had blurries, still had lowered fps. Next day, no apparent reason, everything now was back performing well. Incredible!There's simply something about this FSX that requires constant vigilance , constant tweaking. And for certain, one never knows what a single add-on might do to change it...for better or for worse. I don't know if it is the FSX program that is so inherently unstable or simply extremely sensitive to ANY changes within the computer operation, be it the operating system, or changes to background tasks or whatever. It'll drive you silly trying to fix.bill

Share this post


Link to post
Share on other sites

>There's simply something about this FSX that requires constant>vigilance , constant tweaking. And for certain, one never>knows what a single add-on might do to change it...for better>or for worse. I don't know if it is the FSX program that is so>inherently unstable or simply extremely sensitive to ANY>changes within the computer operation, be it the operating>system, or changes to background tasks or whatever. It'll>drive you silly trying to fix.Yeah, it's the blurrie monster :-jumpy Hiding under your pc, and returning whenever you turn your back to FSX.Ulf B

Share this post


Link to post
Share on other sites

.. and it could just be the effects of the holiday "celebrations"... :+

Share this post


Link to post
Share on other sites

Hi Dave,you have to add those entries to the FSX.cfg, but there is no real need for this tweaks. They are only fine tuning and not a magic thing, which will allow you to run FSX perfect with an old PC.Here you can find the explanations from Phil:http://blogs.msdn.com/ptaylor/archive/2007...aks-in-sp1.aspxhttp://blogs.msdn.com/ptaylor/archive/2007...-week-or-2.aspxI think it's better to use the sliders in the settings menue, because if you get the really bad blurries and stutters, it is really a sign, that your machine is overchallenged. For configuring FSX, i had choosen New York and i used one of my add-on airplanes which gives me the worst FPS, weather theme=gray and rain and ai traffic to about 100 airplanes (enable the traffic explorer in the dll.xml and monitor your ai traffic). If you now set your sliders so that you are able to fly with the above mentioned settings in New York, you will be able to enjoy FSX world wide. You always have to consider the complexity of FSX (ai traffic+weather+scenery+water), so there will be always places where you have good FPS and there will be places/situations, where the FPS will drop dramatically because of the complexity. Sorry for my bad english and Happy new Year!

Share this post


Link to post
Share on other sites

Hi.. I'm in the same boat, after trying/testing ALL the tips in david roch's thread I still have the same problem, bad stuttering> poor frame rates. Dell XPS720/4GBs Ram/Nvidia8800GTX/QX6700 IntelCore2 Extreme processor. Fresh XP install, all drivers up todate. Separate HD FSX is installed > De-fraged and TuneUp Utilities 2008 used. For me problem never happened before SP1, was hoping problem would be fixed for SP2 and its still there. I've been around and flying flight sims since the ole Flightpath 737 days on the Vic-20. So like many here been around the block with tweaking sims lol. But I don't have time for it any more, I want to enjoy to as close as I can get with using all the features a game has to offer. IE Maxing out the sliders.I can do it with any current game out atm I play. COD4/Crysis/MOHAirborne/NFSProstreet/Eve-online - and still get very respectable frame rates and most important enjoy the game without have to worry is my computer going to be able to run this game. While no PC game is perfect, in this day and age this kinda stuttering effect while playing FSX is unacceptable. It should be been addressed in SP2, as the problem was known ever since SP1 came out. I mean its one thing to have the deal with average frame rates, on settings not even close to be maxxed out on the computer that exceeds the recommend specs that MS require to run FSX, but its another thing to have the deal with this stuttering and lagging. I don't mean to come across harsh, but I see alot of others having the same problem as I and very little been done about it. So I ask Microsoft is this problem going to be addressed and if so what kinda time frame we looking at for it to be fixed. Thanks ..

Share this post


Link to post
Share on other sites

Follow Dave Roches installation procedure if you want stutter free/high fps fsx simming.

Share this post


Link to post
Share on other sites

I don't have any stutters on my new machine-but on my old:settings of autogen/water/aitraffic (cars/boats/air traffic) along with shadows and high antialiasing settings could all cause stuttering. Turn them down -then turn them up to a level where it doesn't happen-or upgrade for the ultimate freedom! :-)http://www.mediafire.com/imgbnc.php/1b5baf...b9f427f694g.jpgMy blog:http://geofageofa.spaces.live.com/

Share this post


Link to post
Share on other sites

>Follow Dave Roches installation procedure if you want stutter>free/high fps fsx simming.As stated in my 1st post, I have :) just like many others who still have the same problem.

Share this post


Link to post
Share on other sites

I'd be willing to bet that most causes of stuttering (and many more evil symptoms) happen to those of us with _only_ 2GB of memory. I was having stuttering and pauses and finally correlated it to paging by the system. I've just switched to a fixed size page file on a different drive and so far it seems like it might have helped. I'll be looking for more memory as soon as I can.I'd be curious to find out what percentage of people who have many problems only have 2GB vs. people with great running systems and 4BG. Also if Phil or anyone at Aces has done any profiling to see how much memory you really need and what settings really use up the memory or what features might have severe memory leaks. Don

Share this post


Link to post
Share on other sites

>>>I want to enjoy to as close as I can get with using all the features a game has to offer. IE Maxing out the sliders.This is a mis-conception..Enjoying means finding a reasonable balance between what your computer can handle and the level of detail you experience.As documented countless times, "all sliders to the right" is not the way to fly FSX.

Share this post


Link to post
Share on other sites

>So I ask Microsoft is this problem going to be addressed and>if so what kinda time frame we looking at for it to be fixed.I think Phil Taylor has made it quite clear that there will be no further work done on FSX. Period. End of sentence... :-halo IMHO, the single biggest problem with FSX in most cases lies behind the keyboard... :-outta

Share this post


Link to post
Share on other sites

>and have Core>Affinity set to 14 (i.e. like your setting it locks out Core 0Bob, Phil has made it very, very clear that this "Affinity Mask" only affects threading. FSX 'core' continues to run on Core 0, irrespective of the Affinity Mask.With the improvements made to their threading, this setting has lost any real value for Quad Core owners. ;)

Share this post


Link to post
Share on other sites

Not sure if this is of any consequence, and I don't remember if David or Geofa posted this, but I used to get frequent stutters, and after changing the below information I haven't seen the stutters since. Anyways, it's worth a try.TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4000TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0000Happy New Year everyone.

Share this post


Link to post
Share on other sites

>Not sure if this is of any consequence, and I don't remember>if David or Geofa posted this, but I used to get frequent>stutters, and after changing the below information I haven't>seen the stutters since. Anyways, it's worth a try.>>TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4000>TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0000>>Happy New Year everyone.>I might add that the above lines should be added under the section TERRAIN in your fsx.cfg file.The fsx default values are:TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4500TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=3000Ulf B

Share this post


Link to post
Share on other sites

Bill,Sorry, but I have to disagree with Phil about the effect of Core Affinity.In my case the benefit is not so the frame rate, but the initial loading speed of the game from the hard disk almost doubled when I changed the Core Affinity to 14. (My default flight is on the boundary of two large areas of VFR scenery which may go some way to explain this effect). PS - With this setting, FSX uses about 30% of Core 0, 100% of Core 1. Cores 2 & 3 are a bit more variable (depends where you fly) - typically they both run at 100% for a 5 to 10 seconds, then decline to 25% for a second or so, and then return to 100% and repeat the cycle. So all four cores are used, the main change seems to be that the majority of the work moved from Core 0 to Core 1.

Share this post


Link to post
Share on other sites

I know that that is what Phil said, but the heavy load, pretty much 100% utilization all the time, moves from core 0 to core 1 and leaves core 0 lightly loaded, when using a mask of 14.

Share this post


Link to post
Share on other sites

I use the BufferPools tweak except that I find that the value suggested above doesn't enough for me. I was still getting bad stutters until I read something that someone over at FSW had done, they had set their BufferPools to 100000000 (100MB.) I use 110MB or, 110000000. The amount suggested above, "Poolsize=6000000", is only 6MB!!! Thats barely using any of your video card's memory. It works best if your card is 512MB or over but if it's lower than that, you can experiment with lower values. When you start seeing wierd things like wheels sticking up out of the plane's roof etc, just reduce the value by 10MB and try that. I hope this helps, it sure helped me!

Share this post


Link to post
Share on other sites

i fully agree to this, geofa. And to add a few. SP2 without any tweaking in the cfg file except maybe the max_autogen_buildings and trees tweak makes the best performance, the other tweaks are RTM or SP1 and much of a cause for stutters with SP2. And when overclocking the system, don't take it to the max and don't overclock the graphic board. MHO :-)Regards, Gerrit Kranenbarg


http://www.oncourse-software.co.uk/forum_images/pfe_team.jpg

Share this post


Link to post
Share on other sites

Ulf,I have got to thank you for this tip. With just 2GB RAM it's cured my stutters.Using.........NVidea 6800GT and dual core CPU

Share this post


Link to post
Share on other sites

Why not simply lower the autogen settings in FSX...? It seems sometimes people don't mind editing cfg's but changing simple menu-options is a no go... (I know you can't change autogen trees and houses apart from each other in FSX, but still, removing all houses is more drastic than simply lowering autogen and have fewer trees and houses.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this