Sign in to follow this  
vsukpadman

FSX SP2 vista Nvidia Magic Bullet .. this REALLY works !

Recommended Posts

Ok ..VERY high spec machine Dual intel 5160 xeon 3 ghz, 3 gig ram, Nvidia 880O ULTRA(768 MEG).I tried EVERYTHING to make this run as advertised, using the great setup advice here,(clean vista, clean fs , then sp1/2 defrag etc etc) and was getting 10-15 FPS with low slider settings . (dx10 preview enabled)I really was tearing my hair out ,and was about to trash vista/fsx! and discovered this...1) MAXIMISE the window in windowed mode..observe YOUR frame rate.(this is how I was using it)2) Hit the restore down icon (top right next to the red cross icon ) to allow you to manually size the window.3) Grab bottom right handle, and drag in around 3 or 4 milimetres (nothing at all basically)so you are SLIGHTLY reducing the size of the screen by around 3 or 4 mm NOW look at the frame rate... it seems that this alone jumps mine from 15 to 60! with ALL sliders to the right!Maximise it again and watch em drop thru the floorI have asked three other Nividia owners to try this , and it works for all of them, but NOT ati owners it seemsThis is a magic bullet for me, and im not imagining it!any ideas why?Not questioning it - it works!Bill PLondonUse WINDOWED mode ...

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Bill,Are you getting 60FPS in London? If so, post a screenshot with Shift-Z enabled so we can see the 60FPS.

Share this post


Link to post
Share on other sites

I believe flying in full-screen mode will also yield much better frame rates. Any reason why you're flying in windowed mode? (just curious :) )James

Share this post


Link to post
Share on other sites

I totally disagree with that, windowed has always given me more FPS than full screen...I spose its just different configs

Share this post


Link to post
Share on other sites

I agree, going into full screen mode doubles my FPS compared to windowed mode. One question, however, I have a second monitor which I am running FS Commander on. It works great in the windowed mode, but in the full screen mode the second monitor is black, no FS Commander to be seen. What am I doing wrong? Any help would be greatly appreciated.ThanksBernd

Share this post


Link to post
Share on other sites

Jim,Thanks for your response, does that mean that I either have to accept a 50% drop in FSP and can use FS Commander on a second monitor, or have much higher FPS in a full screen mode but without FS Commander?Bernd

Share this post


Link to post
Share on other sites

>I totally disagree with that, windowed has always given me>more FPS than full screen...I spose its just different>configsRyan, are running full screen or windowed mode in FSX/SP2?I can say that fullscreen on my system yields MUCH better FPS than windowed mode.:-)

Share this post


Link to post
Share on other sites

Bernd, I haven't tried it but Jim is probably right...FSX multimonitor support may be the culprit there:-)

Share this post


Link to post
Share on other sites

Thanks Ron, I guess I have to wait for a moving map/planner program which resides inside of FSX so that I can move it to a second monitor. I'd love to see a full screen moving map especially with my SR 22.

Share this post


Link to post
Share on other sites

Hi allwill take some screenshots later.I also suffer from a black second screen Im afraid, so full screen mode is out for me ! This trick solves the problem beautifully..the question is WHY?What is technically happening to cause this massive difference by moving the screen size less than 5 mm?There would be a lot less people moaning about FSX if they just tried this :-)BERND- you dont have to suffer the drop, thats the point of my post, this trick will give you the FPS and a second monitor, but in windowed mode.cheersBill PLondon

Share this post


Link to post
Share on other sites

Bill, please let me see your screen shots.ThanksBernd

Share this post


Link to post
Share on other sites

Just to report that I experience no difference in fullscreen, windowed, or reduced windowed. Using latest Nvidia drivers.Asus P5K, Intel Core 2 Duo E6850 (3.4GHz), 2GB PC6000 DDR2 RAM, POV GF8600GT 256MB. TrackIR PRO 4.

Share this post


Link to post
Share on other sites

Done some more investigation on this..heres what I foundwith DX10 preview ON , this trick works..frame rates are very high.with DX10 preview OFF , the trick does NOT work...frame rates are low and the same maximised or reduced.Problem is, with DX10 preview ON, I cant get AA to work at all well except by using the AA tickbox in game (which I believe is set to 2x), Nhancer does not seem to work in Directx10 preview mode (this is reported as a bug/feature by many)Does anyone have DX10 preview on, AND is getting sharp AA, if so , how?cheersBill PLondon

Share this post


Link to post
Share on other sites

I can verify this. Whereas there was no difference in DX9, switching to DX10 preview increased the frame rate when switching from windowed to fullscreen or reduce the window. However, the problem with this is that, even though the frame rate is good, I get microstutters which make the sim unpleasant to use.

Share this post


Link to post
Share on other sites

>Bernd, I haven't tried it but Jim is probably right...FSX>multimonitor support may be the culprit there:-)They did it so that we don't have to "undock" windows anymore to drag them over. I for one much prefer it to FS9.

Share this post


Link to post
Share on other sites

Bill, I got it to work with 169.28 drivers. Check it on in the game with ansiotrophic (not trilinear) and make sure your driver settings 'use application settings'. Also, make sure you set antialiasing gamma correction and supersampling on.jja

Share this post


Link to post
Share on other sites

JJAthnx for the info..yet MORE new Nvidia drivers ...hmm quantity over quality springs to mind :-) LOLwill give them a try ..cheersBill P

Share this post


Link to post
Share on other sites

>This is a magic bullet for me, and im not imagining it!>any ideas why?I've seen this a lot in my work, albeit with 2D video rendering rather than 3D rendering, but I imagine the principle is the same.A lot of video drivers are optimized for the case where the horizontal resolution of the display surface is a multiple of 4 (or sometimes 2, or possibly even 8 or 16 depending on the driver and the hardware). I'm guessing that your frame rate shoots up whenever your window size hits such a multiple, and drops when the resolution is an "odd" number.Obviously in full screen mode this shouldn't be an issue since the horizontal resolution will always be a multiple of some fairly high power of 2.Colin

Share this post


Link to post
Share on other sites

Hello, i'm running dx10 on a amd 6000 at 3.02 and 4 gigs ram and nvidia 8800 gtx 768. i have gotton results that work for me. Average frames 25 in cities and 40 to 60 every where else.first running 169.12 drivers from evgaNvidia control panel - Program settings - ms flight simulator xanisotropic filtering 16xantialasing-gamma correction onantialasing-mode overrideantialasing-setting 4xantialasing-transparency offconformant texture damp offerror reporting onextension limit offforce mipmaps nonemulti-display single displaystereo use on boardtexture filtering anisotropic offtexture filtering negative lod allowtexture filtering quality hightexture filtering trilinear offtreaded optimization offtriple buffering offtexture filtering offvertical sync use appliction settingfltsimx -dx10graphics everthing on full except light bloom Scenery detail - largemesh comp. 75mesh res. 19tex. res. 30water aff. 2.xland detail onscenery comp. fullautogen denseno shadowsspecial affects fulltraffic default or slightly betterweather default or slightly bettercfg fileFIBER_FRAME_TIME_FRACTION=0.50TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2000TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=1000only 3 changesi enjoy flying around vancouver and vancouver island with van+ and vic+ and get frames from low twenties to 50.attached screen shot of london downtown avg over 25 frames maybe these setting might help.

Share this post


Link to post
Share on other sites

Colinvery interesting stuff..you would think Microsoft would maybe mention this, as its NOT obvious to go from windowed maximised , to windowed sized..Most people will use maximised , which kills the frame rate.I discovered it completely by accident :-)thnx for the infoBill P

Share this post


Link to post
Share on other sites

Thanks for the settings...I notice you are not using Nhancer, but setting direct from the nvidia control panel .Im still not happy with my performance in FSx at all , given that I have a Dual xeon 3 gig, 3 gig ramNvidia Ultra 8800I will experiment with your suggestions..there SURELY is a way to make this setup "fly" :-)CheersBill p

Share this post


Link to post
Share on other sites

It always used to be the case that windowed mode didn't use all the features of your graphics card.Could be that the DX10 features active when in full screen are simply not working when in windowed mode and therefore, without the extra processing, the FPS increases...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this