Sign in to follow this  
Bert Pieke

Disappointed with FSX performance

Recommended Posts

What's new, right?I spent $1500 on a high-end system, and I am having a hard time understanding why I can't get good performance like other people seem to boast with similar or lesser systems than what I have.Running a AMD 6400 X2, Geforce 8800GTS 512, 2GB 1066 RAM, and a bunch of other high-end components, running on Vista. If I turn it all up, I get maybe 15FPS... I have to put water on 2x Low with no traffic, no bloom and usually half or no Autogen to get acceptable performance (25+ FPS). Yes I know, forget the FPS and just worry about it being smooth. Well, I don't know about you but 10-15FPS isn't smooth to my eye. Not only that, but I keep getting these freeze-ups with a stuttering sound for about 5 seconds (count it out... thats a long time when youre trying to have a fun flying experience).All my other games run like a champ (even Crysis... reportedly one of the harshest games today for hardware) and Call of Duty 4, as well as various other games, most of them on very close to maximum settings.Can someone please give me some pointers in regards to what really kills performance in FSX and what I probably should have my settings at, as well as any .cfg tweaks I should do? Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First of all, make sure you have SP1 and SP2.Next, no system today can run FSX full out. It was designed so that hardware 3 or so years from now can run it like that, so it's a futureproof game. That's how it's always been. Autogen, traffic, and especially light bloom are the killer options. Leave traffic low-ish, autogen at about medium, and light bloom...don't enable it unless your frames are over the 50s and 60s. Then, when you enable it, your frames will drop to a still playable 25-30 FPS.Also, I would look into overclocking. You can get a lot more frames that way.

Share this post


Link to post
Share on other sites

I definitely have overclocking potential... I have a Black Edition 6400 X2, which means that it is overclockable, and I also know that the 8800GTS 512 can be overclocked to outperform the 8800GTX. I also have the cooling ability as well (Antec 900 case with a huge Zalman CPU cooler) so I may look into overclocking.I also want to pick up another 2GB of RAM sometime as well.

Share this post


Link to post
Share on other sites

Yes, the extra 2 GB of RAM will help a lot. Vista and FSX each have a 2 GB barrier, unless the /3G switch is enabled. Since you only have for now 2 GB of RAM, FSX and Vista are fighting over the RAM, causing stutters. So 4 GB will help immensely. Just make sure you have Vista 64-bit so that all 4 GB, not just 3.2 GB, of RAM will be recognized.FSX+XP=2 GB of RAM is sufficientFSX+Vista=2 GB minimum, 4 GB best.BoeingGuy

Share this post


Link to post
Share on other sites

Nope.http://forums.microsoft.com/TechNet/ShowPo...72502&SiteID=17"The OS isn't necessarily taking up 1.2 gigs. The problem is 32 bit OS has a memory limitation, it can only use 4 gig of memory, this includes video memory and the memory I/O devices are loaded into memory by your mother board. The 4 gigs, they're there, it's just after calculating devices and video there's only enough room left to see ~3 gigs. If you where using a 64 bit OS you would see all 4 gigs."Actually Vista 64 will recognize over 128 GB RAM :D.

Share this post


Link to post
Share on other sites

Geezus... 128GB? That's freaking wild lol.So... would you think I'd be better off just buying one more 1GB stick instead or might as well go for two?

Share this post


Link to post
Share on other sites

Todd I would go for a matched pair if I were you.. that would be best. Also, you might want to check how many processes you have running in your task manager.

Share this post


Link to post
Share on other sites

Well, it's up to you. With 4 GB, you'll have the absolute max the OS can see, and it'll mean more memory for the I/O and the video devices. With 3 GB, you'll have 1 GB of RAM for the OS and 2 gigs for the game, and it is slightly unbalanced. I agree with Tim.

Share this post


Link to post
Share on other sites

Yea, it appears you've pretty much arrived. FSX is still a single core app that has enabled multicore capability (primarily) to load pre-flights and in-flight scenery. Frame rates between 2 and/or 8 cores won't matter. FPS wise, this is still a single core game.An AMD 6400 at 2.4ghz will run about with a Core 2 at 2.2ghz. So, that's a single core at 2.2 trying to run FSX? That's not going to do it. What will it take? For instance, we have a Penryn around that is running at 5.7ghz that claims to finally get the sliders full right. But still, that quad is only using a Single Core for other-than-scenery-loading duties. A $250 Q6600 @ 3.6ghz is still our best bet. You are going to have to live with stuff shut down. So, try Ground Environment X, a good landclass (Ultimate Terrain for cities and maybe SceneryTech for the rest), then turn Off autogen completely. Traffic's gotta go. We just don't have the HP to spare. Add another 2gs of ram. Vista 32 will at least use 3 of it. Vista 64 will use the rest. This is Not app dependent. FSX will use whatever is available.Good luck,

Share this post


Link to post
Share on other sites

I have GEX and UTX, so the game looks decent without Autogen, and I'm not too picky about having airplanes everywhere... so it's acceptable but I was just surprised to not see a better improvement. I'm sure we've all said this before but... maybe in the next version :)

Share this post


Link to post
Share on other sites

You don't need Vista 64. Sure, it helps, but you can get very decent results with 32. Even though the system reports only about 3.2 Gb when you have 4 (make sure you have 4, that will REALLY make a difference), it is using all 4 Gb (the difference is being mapped to your video card memory: the more your board has, the less your system will report).Yes, FSX will be limited to 2 Gb, but it will run very fine. You can give it more, requires some boot parameters (search for a post from PTaylor), but Vista will suffer. Unless you get OOM's crashes, you don't need more than 2 Gb assigned to FSX. Most of the time, it won't use that much.I'm running FSX on Vista32 with 4Gb, 8800 ultra, and I'm quite happy (never go under 20, even with lots of traffic, and inflight I can usually get more than 50, smooth and stable). Don't go for "everything maxed", you really don't need it. The sky will be overcrowded, the autogen is not that beautiful, it will cover up the very nice textures, loading time will suffer (blurs). Go for GEX (AWESOME and FPS friendly), autogen normal, 38m, 1m textures, forget about bloom and set water effects to 1.0 (high or low, your taste). The textures will be beautiful, sharp, will load in time and you'll have an overall awesome flying experience. (OK, I have a pentium quad system, but it doesn't help that much, see other posts.)Make sure to do a clean install of FSX with SP2. Than, put your addons one by one, carefully checking the results. Your system is more than capable of giving you a very nice FSX experience, it only needs those extra 2Gb of memory.If you have the extra cash, go for Vista 64 and give it all the memory you can afford. But, trust me, you don't really need it.Ah, last but not least, forget about DX10 preview. On some systems, and maybe this is your problem, the FPS go way down when you use it. It is a lot to pay for some very disappointing effects (IMHO, of course).Cheers,Sergio

Share this post


Link to post
Share on other sites

You might want to try what I do-autogen maxed but buildings turned "off". This allows the high res textures to show thru with full trees. I do this not for performance but for greater reality looks.Under terrain in your fsx.cfg file add:TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4500TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0000Then crank your autogen to the max!http://www.mediafire.com/imgbnc.php/1b5baf...b9f427f694g.jpgMy blog:http://geofageofa.spaces.live.com/

Share this post


Link to post
Share on other sites

Sergio, thanks for your input... thats what I was looking for - someone with a system similar to mine to give me an idea of what I'm missing here, and it certainly sounds like that extra 2GB.I will order another pair of what I already have so there will be four 1GB sticks in there. Will let you guys know how that turns out. I will also be getting a Raptor, as well. (Did not have room in the budget at the time to get a Raptor and/or 4GB when I got the rest of the system)Geofa, I'll give that a try. Trees always look good... but I've always had reservations about the buildings.Thanks a bunch everyone... this has been a great help.

Share this post


Link to post
Share on other sites

Let me mention something that I have not seen others mention in this thread...That is, when you are getting these big long 5 second slowdowns you describe, have you pulled up Task Manager (or whatever Vista has) to see what running process is taking your valuable cpu time when the slowdowns occur?RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

>You might want to try what I do-autogen maxed but buildings>turned "off". This allows the high res textures to show thru>with full trees. I do this not for performance but for greater>reality looks.>>Under terrain in your fsx.cfg file add:>TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=4500>TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=0000>>Then crank your autogen to the max!>>http://www.mediafire.com/imgbnc.php/1b5baf...b9f427f694g.jpg>>My blog:>http://geofageofa.spaces.live.com/Didn't Phil, a while back warn not to set these values to zero? He said, you would get unstable results I think? Obviously your not seeing any issues, so I wonder what he was concerned about?

Share this post


Link to post
Share on other sites

Geofa,I tried your suggestion, and not only did that help a lot, but it definitely does look a lot better in terms of realism! Sergio, I went ahead and set the water back to 1.0, which sucks to lose those nice reflections but that made a difference too. I'm more happy with the sim now with some of those adjustments.McCrash, yes I have it set to Unlimted... seems to be a little bit better than setting it to where it usually is anyway (about 30)Thanks again.

Share this post


Link to post
Share on other sites

>Is there a /3G switch for XP and, if so, how is it enabled?>>Thanks a lot,First off, make sure you have SP2 installed as the FSX executeable included with SP2 is greater than 2GB aware.Configuring MS Windows XP: add the flag /3GB to the Boot.ini file. To do this just open the Control panel, click on the System icon, on the Advanced options panel, then press the Configuration button of the Start and recuperation section. In this window click on the Edit button inside the System start section and the Notepad will pop-up with the Boot.ini file opened. In this file there should be a line like this:multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetectjust add the /3GB flag at the end, like:multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect /3GBNow the file must be saved, and MS Windows restarted

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this