Archived

This topic is now archived and is closed to further replies.

flilotUK

PLEASE save me from D3D9.DLL h#ll !

Recommended Posts

Has ANYBODY found a workaround or fix for the INFURIATING d3d9.dll errors that persist after the installation of SP2?It's gotten to the point for me where it's almost a 'Russian Roulette' type situation if I need to access the FSX menu, or press ALT+ENTER to go from full-screen to a window during flight, both of which randomly crash FSX with it citing d3d9.dll as the culprit each time. NOTHING is worse than nearing the end of a several hour flight, only to want to quickly check something, with FSX responding with an unceremonius dumping of the pilot back to their desktop. ARGHHHH!My system:Motherboard: ASUS M2N-SLI DeluxeCPU: AMD Athlon64 X2 6000+ (not overclocked)Memory: 4Gb Corsair DDR2 (2x 2Gb sticks, in Dual Channel mode, not overclocked)Graphics: Inno3D Nvidia GeForce 8800GT 512Mb Sound: ASUS Xonar DX PCI-Express SoundcardOS: Windows XP x64 Edition SP2 with all Windows UpdatesDrivers/Software:Nvidia Driver: 177.79 (have tried earlier drivers with no change)DirectX: Latest update, 08/08/2008FSX:Re-installed clean on Thursday 07 August 2008, SP1 then SP2 applied, then all add-ons installed.Add-Ons:Active Sky X (All SPs applied)X Graphics (All Updates Applied)Flight Environment X (SHD Update applied, but not using 4096 clouds)SceneryTech Europe LandclassFScene4X EuropeMyTrafficX (latest update applied)FSDreamTeam O'Hare XBirmingham XtremeEdinburgh XtremeBristol XtremeFlight 1 ATR 72-500 (all SPs applied)Overland Airbus Package (FSX Updated)Overland Boeing Package (FSX Updated)Flight1/Coolsky Super80 ProfessionalAddons/Aircraft error occurs on:ALL AIRCRAFT AT RANDOMActual Error Displayed:AppName: fsx.exe AppVer: 10.0.61472.0 AppStamp:475e17d3ModName: d3d9.dll ModVer: 5.3.3790.3959 ModStamp:45d70a26fDebug: 0 Offset: 000a5ce2Please. ACES, Microsoft, Nvidia, God, ANYONE...Ideas? Help?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I can only sympathise. I have only half your add-ons and only a 7950 Gt card but I have the same problem. I have tried many re-installs, different graphics drivers etc etc but have had three d3d9.dll crashes today. As you suggest no-one seems interested so glad I kept FS9 running.John R

Share this post


Link to post
Share on other sites

This isnt any help for you but I have never had a dll problem with FSX, except when I had a few of the more expensive airplanes installed, I removed them and 0 problems. I forget exactly which one it was causing the problem, but it messed up the dll file in FSX, not SP2XP Pro SP2-FSX SP2AMD FX60-8800GTS-2 Gigs RAMFEX-GEX-UTUSA-FSGenesis-and a bunch of other stuffComputer optimized by www.fs-gs.com

Share this post


Link to post
Share on other sites

You need to know that the d3d9.dll file is a portion of the Microsoft DirectX package. Other AVSIM members who have had this error have attempted to fix errors related to the d3d9.dll file by manually copying the file from somewhere else. This will not work, so do not try this. The right way to get rid of the d3d9.dll error is to reinstall Microsoft DirectX; you can download the most recent version of Microsoft DirectX here: http://www.microsoft.com/downloads/details...&displaylang=en. (Yes, I saw that you have the latest update installed but you still need to reinstall).Your FSX.exe app ver is different from mine and I have FSX Acceleration installed (which installs SP2). My version of FSX is 10.0.61637.0. (Probably not the problem but thought I'd mention it).You state you are using the 177.79 display drivers. I don't see them listed as being compatible with your OS/Graphics card. Perhaps you got your drivers from Inno3D, the manufacturer of your card? There is a beta 177.92 on the Nvidia site which is compatible and is the latest and greatest for your card. The latest WHQL driver (according to NVIDIA) for your OS/Graphics card is the 175.16 driver. Perhaps this is your problem?Best regards,Jim

Share this post


Link to post
Share on other sites

>Has ANYBODY found a workaround or fix for the INFURIATING>d3d9.dll errors that persist after the installation of SP2?>>It's gotten to the point for me where it's almost a 'Russian>Roulette' type situation if I need to access the FSX menu, or>press ALT+ENTER to go from full-screen to a window during>flight, both of which randomly crash FSX with it citing>d3d9.dll as the culprit each time. >NOTHING is worse than nearing the end of a several hour>flight, only to want to quickly check something, with FSX>responding with an unceremonius dumping of the pilot back to>their desktop. ARGHHHH!>>My system:>Motherboard: ASUS M2N-SLI Deluxe>CPU: AMD Athlon64 X2 6000+ (not overclocked)>Memory: 4Gb Corsair DDR2 (2x 2Gb sticks, in Dual Channel mode,>not overclocked)>Graphics: Inno3D Nvidia GeForce 8800GT 512Mb >Sound: ASUS Xonar DX PCI-Express Soundcard>OS: Windows XP x64 Edition SP2 with all Windows Updates>>Drivers/Software:>Nvidia Driver: 177.79 (have tried earlier drivers with no>change)>DirectX: Latest update, 08/08/2008>>FSX:>Re-installed clean on Thursday 07 August 2008, SP1 then SP2>applied, then all add-ons installed.>>Add-Ons:>Active Sky X (All SPs applied)>X Graphics (All Updates Applied)>Flight Environment X (SHD Update applied, but not using 4096>clouds)>SceneryTech Europe Landclass>FScene4X Europe>MyTrafficX (latest update applied)>FSDreamTeam O'Hare X>Birmingham Xtreme>Edinburgh Xtreme>Bristol Xtreme>Flight 1 ATR 72-500 (all SPs applied)>Overland Airbus Package (FSX Updated)>Overland Boeing Package (FSX Updated)>Flight1/Coolsky Super80 Professional>ModName: d3d9.dll ModVer: 5.3.3790.3959 I noticed that you have Flight Environment X (SHD Update applied, but not using 4096). I had the exact same problem you have after installing the SHD update. The solution for me was to was changing from 32bit to DXT5 in FEX. Apparently this is a known issue with SHD. I hope it resolves your issue.

Share this post


Link to post
Share on other sites

Wow, this old topic suddenly got a flurry of answers! :)I fixed my problem - I uninstalled FSX SP2. My flights are now peaceful and error-free. :-halo

Share this post


Link to post
Share on other sites

>Wow, this old topic suddenly got a flurry of answers! :)>I fixed my problem - I uninstalled FSX SP2. My flights are now>peaceful and error-free. :-haloThat's not really a "solution" though, it's simply avoiding the underlying problem... ;)

Share this post


Link to post
Share on other sites

Just thought i'd add that I used to have these all the time, but since upgrading to a 64bit OS (XP) it happens very rarely now. Not sure that is the answer, so far so good. *Knocks on wood*

Share this post


Link to post
Share on other sites

Been there, tried that!!! Along with several uninstalls/re-installs, several different Nvidia drivers, many different graphics settings found on various forums, trying FSX "clean" with no add-ons installed, updated Direct X etc etc. Options left seem to be:1. Fly permanently in window mode2. Fly full screen but change to window for all menu requirements {but there is no guarantee that using ALT - ENTER will not result in a D3D9.dll crash}.3. Fly without AA & AF. Seems to work but loses FSX graphics benefits.4. Keep flying FS9 (I do, but the more I see of FSX the more I see its potential}5, Follow Bill Leaming's experience and change to an ATI card. But a waste of an otherwise good NVidia card and will this will solve the problem on my particular system???But I guess we will keep trying. There must be something in the system set up that differentiates us from others with simiar hardware .....?John Rooum

Share this post


Link to post
Share on other sites

same problem here since SP2. When i access the menus in FSX, the program crashes in most cases. I have a 7800GTX.The only solution is to run FSX in windowed mode.It's annoying, yes, but i started to live with this issue. It seems to be pretty common with nVidia cards/drivers... :-(Cheers,Michael

Share this post


Link to post
Share on other sites

Well it's either an Nvidia or Microsoft issue. There are cases for and against each company. Pre SP2, Nvidia drivers worked fine with the FSX menu. Post SP2, they don't on some cards. Did Microsoft break something, or is Nvidia just refusing to update their drivers? Surely there should have been collaboration and testing between MS and Nvidia prior to the SP2 release.Removing SP2 is a solution for me. I'm not tearing my hair out after a crash to desktop, or on tenterhooks each time I need to access the menu for something. SP1 just works, and performance is great on my system. I have no 'need' for SP2.

Share this post


Link to post
Share on other sites
2. Fly full screen but change to window for all menu requirements {but there is no guarantee that using ALT - ENTER will not result in a D3D9.dll crash}.
Hi All,I just found this topic since I was looking for a solution to this prob as well. I have 2 Nvidia 7900/GT-GTO in SLi config and have the same problem when in 3d mode and accessing any menu. I have had this problem ever since I installed FSx/Acceleration but I only got round to try and solve this just now.There is an extra step to the ALT+ENTER workaround that I have found. I write it as my 2 cents since I see that you experience random crashes when ALT+ENTERing.When switching from 3d to 2d, make sure that the menu is INACTIVE (not shown). To do this, ALWAYS press ALT and hold it for 2 secs before pressing ENTER. It always works for me.If in the meantime there has been found a proper solution to the problem, please be so kind as to let me know.Thank youYiannos

Share this post


Link to post
Share on other sites