Archived

This topic is now archived and is closed to further replies.

Guest SuperFortress

Your computer has run out of available memory

Recommended Posts

Recently I've been doing more flying with the PMDG747 and now lately I seem to be getting this constant CTD during flight that tells me "YOUR COMPUTER HAS RUN OUT OF AVAILABLE MEMORY. PLEASE RESTART FLIGHT SIMULATOR AND SELECT DIFFERENT GRPAHICS, SCENERY, OR TRAFFIC SETTINGS." Sometimes I get this CTD with default aircraft but the PMDG seems more frequent. My system has 4GB of RAM and Windows XP is reporting that it sees 3.25GB. Should'nt that be enough? Any help would be greatly appreciated. Thank you.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The problem has more to do with how FSX and your computer use memory than how much memory you have. I have 2gb and still benefit from the 3 gb switch. You can search for info here on the forum. Bob

Share this post


Link to post
Share on other sites

For me, SP2 is the problem. With SP1, I had no problems with the PMDG747 and FSX. But with SP2, I get the out of memory errors a lot unless I run the 3gb switch. The problem with the 3gb switch is it can cause other programs to error, so give it a try and see if you can live with the compromise.

Share this post


Link to post
Share on other sites

Yeah, you'll prolly have to use the 3GB switch - that's what was happening to me while running complex addons and scenery...I only have 2GB using XP Pro SP2 with FSX Acceleration

Share this post


Link to post
Share on other sites

"For me, SP2 is the problem. With SP1, I had no problems with the PMDG747 and FSX. But with SP2, I get the out of memory errors a lot unless I run the 3gb switch. The problem with the 3gb switch is it can cause other programs to error, so give it a try and see if you can live with the compromise."Interesting. Don't understand why you get OOM's with SP2. With SP2, a new FSX.exe was installed as the old FSX.exe could not see memory greater than 2GB. Everyone had to hack into the old FSX.exe to change a setting to make it 'see' more than 2GB of memory. Then the /3GB switch had to be implemented for XP systems to make it work properly; the BCDEdit is used for Vista32 bit systems. There's an excellent post here on the FSX forum that provides more detailed info. Just do a search for OOM. Here's another regarding the subject for those who don't want to upgrade to SP2 and want to manually hack into FSX.exe: http://www.nvnews.net/vbulletin/showthread.php?t=89138Jim

Share this post


Link to post
Share on other sites

Well guys I took your advice and added the following: multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /userva=2560Unfortunately it's not helping. I'm still getting the same CTD after about 10-15 into the flight:( Any other ideas? Thank you again.

Share this post


Link to post
Share on other sites

No offense to the extremely knowlegeable people here, but you might consider taking this to the hardware forum as well.

Share this post


Link to post
Share on other sites

SuperfortressThe OOM issue is due to the way that Windows addresses the 'virtual address space' it has nothing to with the physical RAM on board. One of the reasons that it happens on more "modern" sysytems is probably due to the increased VRAM on the video card, from MS: "A modern graphics processing unit (GPU) can have 512 MB or more of video memory. Applications that try to take advantage of such large amounts of video memory can use a large proportion of their virtual address space for an in-memory copy of their video resources. On 32-bit systems, such applications may consume all the available virtual address space". The last bit is why you get the OOM error. The solution, its expensive but simple - Windows 64-bit: "The way to ensure that you have reasonably unlimited virtual address space with GBytes of contiguous address ranges is to move to 64bit." (from http://www.tech-archive.net/Archive/Develo.../msg00063.html) But, as we know there are also issues with 64-bit Operating systems.Or you could turn your sliders down, that may help.Peter Hayes

Share this post


Link to post
Share on other sites

"The OOM issue is due to the way that Windows addresses the 'virtual address space' it has nothing to with the physical RAM on board. One of the reasons that it happens on more "modern" sysytems is probably due to the increased VRAM on the video card, from MS: "A modern graphics processing unit (GPU) can have 512 MB or more of video memory. Applications that try to take advantage of such large amounts of video memory can use a large proportion of their virtual address space for an in-memory copy of their video resources. On 32-bit systems, such applications may consume all the available virtual address space". The last bit is why you get the OOM error. The solution, its expensive but simple - Windows 64-bit: "The way to ensure that you have reasonably unlimited virtual address space with GBytes of contiguous address ranges is to move to 64bit." (from http://www.tech-archive.net/Archive/Develo.../msg00063.html) But, as we know there are also issues with 64-bit Operating systems. Or you could turn your sliders down, that may help."Well stated Peter! I was going to mention turning the sliders down too. I use to get the OOM even with the switches until I turned my sliders down. I still get great graphics and no CTD's! Superfortress: I would also suggest you check your virtual memory (page file) settings and make sure it's set to "System Managed Size". Jim

Share this post


Link to post
Share on other sites

Once again guys, thank you for all of your suggestions. I think have managed to resolve the issue. Yesterday I was using the /3GB along with USERVA. I then decided to delete the USERVA entry and only left the /3GB switch in place. Not sure what it did but so far so good. Just completed a couple of flights with the PMDG747 and no CTDs at all. Crossing my fingers that it stays that way:)

Share this post


Link to post
Share on other sites

That makes sense... the Userva entry limits the VA space that a user application can use. No Userva = full 3GB potentially available.The risk is that you starve operating system use.

Share this post


Link to post
Share on other sites

My experience was the same -- the /3GB switch along with ISERVA=2560, I still got an OOM error. By removing the USERVA entry, I was able to get through the same flight without the OOM error. However, I also had some graphics anomalies at times on booting the system. I may resort to booting with the /3GB switch only when I intend to fly with FSX. But reducing the grapics settings may be a better solution. For those, who have solved the OOM errors by reducing their FSX sliders, what settings are you using? What sliders have the most effect on virtual address space use?Don S.

Share this post


Link to post
Share on other sites

>Once again guys, thank you for all of your suggestions. I>think have managed to resolve the issue. Yesterday I was using>the /3GB along with USERVA. I then decided to delete the>USERVA entry and only left the /3GB switch in place. Not sure>what it did but so far so good. Just completed a couple of>flights with the PMDG747 and no CTDs at all. Crossing my>fingers that it stays that way:)Hi There,Can you please let me know what is the exact entry you have now for the 3GB switch, as me too I still have the same problem of crashing.Thanks in advance

Share this post


Link to post
Share on other sites

My entry looks pretty much like this:multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB

Share this post


Link to post
Share on other sites

There's another way, although non-conventional, to help this problem out. You will want to run FSX in Windowed Mode to do this, as the "fix" below will explain.1. Prior to starting FSX, open up your Task Manager (Ctr-Alt-Del) and select the Processes Tab.2. Start FSX, and look in the tab list for the "fsx.exe" file. Monitor the "Mem Usage" column, and watch it climb as FSX loads. 3. Assuming FSX loads OK to begin with, choose your flight settings, then start loading your flight. Note several settings in FSX can have a huge affect on this. One of those "tweaks" that suggests raising your LOD setting to 8.0 will really increase the amount of memory used. You will also notice much more memory being used depending on the aircraft being loaded. Loading a PMDG 747 vs the default Cessan will really increase the memory usage of the flight being loaded. Keep watching the fsx.exe file memory usage. It SHOULD eventually stabilize once the flight loading completes...if it DOESN'T, you want to find out why, because eventually you are going to hit a value where you get the OOM message. This is a nice value to know for your computer, because there is a way to stop the OOM BEFORE it happens if you know the value.Assuming you got the flight loaded and everything is still running, start your flight. Keep an eye on that Mem Usage value, and I want you to try a couple things while you are watching that memory usage number. First, start switching views in FSX. Cycle through the cockpit, Spot, Tower, etc, etc, views. Watch what happens to that memory usage. It will normally INCREASE each time you switch a view. Texture loading, texture switching, etc. This can result in the GPU ending up using all that Virtual Memory space talked about in the above posts. Eventually, you might get to the OOM crash-limit.Now, try this also. With FSX in Windowed Mode, MINIMIZE FSX to your Taskbar. Watch what happens to the Memory Usage value. If it drops like a rock, yippee. Maximize FSX again, and you basically "start over", climbing to higher numbers. If your original flight loaded OK, the Mem Usage value will "stabilize" at a certain value again. But as soon as you start switching views, etc, it will keep climbing again with each view switch. For some people, simply periodically minimizing FSX to the Taskbar can keep things "under control" and you won't get the OOM as long as you don't let the Mem Usage value get to the point where your computer crashes FSX.Massive amounts of "view switching" can be a culprit in OOM errors in FSX. I use the TrackIR, and never have to switch views in any cockpits. All the necessary textures get loaded, then I can "see" them all by sinply turning my head to view different areas of the cockpit. No "view cycling" is required, thus no "loading/unloading" of textures with the associated increase in the Mem Usage values. The less "view cycling" you do in FSX, the better. I know many people don't like flying in Windowed Mode, but by doing it, and simply minimizing FSX to the Taskbar once in a while, I'll bet a lot of folks getting OOM's can stop that from happening. I've recommended this to numerous folks before, and every one of them said it solved their OOM problems. FSX can be finicky depending on your system. If your Mem Usage is getting out of hand like explained above, you may be able to "manage" it "on the fly" using the techniques I mentioned above to prevent OOMs. It only takes a second to do a minimize/maximize of FSX, and if it solves your individual OOM problem, it's not really an inconvenience at all.Your milage may vary. Just an alternate possibility being presented. And if you are die-hard set against running in Windowed Mode, just disregard the whole post. FalconAF

Share this post


Link to post
Share on other sites

Thank you very much Falcon,I always fly in windowed mode, I will try your suggestion and hope it will work for me.ThanksWalouigi

Share this post


Link to post
Share on other sites

>My entry looks pretty much like this:>>multi(0)disk(0)rdisk(0)partition(2)WINDOWS="Microsoft Windows>XP Professional" /noexecute=optin /fastdetect /3GBThank you very much, I will try it out.Regards

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.