Sign in to follow this  
Guest

Unbelievable! Disable AGP and voila!

Recommended Posts

My goodness it is true. I have been up 5 times or so since doing this and it has breathed new life into this P3 1GHz w/ 512 PC103 ram, Radeon 64 DDR VIVO. I am truly amazed as I am running this at 1600 x 1200 x 32 and it really is totally smooth. Seems the AGP disable in DirectX was the thing that seems to have gotten rid of microstutters, or at least 95% of them. I am building a new machine but this clearly tells me there is not so much hurry anymore. Now my lovely Lian Li PC-68 case modified with RheoBus Version 2 and subfloor cooling will sit empty save the nice Yamaha CDRW and Toshiba 16x DVD player I already installed. I am running everything maxed except for terrain detail distance slider to 80%, clouds to 40%, and ATC traffic to 40%. The FPS drops down to 10 or so in the worst situations, but at least it's a predictable steady drop in FPS, vs the annoying microstutters when the FPS is locked at 22. It stays on 22 most of the time now. Hopefully I can be patient enough to nab something that will do over 3GHz which should be in about 1 1.5 months.BTW, I tried decreasing the AGP aperture to 16 which effectively disabled AGP, however I would get lock ups well into flight. By disabling via the DirectX applet the lock ups have ceased.Cheers, and see you at Tahoe :()NoelKCIC

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Oh no! I hope this doesn't mean you have now lost interest in SCSI. We were all relying on you for a test report ;-) :-lol

Share this post


Link to post
Share on other sites

There we have another believer. I am glad it worked out for you. BTW some experience lockups when disabling AGP in DirectX but can run stable when lowering the aperture size to 16MB. So you never know. Just gotta try what works fr you.Alex

Share this post


Link to post
Share on other sites

Type dxdiag at the RUN available in your START button lower left of screen.. Go to display section of dxdiag.Dick

Share this post


Link to post
Share on other sites

This is gonna sound stupid...how do I access the directx applet?I did a search on my PC for *.cpl and didnt find any directx relatedcontrol panel applets etc?Eric

Share this post


Link to post
Share on other sites

This should be an FAQ entry somewhere... But MY question is - what video card RAM level makes it a safe bet to turn off AGP? (32?), 64, 128? I've got a 64 MB card myself...-Greg

Share this post


Link to post
Share on other sites

Good question Greg. I'd be interested in the answer too. It seems that (as ever!) your milage may vary with this. I tried disabling AGP on my Geforce 3 Ti 200 (64Mb). A quick before and after test showed that I lost 4-5 fps and there was no noticable improvments in the small "micro" stutters I sometime experience.I wonder if drivers are a factor too? I'm using the 29.42's.

Share this post


Link to post
Share on other sites

A little info from the ATI standpoint....My system specs: Dell PIII 1GHz, 512Mb RDRAM, ATI Radeon 32 DDR, SB Live! soundFirst I started messing with the aperture in the bios. Mine only had two selections, 64 and 256. It was set at 64 and I increased it to 256 and gained about 2 or 3 fps.After reading Alex's threads, I disabled AGP textures using Dxdiag as described here. My average fps jumped from 7 or 8 to 14 or so with just a few stutters particularily when looking out the side views.Interesting enough, I went back to the bios and set the aperture back to 64 and I still lost about 2 fps overall.My current setting is 256 in the bios and AGP texturing disabled in Dxdiag. I'm pretty happy but I would love to be able to squeeze a little more out of her.If anyone has a similar system as mine running better, I would like to know any other preferred settings. As everyone here, I want the best quality with the best fps I can get with this system.I'm not ready to buy a new PC but I have considered a newer video card. I know that it will not neccessarily increase my fps but I thought that it might allow me to run things a little more maxed out. I've read a lot about nVidea here but basically I am an ATI man. I've always had good experience with ATI cards and drivers.Any suggestions are appreciated.

Share this post


Link to post
Share on other sites

Jon I knew you were going to write that. At this point I am STILL leaning towards Cheetah X15 as there are still situations when drive access cause stalls in FS. Example: loading flightmax and a few others, like loading certain sounds, etc. I am interested in the GigaPiano as well, which loads huge piano samples in realtime, and demands fast SCSI. But I suppose if this issue of microstutters disappearing remains a non-issue we really won't be doing SCSI for FS.Bubba Wolford of SimHQ is setting up the Cheetah vs IDE comparison or so he wrote me so who knows.Now, back up to see if we can remain free of microstutters in yet another situation!Noel

Share this post


Link to post
Share on other sites

Hi all.I have a Radeon 64 DDR VIVO, so I was going to refute this entire discussion, as I have no problems with my system...however...I looked, and found I had already disabled it!:-xxrotflmao It certainly causes no harm on my system, and I'm leaving the AGP texturing setting OFF.

Share this post


Link to post
Share on other sites

Absolutely amazing! I tried this on a PIII-800, GeForceII MX 440, and my framre rates are a little higher, but more importantly the stuttering in turns which used to really get my goat is almost completely gone. Thank you for a fantastic tip!Cheers,Gareth Evans

Share this post


Link to post
Share on other sites

Then i shall reinstall FS on my old P3 500 Voodoo 5 and see what i get. It was unplayable before but i'd like to try the DX trick on the old horse :)Log

Share this post


Link to post
Share on other sites

I tried it & I don't see any FPS improvement. :(Oh, well. It's probably because I have a really crappy computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this