Archived

This topic is now archived and is closed to further replies.

Moose4

Help--fast new machine, extremely low windowed framerates?

Recommended Posts

Hey guys, I've just re-installed FS2004 on my brand new machine, which is a Core 2 Duo E8400 processor, 4 GB RAM, Geforce 8800GTS 512MB video card with the latest nVidia WHQL drivers (175.something). This thing should run FS2004 with everything pushed over to the right quite easily, and it does...in full-screen mode only.I've installed no add-ons at all as of yet, just FS2004, the 9.1 update, and the no-CD mod (to save wear and tear on my disk #4). In the default flight, sitting on the ground at KSEA, if I'm in full-screen mode at my normal resolution of 1680x1050, I get 40 fps (locked at 40). If I switch to windowed mode, still at 1680x1050, I get 8 fps. Anti-aliasing is not turned on in my nVidia drivers yet. Almost all graphic options are maxed out.What's up? My old machine (an Athlon 2500 with a 6600GT) would actually get better frames in windowed than full-screen. I would greatly prefer to run windowed mode since I do a bit of online flying and need the ability to quickly task switch. Thanks!Lewis "Moose" GregoryDurham, North Carolina

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm never sure why FS does this, it happens on my rather old machine (ordering a new one on Tuesday and i cant not wait!), but the point of my message is that its not just your machine, i think its something to do with having to run the desktop along side as well, but i am guessing there.

Share this post


Link to post
Share on other sites

I have a new system also, pretty similar to yours. It effects mine the same way, so now I just fly in full screen mode. If I want to access the menu at the top I just press the Alt key. I'm so shocked at how well FSX runs now, I rarely use FS9.Curt

Share this post


Link to post
Share on other sites

Just for the record I get identical framerates in full or windowed mode fs9.Its a core2 duo 2.4Ghzand Nvidia 8600M GT2 GB RAMfps about the same as other computers with similar specs, but: no dif between full or windowed.Because mine is a laptop, and Nvidia warns to only use the makers' drivers, I'm still at v.156.10, so maybe earlier drivers would help your situation, maybe not though...

Share this post


Link to post
Share on other sites

I believe it has something to do with the Global Settngs for your video card, but I might be wrong.Bill

Share this post


Link to post
Share on other sites

Actually I think I may have partially figured it out...it's the taskbar. If I set the taskbar to auto-hide, my frames jump back up to 30+ in the window. As soon as the taskbar pops up, my frames go back in the toilet again. As long as I keep the taskbar hidden, it seems to be working fairly well in a window. That's very odd.Lewis "Moose" GregoryDurham, North Carolina

Share this post


Link to post
Share on other sites

>Hey guys, ...... >Geforce 8800GTS 512MB video card with the latest nVidia WHQL>drivers (175.something). ......>>Lewis "Moose" Gregory>Durham, North CarolinaLewis, You might try getting hold of the nHancer utility from www.nhancer.com which solves some of the problems associated with the Nvidia drivers and various gaming platforms, including anti-aliasing on FS2004. I'm not sure if its still needed with the 175 series drivers but I have found it helpful in the past and I'm still running it on my 880GTS with the 175.16 drivers and OK framerates both windowed and full screen. If nothing else it helps you understand what some of the graphics options on the card do!!!

Share this post


Link to post
Share on other sites

I agree with john willimas about nVidia driverI have system pretty similar to yours and had same problemsI changed nVidia driver, changed my Anti virus

Share this post


Link to post
Share on other sites

I've had better luck running Omega drivers rather than stock Nvidia drivers. They're more stable and have better framerates. You might give them a try.

Share this post


Link to post
Share on other sites

I think you may have found your solution with the task bar. I always fly with mine set to auto hide but if, for some reason, I have to go to it my sim FRs plummet. Not sure what the technical explanation is, but that's what happens so I just acces the task bar as little as possible during a flight.

Share this post


Link to post
Share on other sites