Archived

This topic is now archived and is closed to further replies.

borisvp

Autogen popup

Recommended Posts

Hello,as the search for "autogen" and "popup" reveals more that 1000 results, I may be excused to ask an already answered question again :( I'd like FSX a lot, if it weren't for the autogen which keeps popping up in close distance. This is really annoying. I already learnt that this has something to do with the so called alpha shader, which the late Aces guys removed with SP 2.But SP2 was back in 2007, and I want to ask if there is a fix available by now? ThanksBoris

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

But SP2 was back in 2007, and I want to ask if there is a fix available by now?
SP2 did not remove alpha fade. FSX never had it to begin with.But do post your specs as Bob mentions, because with the right tweaking you can minimize the popping a little.

Share this post


Link to post
Share on other sites

There always will be popping, no matter what. Phil Taylor said this when SP1 was released:"The vastly improved batching of Autogen was one of the major performance items in SP1 and helps to reach our target reduction of 35-40% for Draw and SetTexure calls. However, it does have an implication that, when coupled with a feature we lost from FS9, you should be aware of. FSX does not

Share this post


Link to post
Share on other sites

If I had knowledge about programming I might say "what a stupid move from Aces" - of course I haven't :( But I'd rather live with less autogen showing smoothly than way too much than current hardware can handle suddenly flashing in the way it is now - and this even with the lowest setting. Well, FSX has lots of improvements over FS9 (better mesh representation, no simplified world model, much better textures even by default, less blurring - but that, dear FSX, is a KO criteria.Anyway, here's my hardware - maybe there can be reached at least some improvement to make the thing usable for me.MSI P45 Platinum (latest BIOS and chipset drivers)E86002x2GB OCX 1066 Reaper K2MSI GTX260 / TH2G analog with 3x17" / 1x15"MSI 8600 / 2x 17"VGA driver version 178.24XP SP2 on 2xSeagate 500GB/7200 RAID0FS on 2x WD Raptor 74GB RAID0Corsair 620W power supplyThanks for your help :( Boris

Share this post


Link to post
Share on other sites
If I had knowledge about programming I might say "what a stupid move from Aces" - of course I haven't :( But I'd rather live with less autogen showing smoothly than way too much than current hardware can handle suddenly flashing in the way it is now - and this even with the lowest setting. Well, FSX has lots of improvements over FS9 (better mesh representation, no simplified world model, much better textures even by default, less blurring - but that, dear FSX, is a KO criteria.Thanks for your help :( Boris
I agree that autogen popping can be quite distracting, especially when you start focusing on it...I think the Aces team was getting beaten up about bad FSX performance and made some trade-offs that wemight want to second guess later. This is one of the things that is unlikely to change, now that Aces is out of business. I'm sure it was on the list of things to fix for FSXI.Try flying with scenery on complex and autogen on sparse... for me, at least, it is more pleasing to the eye.

Share this post


Link to post
Share on other sites
Try flying with scenery on complex and autogen on sparse
I tried. Bare landscape, and still popping. Sorry, but FSX looks too good with autogen on dense - as long as you don't move.Isn't there a way to increase the autogen draw distance? Or to build the fader function directly into the autogen? Hmm, probably not, or someone would already have done it. Well, then I'll hope for a change - and wait. FS9 is fine, too :( RegardsBoris

Share this post


Link to post
Share on other sites

Hi,This popping of autogen really ruined FSX for me, so what I did was move to Satellite scenery. Many don't like it but for me it was a good choice. I use no autogen at all. Yes, it is a little bit of a disappointment when taking off our landing as you dont see any 3D stuff (trees etc) except for the airport defaults and other buildings not associated with autogen. But, I just keep my head forward until I need perspective during landing or takeoff when close to the runway.Just an idea!RegardsBob G

Share this post


Link to post
Share on other sites
Isn't there a way to increase the autogen draw distance?
If you have a high-end system, try increasing the LOD radius in fsx.cfg from the default 4.5 to 6.5. It will extend the autogen draw distance but may cost you some performance on large urban areas.Be aware that if you change something in the FSX settings menu, that value will revert to the default 4.5 and you will have to change it again.Cheers.

Share this post


Link to post
Share on other sites

Well, what is high end? It is said about LOD radius, that it only has influence on the texture representation. Anyway, I tried 6.5 - no change. 8.5 - seems a little better, but still too abrupt. Above 10 it starts looking OK (which micht be imagination and wishful thinking, though), but gives me OOM after 10mins.RegardsBoris

Share this post


Link to post
Share on other sites