Archived

This topic is now archived and is closed to further replies.

Guest manniko

Equal load distribution to all cores of a Q9650

Recommended Posts

Hi Folks,my situation is as follows:got a new machine and thought it would work seemless with FSX and PMDG A/Cs but it doesn't do the job like I anticipated it would do.Machine: INTEL Q9650 CORE 2 QUAD Q9650 12M 13338 GB OCZ RAM ( 4 GB Patch installed for FSX)Windows XP Pro 32 bit G-Force GTX 850 with 1 GB RAMP45 Motherboard 2 x 22" TFT MonitorsSituation:Installed FSX and ajusted all the display possibilities real moderate - nothing squeezed to ULTRA High. Installed PMD MD-11 A/s. Basically it works real good and I get very nice frame rates. Sometimes up to 200 fps (depends on the situation) - but nearly never below 30 fps. But sometimes my machine seems to get a hickup and it freezes for a second or more. Sometimes even for 5 - 10 seconds and then it will recover. Very annoying if it happens during landing. As I watch the load of the 4 cores, I noticed, that always core 1 is fully loaded - mostly around 99 to 100%. All other 3 cores have a lot less load. The overall load of my Quad Core CPU is around 30% - 50% not more. My Question:Is there any possibility to adjust my system in a way that all cores will be equally loaded? I have some add-ons (FS-Map) here I can assign a certain core to that program to put the high load to. Is there any known solution to my problem? Help and advice would be highly appreciated. Regards Manfred Kohl (OERK)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Couple things here:1. 8GB of RAM is absolutely useless in XP - get Vista 64. The 1GB video card is likely actually making matters worse for you because the 1GB of RAM on it cuts into the available User VA space.2. Make absolutely certain you have the latest drivers for everything, especially the motherboard chipset, and make sure that the BIOS is set correctly as far as RAM timings etc.Now, with respect to the core loading, it doesn't work like that. How much of each core gets used depends on how the application is programmed. (this is called "multithreading") FSX has one main application thread that does most of the work and then a some smaller threads that help with things like terrain load-in etc. This is why you don't see all 4 cores being fully utilized, it's just not how the engine is programmed. Some applications have much better multithreading than others do.At any rate, the problem is probably not in your hardware. I would also ensure you don't have any programs running in the background like real time antivirus scanners etc that could cause that hitching you're seeing.

Share this post


Link to post
Share on other sites
Couple things here:1. 8GB of RAM is absolutely useless in XP - get Vista 64. The 1GB video card is likely actually making matters worse for you because the 1GB of RAM on it cuts into the available User VA space.2. Make absolutely certain you have the latest drivers for everything, especially the motherboard chipset, and make sure that the BIOS is set correctly as far as RAM timings etc.Now, with respect to the core loading, it doesn't work like that. How much of each core gets used depends on how the application is programmed. (this is called "multithreading") FSX has one main application thread that does most of the work and then a some smaller threads that help with things like terrain load-in etc. This is why you don't see all 4 cores being fully utilized, it's just not how the engine is programmed. Some applications have much better multithreading than others do.At any rate, the problem is probably not in your hardware. I would also ensure you don't have any programs running in the background like real time antivirus scanners etc that could cause that hitching you're seeing.
Hi Ryan,thanks a lot for your fas and prompt reply and offer to help. We appreciate that any time as we see that you are always jumping on with grateful advices. 1.) I know that WIN XP can only utilize a max. of - I guess 3.6 GB with the patch and the additional switch in the boot.ini - When I ordered this machine, I intended to install VISTA 64 bit on it but deviated from my decision because of some threads I read which reported a lot of problems with VISTA 64. So I wanted to go the safe way and went back to WIN XP Pro. Anyway I bought now the WIN XP Pro 64 bit version and I think I will give it a try - or would you advise to install VISTA 64 bit instead ? Regarding the graphic card (G-Force GTX 850), it is the latest Graphic Adapter from G-Force and I suppose to have the latest driver installed. If the graphic card is the perpetrator what could I do in this case?2.) Ok, understood that FSX is not supporting a leveled load for more cores - unfortunately not. Normally I do not have any other programs running simultaneously (this computer is solely used for FS fun). Parallel to the FSX I am only running FS-MAP which sucks a lot of load ( and memory, because of the large maps ) but I can put here the load on another core ( I usually use core 3 for FS-MAP). But I have Kaspersky Antivirus running in the background and today afternoon I will try to switch it off in order to see if there is any improvement of the situation. Thanks a lot Ryan and greetings from Riyadh (OERK)Manfred Kohl (OERK - Riyadh)

Share this post


Link to post
Share on other sites

Manfred,I had the same problem of yours running my quad core.I managed to partially solve it and making things "smoother" using the facility coming together with FSInn/Copilot.It is called Multicore Optimization and it allows you to choose one core only for FSX rendering and others for Xp related services.I assume it was originally designed for dual core cpus but it made a nice improvement on my FPS as well.Another solution you might want to take alook at is here: http://forums.flightsim.com/vbfs/showthread.php?t=161337.I tried it myself too, but to be honest I could not appreciate any difference with this.Hope this helpsNick

Share this post


Link to post
Share on other sites
It is called Multicore Optimization and it allows you to choose one core only for rendering and others for Xp related services.
DO NOT DO THIS IT IS SNAKE OIL if you use FSX SP1 or SP2. It may have been helpful with the original release of FSX but it most definitely isn't with FSX SP1 and later, doing this would actually slow FSX down significantly.

Share this post


Link to post
Share on other sites
Manfred,I had the same problem of yours running my quad core.I managed to solve the problem of making things "smoother" using the facility coming together with FSInn/Copilot.It is called Multicore Optimization and it allows you to choose one core only for rendering and others for Xp related services.I assume it was originally designed for dual core cpus but it made a nice improvements on my FPS as well.Another solution you might want to take alook at is here: http://forums.flightsim.com/vbfs/showthread.php?t=161337.I tried it myself too, but to be honest I could not appreciate any difference with this.Hope this helpsNick
Hi Nick,thank you for your reply and help. I read already a lot about that stuff and will give it a try. Especially the possibility under FsInn/FS CoPilot and their possibility to tweak a MultiCore process seems to be interesting. I guess, I will give it a try after I install WIN XP 64 or VISTA 64 .Regards from Riyadh Manfred Kohl (OERK)
DO NOT DO THIS IT IS SNAKE OIL if you use FSX SP1 or SP2. It may have been helpful with the original release of FSX but it most definitely isn't with FSX SP1 and later, doing this would actually slow FSX down significantly.
Hi Andy,thanks for reply and advice. I have the original version of FSX and Acceleration installed - I guess FSX Acceleration includes SP1 and SP2 as far as I knkow. I always make a DriveImage Backup before I play around and try to twiggle around with things. If it goes bad, a fast restore of my complete data could be done. Thank you again Andy and regards from Riyadh - in the middle of nowhere. Manfred (OERK)

Share this post


Link to post
Share on other sites

Hello Manfred, yes Acceleration is the same as SP2 more or less. This tweak wont do any permanent damage but it will make FSX perform worse overall, you can do the same test just by simply setting the affinity of the processes with the Windows task manager, this is all this so called optimisation is.Simply bring up the task manager when FSX is running and right click on the FSX.exe and select "set affinity".You will now get a pop up box with some check boxes and ticks in it, deselect one or more ticks and you are done, FSX will now perform worse than it did before. The first thing you will probably notice is that the ground scenery textures will start to get more blurry.

Share this post


Link to post
Share on other sites
Hello Manfred, yes Acceleration is the same as SP2 more or less. This tweak wont do any permanent damage but it will make FSX perform worse overall, you can do the same test just by simply setting the affinity of the processes with the Windows task manager, this is all this so called optimisation is.Simply bring up the task manager when FSX is running and right click on the FSX.exe and select "set affinity".You will now get a pop up box with some check boxes and ticks in it, deselect one or more ticks and you are done, FSX will now perform worse than it did before. The first thing you will probably notice is that the ground scenery textures will start to get more blurry.
Hi Andy,some people obviously never sleep ;-) - the responses are coming so fast and at any given time. Andy, I will give the "affinity" settings via the task manager a try - it is fast and easy to do and we will see the performance change immediately and a re-change is done quickly as well. Any advice for me regarding XP 64 or VISTA 64 ?? I bought already XP 64 but it won't be a problem to get also a original VISTA 64 . Only the installation time is here relevant. I can buy the OEM Versions of the OSs for very reasonable prices. Ciao and always happy landings and greetings from the desert. BTW: Please excuse my sometimes humpy English - I am a German but I try my best to make my wordings as clear as possible. Manfred (OERK)

Share this post


Link to post
Share on other sites

Your English is probably better than mine and I am British born and bred :( XP 64 or Vista 64 should be fine they are both pretty well supported now driver wise, if you do have a problem getting drivers it will only be with old hardware like scanners and such.

Share this post


Link to post
Share on other sites

My experience with a Q9650 on a ASUS Rampage with 1066 4Gb memory is good. I've not found a need to over clock, I can run FSX with ASX and run Outlook simultaneously with Norton 2009 in the background (this is a much improved NAV over previous releases). I will get a rare stutter in dense scenery.My understanding is a stutter is a CPU getting behind the flow. I recommend the approach you are taking to isolate if your antivirus is holding you up.

Share this post


Link to post
Share on other sites
My experience with a Q9650 on a ASUS Rampage with 1066 4Gb memory is good. I've not found a need to over clock, I can run FSX with ASX and run Outlook simultaneously with Norton 2009 in the background (this is a much improved NAV over previous releases). I will get a rare stutter in dense scenery.My understanding is a stutter is a CPU getting behind the flow. I recommend the approach you are taking to isolate if your antivirus is holding you up.
Hi Dan,thanks also for your note and reply. Yes, my first approach will be to deactivate my Antivirus (Kaspersky full paid version ) prg and will first see the result before I will dig deeper into the problem. First thing, when I come home today.Greetings from Riyadh Manfred (Riyadh - OERK)

Share this post


Link to post
Share on other sites
Hi Dan,thanks also for your note and reply. Yes, my first approach will be to deactivate my Antivirus (Kaspersky full paid version ) prg and will first see the result before I will dig deeper into the problem. First thing, when I come home today.Greetings from Riyadh Manfred (Riyadh - OERK)
Hi Manfred, what is your target FPS rate? I had crashes/ and hanging screens with the unlimited setting, since putting it to 70 it does not happen anymore. Just an idea, eventhough my system is not as good as yours.Tom M

Share this post


Link to post
Share on other sites
Situation:Installed FSX and ajusted all the display possibilities real moderate - nothing squeezed to ULTRA High. Installed PMD MD-11 A/s. Basically it works real good and I get very nice frame rates. Sometimes up to 200 fps (depends on the situation) - but nearly never below 30 fps. But sometimes my machine seems to get a hickup and it freezes for a second or more. Sometimes even for 5 - 10 seconds and then it will recover. Very annoying if it happens during landing. As I watch the load of the 4 cores, I noticed, that always core 1 is fully loaded - mostly around 99 to 100%. All other 3 cores have a lot less load. The overall load of my Quad Core CPU is around 30% - 50% not more.
I had this situation with my quad core when I first got it. I heard from a reliable source that FSX doesn't play nice with all quad cores, so I changed the affinity mask in FSX.cfg to only use 3 of my 4 cores. Once I did that, I was smooth sailing.To test, add the following to the fsx.cfg under the [JOBSCHEDULER] tag:AFFINITYMASK=7This will force FSX to only use three cores. It worked for me.- JohnFSX SP2Windows XP SP3 32bit

Share this post


Link to post
Share on other sites
Hi Manfred, what is your target FPS rate? I had crashes/ and hanging screens with the unlimited setting, since putting it to 70 it does not happen anymore. Just an idea, eventhough my system is not as good as yours.Tom M
Hi Tom,thanks for the reply - normally I had the FPS rate set to indefinite, but reduced it to 50 - no improvement.I will hang on that issue ;-)Thanks Tom, greetings from the desertManfred ( RIyadh - OERK )
I had this situation with my quad core when I first got it. I heard from a reliable source that FSX doesn't play nice with all quad cores, so I changed the affinity mask in FSX.cfg to only use 3 of my 4 cores. Once I did that, I was smooth sailing.To test, add the following to the fsx.cfg under the [JOBSCHEDULER] tag:AFFINITYMASK=7This will force FSX to only use three cores. It worked for me.- JohnFSX SP2Windows XP SP3 32bit
Hi John,thanks for the advice and reply on my problem. To add the '' Jobscheduler "" tag 7 is already on my to-do-list. Will hope it will help. Will do it now and will report on it.Greetings from the desert,Manfred (Riyadh OERK)

Share this post


Link to post
Share on other sites
Hi Folks,my situation is as follows:got a new machine and thought it would work seemless with FSX and PMDG A/Cs but it doesn't do the job like I anticipated it would do.Machine:INTEL Q9650 CORE 2 QUAD Q9650 12M 13338 GB OCZ RAM ( 4 GB Patch installed for FSX)Windows XP Pro 32 bitG-Force GTX 850 with 1 GB RAMP45 Motherboard2 x 22" TFT Monitors
This is kinda off topic, but what in the world is a GTX 850? You sure you don't mean 8500 GT or GTX 260/280?

Share this post


Link to post
Share on other sites
This is kinda off topic, but what in the world is a GTX 850? You sure you don't mean 8500 GT or GTX 260/280?
Hi Emil,you are fully right - it is off course not a GTX 850 !! It is the GTX-285 (new model) with 1 GB RAM.Thanks for the advice, appreciate it very much.Hej hej from Riyadh.Manfred (Riyadh - OERK)

Share this post


Link to post
Share on other sites
Hello Manfred, yes Acceleration is the same as SP2 more or less. This tweak wont do any permanent damage but it will make FSX perform worse overall, you can do the same test just by simply setting the affinity of the processes with the Windows task manager, this is all this so called optimisation is.Simply bring up the task manager when FSX is running and right click on the FSX.exe and select "set affinity".You will now get a pop up box with some check boxes and ticks in it, deselect one or more ticks and you are done, FSX will now perform worse than it did before. The first thing you will probably notice is that the ground scenery textures will start to get more blurry.
Hi Andy and all the others who gave same advices,My system runs well and FSX is NOT anymore stuttering - not one time !!!! Problem is solved !!! What I did:I set from the task manager the affinity for fsx.exe to the following setting:core 0 = de-selectedcore 1 to 3 = selectedWhat my computer now is doing:Instead of having all the load on core 1 (mostly around 100%) the load is now nearly equally distributed among core 2,3,4 - the load never reaches a single time 100% - the cores are now loaded between 30% and 80% with some very short peaks which are going up to 90%.Core 1 - which has been fully loaded before - indicates now only around 5% and the average load for all 4 cores is floating around 30 - 40% !!!A great day and a great solution for my problem. It is very nice to have a smooth running system with no fear that the system will hang for a couple of seconds. Thanks to all again, you are my men.Greetings from the desert of Saudi Arabia Manfred (Riyadh - OERK)

Share this post


Link to post
Share on other sites

Guys,how do I make the usage of cores 2,3 and 4 as default?everytime I start FSX the Affinity goes back to all 4 cores again.ThanksNIck

Share this post


Link to post
Share on other sites

Hey just want to squeeze in a ques here i really need some advice. Im planning on buying a new system but swapping out the Phenom X4 9500 2.2Ghz processor with an Athlon 64 X2 6000+ 3.0Ghz mainly because they say that FS9 doesnt work too well with Quad Core, my question can the "AFFINITYMASK=7" tweak work with FS9 as well?

Share this post


Link to post
Share on other sites

I've been using the AffinityMask tweak for a while now and it works better than anything I've tried for stutters. Something to think about, whether to use AffinityMask=7 or AfffinityMask=14. In the original post from JohnCi who discovered the 3 core tweak for stutters, the way I understand it is the main reason for using 14 instead of 7 is that you want FSX to use the last three cores and let your OS use the 0 (zero) core exclusively. There was some confusion about which number to use. From what I read, the logic looks like this:0111=71110=14The cores are numbered from the right, so the zero core that the system uses is the last one. It's confusing because it seems Windows Task Manager (performance tab) displays this with the zero core first. I've tried both 7 and 14 and they both seem to work but I have it set to 14 now.Another thing to look at, many like to use the BufferPools tweak, but on my system (Q6600) this causes serious stutters.I rarely get any stutters now.Jeff P.Nfus, put this at the end of your fsx.cfg file[JOBSCHEDULER]AffinityMask=14

Share this post


Link to post
Share on other sites
Nfus, put this at the end of your fsx.cfg file[JOBSCHEDULER]AffinityMask=14
Done it but FSX seems to ignore this command.When FSX.exe starts all 4 cores are always ticked.Could it be related to the fact that Im using Vista?Nick

Share this post


Link to post
Share on other sites

It doesn't unselect the cores in the affinity options, to do this the executable header has to be changed, which isn't something that users can normally do easily. If you were to open the task manager and click on the performance tab you would see that only 3 cores are actually being used to any degree, and more than likely most of the time only one core is pegged at 100%, unless that is you are flying over photoscenery in which case all cores would be at 100% more often than not, depending on the speed you are travelling at.

Share this post


Link to post
Share on other sites
It doesn't unselect the cores in the affinity options, to do this the executable header has to be changed, which isn't something that users can normally do easily. If you were to open the task manager and click on the performance tab you would see that only 3 cores are actually being used to any degree, and more than likely most of the time only one core is pegged at 100%, unless that is you are flying over photoscenery in which case all cores would be at 100% more often than not, depending on the speed you are travelling at.
Whatever affinity mask value I input on fsx.cfg, when I start FSX and I check my PC performance, only the first core is at 100% and the other 3 are at 10/20%.Anyway this is not a problem anymore as I discovered something probably even better:What I do is going to task manager and change the affinity for fsx.exe "stopping" the first core (called 0). If you now check the performance you will see that core 1 "sleeps" meanwhile the other 3 run at about 70/80%. ( I have a Q9950 with Nvidia GTX280, Vista32 businnes, 4GB Ram)Now if I switch back-on the first core it appens that all 4 cores run at the same level/load! Core 1 is no more the only one overcharged like when you first run FSX.In my PC the load is now equally divided on all 4 cores giving an overall CPU's usage varying from 40% to 70%!!!This gives me a much smoother simulation and an average of 6/10FPS more than before.At least on my PC I can now run FSX with all sliders (ALL!!!) to max (apart from autogen and scenery density which are on Normal) and my FPS go from a min of 10 to a max of 40!!Nick

Share this post


Link to post
Share on other sites
Whatever affinity mask value I input on fsx.cfg, when I start FSX and I check my PC performance, only the first core is at 100% and the other 3 are at 10/20%.Anyway this is not a problem anymore as I discovered something probably even better:What I do is going to task manager and change the affinity for fsx.exe "stopping" the first core (called 0). If you now check the performance you will see that core 1 "sleeps" meanwhile the other 3 run at about 70/80%. ( I have a Q9950 with Nvidia GTX280, Vista32 businnes, 4GB Ram)Now if I switch back-on the first core it appens that all 4 cores run at the same level/load! Core 1 is no more the only one overcharged like when you first run FSX.In my PC the load is now equally divided on all 4 cores giving an overall CPU's usage varying from 40% to 70%!!!This gives me a much smoother simulation and an average of 6/10FPS more than before.At least on my PC I can now run FSX with all sliders (ALL!!!) to max (apart from autogen and scenery density which are on Normal) and my FPS go from a min of 10 to a max of 40!!NickHi Nick,thanks for sharing this new setting with us. I tried it and it works EXACTLY like you desribed it. BUT:I cannot run FSX with all sliders (except the ones you mentioned) at max!! Impossible, I will get then latest when I connect the SQUAWK Box a error which says: running out of memory, restart FSX. I have 8 GB memory istalled ( I know 4 of them are useless) and I installed also the 4 GB patch for FSX.EXE. I am not really sure what the heck is eating my memory.Regards from the saudi arabian desert,Manfred Kohl Riyadh OERK VA Pilot LH113

Share this post


Link to post
Share on other sites
What I do is going to task manager and change the affinity for fsx.exe "stopping" the first core (called 0). If you now check the performance you will see that core 1 "sleeps" meanwhile the other 3 run at about 70/80%. ( I have a Q9950 with Nvidia GTX280, Vista32 businnes, 4GB Ram)Now if I switch back-on the first core it appens that all 4 cores run at the same level/load! Core 1 is no more the only one overcharged like when you first run FSX.In my PC the load is now equally divided on all 4 cores giving an overall CPU's usage varying from 40% to 70%!!!
This is great! Tested this on my (dual-core system) and it results in higher framerates: the load is equally divided on the two cores.Thanks Nick.

Share this post


Link to post
Share on other sites