Archived

This topic is now archived and is closed to further replies.

Guest davidbernard

AI dissapearing after landing

Recommended Posts

Hi folks,A true challenge for the AI die-hards over here :( I have been building this AFCAD for Balad Southeast (OR0N) and added a lot of AI traffic. Now I have this weird problem:Sometimes the AI aircraft perform a correct approach, but dissapear after they slowed down on the runway. I know there are obvious reasons for that, like no hold short nodes or insufficient parking spots. Well.. all obvious things seem to be ok. I've checked hold short nodes (and distance to the runway), normal nodes in proximity, there's plenty of parking space with correct designator and range (all aircraft show up on the right spots before departure). So there's not a single problem with takeoff and parking seems fine. Driving me nuts!So now I'm looking for a summary of all possibe reasons how this can happen. Hope you can get me on the right track. Thanks!David

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi folks,A true challenge for the AI die-hards over here :( I have been building this AFCAD for Balad Southeast (OR0N) and added a lot of AI traffic. Now I have this weird problem:Sometimes the AI aircraft perform a correct approach, but dissapear after they slowed down on the runway. I know there are obvious reasons for that, like no hold short nodes or insufficient parking spots. Well.. all obvious things seem to be ok. I've checked hold short nodes (and distance to the runway), normal nodes in proximity, there's plenty of parking space with correct designator and range (all aircraft show up on the right spots before departure). So there's not a single problem with takeoff and parking seems fine. Driving me nuts!So now I'm looking for a summary of all possibe reasons how this can happen. Hope you can get me on the right track. Thanks!David
How long before the a/c is scheduled to take off again ?

Share this post


Link to post
Share on other sites

I see if I can find out (flightplans are generated with RPP_FPGen). Is there a limit? How about a max. number of missed approaches? David

Share this post


Link to post
Share on other sites

Hi,Make sure the radius of the parking spot will accommodate your plane (is this what you meant by "range"?).Sometimes this will happen if the plane is *very* late (i.e. it should already be taking off at the NEXT airport).Very occasionally, I will see that behavior if there are no empty parking spots *with the correct airline parking code*. But usually they just park at the wrong place in that case.Hope this helps,

Share this post


Link to post
Share on other sites

Oops.. I did mean radius where I said range. There is enough parking overflow with the correct parking codes, so I don't think that's a problem. It might have something to do with the departure time of the next flight/leg, because of the number of go arounds. It's kinda busy around the airbase.

Share this post


Link to post
Share on other sites

If you are sure you have plenty of parking spaces and all the runway/taxiway links are correct, then I would suspect the flightplans.You need to have the a/c on the ground for at least 45 minutes between land/departure.

Share this post


Link to post
Share on other sites
You need to have the a/c on the ground for at least 45 minutes between land/departure.
Is this a hard & fast requirement ?

Share this post


Link to post
Share on other sites
Is this a hard & fast requirement ?
i dont know if it exactly 45 minutes, but have always believed it to be there or thereabouts.

Share this post


Link to post
Share on other sites

If it were me, I'd remove all the ai, and start with a simple FP to make sure planes takeoff and land. Do that with each of your planes, one at a time. If some planes work, but others do not, than there is more than likely a parking issue with the aircraft that do not work. I don't know what you are using for AI, but many user planes do not make good AI.In FS9, it is possible to have legs of an FP be very close together, and even overlap a little. In that case, a plane lands, taxis to parking, and then radios for take off.I have not heard of the program you are using for FPs. I always used Ttools for FS9 FPs.If you must have a great deal of AI, consider adding a second parallel runway. A short one will attract fighters, and a longer one will attract cargo and other large planes. If you arange parking carefully, it can work well. This cuts down on go-arounds.Bob

Share this post


Link to post
Share on other sites

Hi Bob,All individual a/c work just fine and are of very high quality AI (Military AI Works stuff; if you don't know it you should check it out: here). The tool I'm using saves a lot of work generating FPs. Again: if you don't know it, give it a try (rpp_fpgen_v1.0.zip). It's great.I agree it must be in the short turnaround time between landing and take-off. I will limit the number of legs per day and see what happens.Thanks for the help everyone!David

Share this post


Link to post
Share on other sites

DavidI do know MAIW. I use their planes. But not the AFCADS or FPs. More fun to make my own. I use AIFP for FP generation, now.Still sounds like a parking issue.Bob

Share this post


Link to post
Share on other sites

Usually it is because you do not have enough parking spaces available for all your traffic or the radius for open parking spots are to small to accommodate the aircraft, so in either case it will disappear.Clutch

Share this post


Link to post
Share on other sites

Sorry guys, that's the odd thing: I am VERY VERY sure that it's not parking related. I have created lots of FPs and detailed AFCADs and never saw this before. I have more than enough parking spots available when this happens, all with the right radius, connected to taxiways, types and codes OK. It's just weird. I told you ;-)David

Share this post


Link to post
Share on other sites
Hi folks,A true challenge for the AI die-hards over here :( I have been building this AFCAD for Balad Southeast (OR0N) and added a lot of AI traffic. Now I have this weird problem:Sometimes the AI aircraft perform a correct approach, but dissapear after they slowed down on the runway. I know there are obvious reasons for that, like no hold short nodes or insufficient parking spots. Well.. all obvious things seem to be ok. I've checked hold short nodes (and distance to the runway), normal nodes in proximity, there's plenty of parking space with correct designator and range (all aircraft show up on the right spots before departure). So there's not a single problem with takeoff and parking seems fine. Driving me nuts!So now I'm looking for a summary of all possibe reasons how this can happen. Hope you can get me on the right track. Thanks!David
Hi DavidI just had the same problem. Turned out that I had turned off or disabled the Addon Scenery. As a result I was using all default afcads. Since the modified afcads are in the addon scenery/scenery folder you can understand why. Hope this helps.

Share this post


Link to post
Share on other sites