Jump to content
Sign in to follow this  
Turbine777

ENBSERIES plug-in and Alt+Enter crash?

Recommended Posts

Hey guys, I've been trying to chase down a new crash that I just started getting. I use to Alt+Enter several times a flight with no issues at all but now that I'm using the free ENBSERIES plug-in I seem to have FSX crash more often than not when going to and from windowed mode or when accessing the menus. It will either be completely black or FSX just minimizes and will not come back up, even with the aid of task manager.I have been disabling it (Shift+F12) prior to ALT+Enter but still having the issue. I am currently running a batch of tests to try and eliminate some possibilities but figured I would ask to those that have used it more than myself.I am thinking it may be a conflict between either the HIGHMEMFIX=1, FSWC or the AA tweaks from the sticky here in the general section.To answer a few questions that I would probably ask someone in my situation;

  • I was using *******'s shader fix but no longer since it and FSWC do not play nice together.
  • After removing and reverting back and removing his shader fix I did change the version number in SHADER_CACHE_VERSION= to something different to have FSX rebuild the shader files.
  • I am and always am in DX9 mode.
  • FSX light bloom is disabled.
  • The windows event logs aren't much help being that the faulting module is listed as "unknown, version: 0.0.0.0, time stamp: 0x00000000".
  • For bufferpools I'm using "RejectThreshold=524288" currently for troubleshooting but had it crash again since the change.
  • My CPU temps are great but my GPU temps are about 82-85c immediatly after crash.
  • Other new addon is EZCA, but have not had any issues like this until now (have had it a week or more).
  • My mothers maiden name is Kennedy.

One other thing I just noticed is that in my FSX.cfg I have a line in the Graphics section for both "SHADER_CACHE_PRIMED=1693500766" and also "SHADER_CACHE_PRIMED_10=1693500766". Are the two entries suppose to be there? I imagine so and don't think the issue is from it since a fairly old fsx.cfg.backup has both too.Here's my complete fsx.cfg if that's needed. It is in text format and will open in a new window (I didn't want to create a 10' post by just pasting it here).Thanks, hopefully this has been seen and dealt with before, although I haven't found anyhing yet. Or maybe I'm missing something obvious.Time to do some more process of eliminating, maybe I'll get lucky.


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post

I've had this same issue since I started using ENBSeries and I have confirmed that I don't get the crashes if I'm running without ENB. I've seen people suggest that the issue happens when running ENBSeries + heavy payware aircraft, and that the solution is to run FSX in XP SP3 Compatibility mode. I could swear that NickN over at simforums was saying that in one of his big threads, but I've just searched the main ones and couldn't find any reference to it.EDIT: Found it:http://www.simforums.com/forums/nhancer-for-25715-and-25721-updated_topic34873.htmlQuoting NickN here:'If you use the ENB MOD you may need to set FSX.exe to run in COMPATIBILITY MODE for WINDOWS XP SP3 or accessing menus with big payware may crash, REGARDLESS of HIGHMEMFIX=1 which actually may cause a crash with ENB running. This may fix that issue''Thats ONLY for ENB Mod/ FSX Menu crashes. This can reduce performance so if you dont need this change to avert ENB d39.dll crashes, dont do it!'I've never actually tried doing what he suggests there, mainly because I can live with the problem (although it is very frustrating when it happens), and really don't want any performance hit!


<a href="http://www.flyaoamedia.com"><img src="http://angleofattack.s3.amazonaws.com/blog/wp-content/uploads/2010/09/aoasiggy.png"/></a>

Nick Collett

i5 2500k @ 4.4GHz, GTX 480, 8GB Corsair 8-8-8-24, 300GB WD Velociraptor, Corsair HX850W

Share this post


Link to post

Thanks Nick, I too have not found anything from Nick but will have a more thorough look now that I know where to look. The Rex forum was where I recently read about it and am going to post over there shortly and will update this thread if I find any other good info.To update what I have done;I also confirmed it is only when the plugin is installed but also saw something that should be able (maybe) someday be fixed.What I was doing is running it then before I went to windowed mode would both disable it (Shift+F12) and then also Pause the sim. Well, that would probably keep it from crashing but unfortunately even if disabled and sim paused, upon changing from windowed to full screen and vice-versa, the plugin re-enables itself automatically. I have also tried various other configurations by replacing the ini.Will update more if I learn something new and thanks again for the info, Nick.Edit: Thanks for the update Nick. I'll check out the link!When you say performance hit, do you mean there is a hit if running in WINDOWS XP SP3 mode? I never tried it but will when I get home. I actually gained performance since ever since I installed the plugin, I was able to disable the normal FSX light bloom (was nice to disable this since seeing the sun thru the earth was getting annoying). I'm glad I did and this mod is the best I have ever seen, it really makes FS look a lot better,,, a lot! Especially Rex clouds edges.


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post
When you say performance hit, do you mean there is a hit if running in WINDOWS XP SP3 mode?
I think that's what he means!I've never actually tried it though, because I've been worried about the performance hit. That's a bit of a weak excuse though, I must give it a go in compatibility mode and see how bad the hit actually is!

<a href="http://www.flyaoamedia.com"><img src="http://angleofattack.s3.amazonaws.com/blog/wp-content/uploads/2010/09/aoasiggy.png"/></a>

Nick Collett

i5 2500k @ 4.4GHz, GTX 480, 8GB Corsair 8-8-8-24, 300GB WD Velociraptor, Corsair HX850W

Share this post


Link to post

Thanks again, Nick. I will give it a shot as well soon as I get home and am looking forward to it.


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post

It's strange that some people see problems like this with ENB - I've been using it for quite a while now and I've had no such problems...


Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post

Ryan, From your past posts I have also gathered that you normally fly only in windowed mode and if that's the case wouldn't expect you to ever see it. This issue is only seen when changing back and forth from full to windowed and/or back again.I can fly and have tested for a 4 hour flight with 0 problems in full screen mode. I can also fly for endless time in windowed mode again without issue. I have since then been able to recreate the bug right away with just a few Alt+Enters 100% of the time.At one point last night it took about 10 Alt+Enters to produce it but surely enough, it happened.It would be nice if someone with the smarts was able to edit the .dll or ini with some type of command to not re-enable itself when the DX window changes.


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post

Hi fellas - Did a bit of research and found Windows Vista 64 came out before XP SP3 so the only compatibility mode available is XP SP2 unfortunately, wonder if it will still work? Nick, have you tried Nick_N's tweak in the post you referred to?


\Robert Hamlich/

 

Share this post


Link to post

I'm pretty sure this has happened to me in windowed mode too, so I don't think that's an easy ticket out :(I've also noticed that the crash has occurred less since I upgraded to my GTX 480. Also, strangely enough, the key command to disable ENBSeries doesn't work while the MD11 is going through its initialization process. I think the flashing when it loads up is normal, but I was always able to quickly disable it when I was using my old GTX 280, but cannot with the 480. Once the aircraft has fully initialised, it toggles on/off fine.

Nick, have you tried Nick_N's tweak in the post you referred to?
Nope, not yet. I must give it a go at some point, I've just not wanted to take the performance hit. I need every FPS I can get for the work I've been doing with Chris at AoA.

<a href="http://www.flyaoamedia.com"><img src="http://angleofattack.s3.amazonaws.com/blog/wp-content/uploads/2010/09/aoasiggy.png"/></a>

Nick Collett

i5 2500k @ 4.4GHz, GTX 480, 8GB Corsair 8-8-8-24, 300GB WD Velociraptor, Corsair HX850W

Share this post


Link to post

That's interesting about the MD-11 initialization period. I haven't tried it during that time and with all the flickering doubt I would be able to see if it was disabled or not anyway. I think I'll try something tonight with windowed mode that I haven't yet tried. I'm guessing it will cause the same effect that Alt+Enter is doing in regard to re-enabling the mods .dll. The test is going to be a focus test and a resize test. When going from full screen to windowed the DX window changes and that's where I imagine the dll is re-enabling, but perhaps its also a focus factor? I doubt it and the test I did was a flight in windowed mode where I left the room and did other things for a couple hours then came back and all was fine. I wonder if in windowed mode if I click the desktop or a folder (anything to break focus) if it will also re-enable. I would imagine resizing it will since once again the DX window is changine and being redrawn. Hopefully I'll be able to test all these things tonight. I am 99% certain though it wouldn't happen at all if there was a way to disable it and keep it from re-enabling itself. I believe it's the exact second it is doing this that is causing the crash since it is happening at the busier time of the system, video driver, or DX in general.Edit:Another thing I will try later tonight is what Nick.N recently wrote. just mentioned. Here is a quote below:

None the less, the d3d9.dll is still loaded with FSX even if the mod is off via SHIFT F12 If you want to try this it may provide a solution Switch FSX back out of compat mode.. so its not using XP SP2/SP3 compat Go into the enbseries.ini file in notepad and change this setting: [GLOBAL]UseEffect=1 to [GLOBAL]UseEffect=0 save and exit.. I have never tried it myself, boot a full screen flight, verify the effect is disabled via SHIFT F12 and then drop to the desktop.. go back to FSX and see if the effect is still off. If it is, then see if the d3d9.dll crashes stop with the effect disabled before switching screens, etc Based on the description, the OPPOSITE action should occur when you switch to the desktop or window/full mode, the effect SHOULD disable automatically instead of enable and you may not need to disable it manually. If it works and I get enough positive reports back I will add that to the instructions for the mod

i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post

Great news, the edit NickN mentioned for:

[GLOBAL]UseEffect=1 to [GLOBAL]UseEffect=0

... is just what the doctor ordered! This not only fixes the crash, but as I mentioned prior about noticing the d3d9.dll re-enabling itself each time you change your DX window has fixed that too. Also, no need to run in compatability mode which I'm sure will be a great relief to many.I did some other tests as well and it appears each time you alter the DX window at all, it will revert back to it's ini setting and reads it each time it has to refresh and not just once re-enabled (toggled via Shift+F12).This means even in windowed mode if you resize the sides at all and have "UseEffect=1" set, you will see that it will once again be turned on.Using "UseEffect=0" will make sure after each window resize (or DX window change/redraw) that it will default back to off. This is a huge plus since at first I thought this tweak might only effect it for its original default startup and after toggling Shift+F12 once would revert back to the bug.Being able to edit this on the fly while loaded in FSX is a major plus also.So far so good, and prior to this I have been able to recreate the crash 100% of the time and now after about 100 Alt+Enters have no issue.I will keep a close eye on this and report any more occurences but so far, so great!


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post
[GLOBAL]UseEffect=1 to [GLOBAL]UseEffect=0

I sincerely hope that this fixes the crash for me too, I just had to change a setting in fsuipc on climbout and it went black on me - wish I'd seen this post before I tried to go flying!

<a href="http://www.flyaoamedia.com"><img src="http://angleofattack.s3.amazonaws.com/blog/wp-content/uploads/2010/09/aoasiggy.png"/></a>

Nick Collett

i5 2500k @ 4.4GHz, GTX 480, 8GB Corsair 8-8-8-24, 300GB WD Velociraptor, Corsair HX850W

Share this post


Link to post

Hey Nick, I don't wanna jinx things but last night I had it crash again, even with the above tweak. I didn't have time to test to see if it was because I Alt+Entered with it active or not. I haven't mentioned anything yet because really haven't had much sim time until early this morning when I saw it. I also wanted to test later to test another hunch before saying my thoughts but might not be simming much tonight if at all.My thoughts are that it is crashing because of the off/on or on/off that it's doing when either resizing or alt+entering. So in other words, the first night I didn't see any issues but it is also possible that each time I alt entered I left it in the disabled state. At least thats what I'm hoping. It may have crashed because with the above setting and the chance it was enabled, it would automatically disable itself on switch and hope thats where the issue lies.On another note: As I mentioned it only crashes when changing window state and never if I just leave things alone. Unforunately, that isn't an option since when I take off I am interupted with an FSP fuel alert that brings up it's own window and was causing the same window state change.As you can see, I need to once again, test some more but wanted to give you heads up before hand. I wish I had the knowledge that Ryan, NickN and ******* have on these issues. I would focus all my free time on it since it's such a great and needed enhancement (and free), but all I can do is try to study it analitically and report what I'm seeing in hopes that those who know, share.


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post

Oh so this ONLY happens when you switch between windowed/full screen?I can stay all day in either, but still get the crash when I access a menu. As you say it'll be interesting to see how it goes once you test further with it enabled/disabled.


<a href="http://www.flyaoamedia.com"><img src="http://angleofattack.s3.amazonaws.com/blog/wp-content/uploads/2010/09/aoasiggy.png"/></a>

Nick Collett

i5 2500k @ 4.4GHz, GTX 480, 8GB Corsair 8-8-8-24, 300GB WD Velociraptor, Corsair HX850W

Share this post


Link to post

When you access a menu it is the same thing. You are causing the DX window to refresh or redraw. There isn't any difference. It isn't the same as say refresh rate but you'll notice with the above tweak and accessing a menu will have the same exact effect as resizing. I suppose I should have better explained. I also mentioned I can stay all day in either without issue too. Only if Alt+Tabbing, resizing, or menu access (anything that causes the DX window to redraw) will have the potential to produce the crash.


i9 10920x @ 4.8 ~ MSI Creator x299 ~ 256 Gb 3600 G.Skill Trident Z Royal ~ EVGA RTX 2080ti ~ Sim drive = M.2  2-TB ~ OS drive = M.2 is 512-gb ~ 5 other Samsung Pro/Evo mix SSD's ~ EVGA 1600w ~ Win 10 Pro

Dan Prunier

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...