Archived

This topic is now archived and is closed to further replies.

ChaoticBeauty

Light Bloom not visible from VC

Recommended Posts

I can't find any reports on this so I'm wondering if I'm the only one with this problem. The effects of light bloom are visible only from the C172 and 206B virtual cockpit, and on any other aircraft's virtual cockpit I see no effect. Does anyone else get this, and is there a fix?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

There is no effect on the panel itself or looking out the windows at the terrain?

 

Is this native bloom? Dx9? Dx10? ENB?

 

Be more specific.

Share this post


Link to post
Share on other sites

There is no effect on the panel itself or looking out the windows at the terrain?

 

Be more specific.

 

The effect does not work at all when viewing the world from inside the cockpit. For example, during an approach, in spot view I get the bloom effect on the runway lights. In cockpit view, the runway lights look normal, without the bloom effect.

 

The C172 and 206B are exceptions though.

Share this post


Link to post
Share on other sites

What kind bloom is it? I edited my original post to include that but you didn't say what you're using.

Share this post


Link to post
Share on other sites

What kind bloom is it? I edited my original post to include that but you didn't say what you're using.

 

Native DX9 bloom.

Share this post


Link to post
Share on other sites

Hardly anyone uses native dx9 bloom because it kills system performance.

You probably won't find many here that can give you feedback due to this.

 

I have used bloom with dx10 before and never noticed any problems with plenty of pay ware aircraft and default.

ENB also hasn't given any problems.

 

Personally I stay away from dx9 bloom like the plague so I have no idea what your issue could be.

 

You may try looking into ENB which gives a similar bloom effect without the performance hit.

Share this post


Link to post
Share on other sites

I know it kills performance, but since I usually fly into non-complex areas, I almost always leave it on.

 

If anybody knows anything about this, please post. If it's an FSX bug, then I doubt it can be fixed, but I'd like to know if there's a solution.

Share this post


Link to post
Share on other sites

I messed around with bloom in dx9 a little yesterday with the Realair Duke v2 and it looked amazing. I was getting bright sheen reflections off the interior panels depending on the sun's location. I should have taken some pics. I did post some pics awhile back demonstrating this with the Lancair. Looks freakin awesome, but unfortionately the fps hit is just not worth it, especially in heavy sceneries.

 

SfqO.jpg

H5yK1.jpg

r1u3f.jpg

ktU.jpg

Share this post


Link to post
Share on other sites

i know about the bug that shows bloom through the panel, and i know that there's a fix, but dont remember its name and where it is. 

so in the Duke v2 bloom works in the VC, and also in helis, but in many other planes don't. (default 737 i.e.).

I am going to do ANOTHER fresh install - SIGH - and see if it works.

Share this post


Link to post
Share on other sites

i know about the bug that shows bloom through the panel, and i know that there's a fix, but dont remember its name and where it is. 

so in the Duke v2 bloom works in the VC, and also in helis, but in many other planes don't. (default 737 i.e.).

I am going to do ANOTHER fresh install - SIGH - and see if it works.

Don't, it's a waste of time. Fresh install never fix anything, they just replace the files that were already there. If you haven't done strange things to your installation, it will never work no matter how many times you reinstall it. 

Share this post


Link to post
Share on other sites

I messed around with bloom in dx9 a little yesterday with the Realair Duke v2 and it looked amazing. I was getting bright sheen reflections off the interior panels depending on the sun's location. I should have taken some pics. I did post some pics awhile back demonstrating this with the Lancair. Looks freakin awesome, but unfortionately the fps hit is just not worth it, especially in heavy sceneries.

 

Wow, so not only does the bloom work through the aircraft's window, but it also creates light inside the actual VC. Thank you for the screenshots, they look amazing.

Share this post


Link to post
Share on other sites

ok did the fresh install and......... default 737 (and many other planes) do not show bloom in VC :( ....wondering is there is a fix........

Share this post


Link to post
Share on other sites

ok did the fresh install and......... default 737 (and many other planes) do not show bloom in VC :( ....wondering is there is a fix........

 

I did some testing a few weeks ago, and most aircraft do not show the bloom inside the VC. The only aircraft that allow it are the Cessna 172 and the Bell 206B for sure, and maybe the King Air.

 

As for add-on aircraft, that should depend on the developer.

Share this post


Link to post
Share on other sites

at least i found out why.

it is because of the windshield, the 3D part of the cockpit, in the .mdl file of the airplane. Sadly i don't know how to edit .mdl files and anyway i think it is not possible.

If you want you can try: open fsx in the default 737, then with CTRL+BACKSPACE move your view until you go OUT of the VC... and voilà, the bloom appears..............

(CTRL+ENTER to come back in the plane).

if only i could remove the windshield....

Share this post


Link to post
Share on other sites

at least i found out why.

it is because of the windshield, the 3D part of the cockpit, in the .mdl file of the airplane. Sadly i don't know how to edit .mdl files and anyway i think it is not possible.

If you want you can try: open fsx in the default 737, then with CTRL+BACKSPACE move your view until you go OUT of the VC... and voilà, the bloom appears..............

(CTRL+ENTER to come back in the plane).

if only i could remove the windshield....

 

Exactly, that's what I did when I made that testing a few weeks ago. When you go out of the windshield, the bloom appears.

 

I wonder why the windshield blocks the bloom in some aircraft and doesn't in others.

Share this post


Link to post
Share on other sites

omg OMG i did it !!!

i installed the SDK and i used a tool called ModelConverterX_130, then i modified the material of "REFECTION" object, and saved the mdl.

try if you want.

download my mdl here:

 

https://www.wetransfer.com/downloads/2db38960034b743f6db318acbf133ce120131104194927/d7f46fcd0f52fc82260fb5e4d756a93a20131104194927/23bc58

 

backup your C:\FSX\SimObjects\Airplanes\B737_800\model\B737_800_interior.mdl and copy mine.

Share this post


Link to post
Share on other sites

ok wait, i noticed the VC lost lot of gauges functions and animations (i.e. landing gear lever).

I will keep working on it, even if it is not a true problem for me, i use only keys and joy.

Share this post


Link to post
Share on other sites

ok wait, i noticed the VC lost lot of gauges functions and animations (i.e. landing gear lever).

I will keep working on it, even if it is not a true problem for me, i use only keys and joy.

 

I'm glad you found the root of the problem and I hope that you can refine this fix further. Can you do it for more aircraft too?

Share this post


Link to post
Share on other sites

yes i did it for the 747 also, and i think i can do it for any aircraft when i will find out how to keep the gauges working.

i'll keep you and this thread up-to-date

Share this post


Link to post
Share on other sites

i am sorry, but i did not found no way to edit the mdl and then exporting a working one.

mdl files, as we already know, are closedsource.

Share this post


Link to post
Share on other sites