Jump to content

Archived

This topic is now archived and is closed to further replies.

PainfulBack

FSX Crashing when using Menus (In flight)

Recommended Posts

Hello everyone.

 

After a long time away from simming, I have recently upgraded my PC where it is now well suited to such things. I have just today done a clean install of FSX SP1 & 2, and decided to do a flight. Durring flight all seems well, untill i start going threw the menues, to change views, pull up GPS, radio stack,throttles ect ect. Then It crashes. Goes to desktop, and wants me to search online for a fix. None found via that route. I can be 2 min into flight, or 50 minutes, its using the menues that is almost for sure causing it. Any help would be great.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Very likely a UIAutomationcore.dll crash. Do a quick search of this forum category or even a google search and you should find an answer pretty quick. I'd find it for you, but I don't have the time at the moment. To put it simply, you need the UIAutomationcore.dll from Windows Vista in your main FSX folder.

Share this post


Link to post
Share on other sites

Hello Hughes, tyvm! I did not expect a reply in 24 hours much less 5 minutes! :) Hopefully this is a good sign that the community is alive & well :) I'll check out your suggestion. Ty again :)

Share this post


Link to post
Share on other sites

Hello everyone.

 

After a long time away from simming, I have recently upgraded my PC where it is now well suited to such things. I have just today done a clean install of FSX SP1 & 2, and decided to do a flight. Durring flight all seems well, untill i start going threw the menues, to change views, pull up GPS, radio stack,throttles ect ect. Then It crashes. Goes to desktop, and wants me to search online for a fix. None found via that route. I can be 2 min into flight, or 50 minutes, its using the menues that is almost for sure causing it. Any help would be great.

 

Thanks in advance!

You need to download uiautomationcore.dll and put it in your main FSX folder. Here is the link to right version https://dl.dropbox.com/u/31158446/Blog/UIAutomationCore.rar

 

Just drop it there, don't do anything else(adding to the registry etc)

 

Cheers

Share this post


Link to post
Share on other sites

Upon initial trial, I do believe you nailed the solution Hughes! Tyvm, I owe you one! DL'ed that file, put in FSX directory, no problems yet :) And lots of menu clicking! :)

Share this post


Link to post
Share on other sites

Hey guys

 

I have been battling this issue and have replaced my file in the fsx main folder as well

It still does it

 

Any more ideas

I even removed my system files and tried it with no improvement

I have since placed the files back in the system and system 64 folders

 

It's very annoying to not be able to use the menus

 

Ay helps would be great

Thanks as always

 

Jho

Share this post


Link to post
Share on other sites

Hey guys

 

I have been battling this issue and have replaced my file in the fsx main folder as well

It still does it

 

Any more ideas

I even removed my system files and tried it with no improvement

I have since placed the files back in the system and system 64 folders

 

It's very annoying to not be able to use the menus

 

Ay helps would be great

Thanks as always

 

Jho

 

 

1. go here and replace your FSUIPC with the new version(you have probably done this, but i added this step just to be sure) http://forum.simflig...pdated-modules/

 

2. Check again that you have right version of UIAutomationCore.dll (i insist with this becouse many simmers have wrong version, or they tried to add this to registry which will cause CTD's :) )  Link to the right version: https://dl.dropbox.com/u/31158446/Blog/UIAutomationCore.rar

 

3. I copied from another forum to safe time, it's important for fsx menu crashes:

"Just follow this steps (even if the seem weird to you)

 
1) Go inside your FSX root folder, right click on the fsx.exe file and select properties.
2) Now go to the Compatibility tab and select the option that says: 'Change settings for all users'
3) Make sure ONLY the following options are checked: 
- Disable visual themes
- Disable desktop composition
- Run this program as an administrator
4) Press Apply, Apply, OK Until you clear all windows
5) Now, go to the control Panel
6) Select the icon called 'Personalization'
7) On the left pane, you'll see the option 'Change mouse pointers' click on it.
 Now, in the mouse properties window, select the 'Pointers' tab
9) Set (None) under the pulldown where you see 'Scheme' and press apply"

Share this post


Link to post
Share on other sites

i will give this a shot 

 

Thank you very much for the reply !!!!

 

Wish me luck 

other than this issue and my throttles FSX works great ( knock on wood ) 

 

JHo

Share this post


Link to post
Share on other sites

Tryed everything you told me to 

 

and it still does it 

 

very frustrating 

 

any other suggestions :(

 

Thanks 

Jho

Share this post


Link to post
Share on other sites

You should start a new post as this gets confusing when you add your problem to a post that has been "Answered".  No one is going to visit it anymore as they think the problem has been fixed.  Start up a new post.  Run AppCrashView - http://www.nirsoft.net/utils/app_crash_view.html and copy and paste the results of the crash in the new post.  Thanks.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Copy that

 

I will run that when I get home and post the results

Thanks for the help

 

Jho

Share this post


Link to post
Share on other sites

×
×
  • Create New...