Jump to content

Archived

This topic is now archived and is closed to further replies.

flyinion

Thinking of trying DX10

Recommended Posts

Been seeing a lot of posts over at FTX and here about DX10 working pretty good and a link to the site to go get all the various "patches" from.  I see a lot of stuff has been fixed, I was wondering though what stuff in the base sim still is broken in DX10 mode? I think all my addons will be compatible.  My FSGenesis mesh of course shouldn't be an issue and I already know REX, OrbX scenery, and my one addon plane (QW Avro) is DX10 compatible (I know OrbX has the odd lights problem in clumps but I'm ok with that).

 

Except for a couple of freeware airports with physical scenery upgrades, all the rest of my airports are Ray Smith AFCAD type files that re-use default scenery bits if there are any physical changes I believe so the only thing I might have not working are some random freeware aircraft that I never use anyway or possibly stock AC repaints if they're not DX10 compliant if I understand right.  So I'm planning on checking out DX10 mode this weekend.  Just wanting to see if there are any "across the board" issues that are still broken.  As an example the disappearing progressive taxi line, I know it's been fixed but I'm using that as an example of what I'm asking when I'm wondering if there are any sim-wide issues still that haven't been fixed.

Share this post


Link to post

   Mind if I but in?

 

   I've been beating this (DX10) mule for two now and I think I have a fairly good thing going. However.....

 

All have been fixed.

   I still have the flashing runway/taxiway/lines everywhere. Have I missed an update or may a suggestion be made that you think I might have overlooked?

 

Thanks ---chik----

 

PaulJ, this is all your fault  !!! :lol:

Share this post


Link to post

 

 


I still have the flashing runway/taxiway/lines everywhere. Have I missed an update or may a suggestion be made that you think I might have overlooked?

 

If you have flashing runways/taxiways everywhere then Steve's DX10 Shader Fix 3.2.2 did not install properly.  You'll have to reinstall.  PJ has a complete ShadersHLSL folder that you can download and replace with yours then try to reapply the fix.  But you don't really need to download the complete file as the only file that was changed was the General10.fx which was backed up when you installed the fix.  Unfortunately though, you have to delete all the files that were included in the fix (like PatchGeneral10; PatchGeneral10Part0; etc.) as the fix will not work when it sees these files in your ShadersHLSL\General folder.  The flashing runways/taxiways was one of the main anomalies that was removed with Steve's Fix.

 

Best regards,

Jim

Share this post


Link to post

Hi Jim

 

   Maybe I missed a function on installation of Steve's files. You say

 

reapply the fix

....as if I need to .exe something in his package. Could you elaborate please?

 

Thanks---chik---

Share this post


Link to post

Hi Jim

 

   Maybe I missed a function on installation of Steve's files. You say

....as if I need to .exe something in his package. Could you elaborate please?

 

Thanks---chik---

 

When I downloaded it there is a .bat file in there that runs some .vbs scripts to update the shaders.  That's probably what he's talking about.

Share this post


Link to post

Been using DX10 for months and will "not" switch back......ever!

Share this post


Link to post

Hello flyinion

 

   If that is true I will wait till PaulJ jumps in. He helped (did most of the work) and should be able to verify if in fact that was done. Everything is coming together nicely so I don't want to *&%$*(^ anything up.

 

   Thanks for that so far.......

Share this post


Link to post

Been using DX10 for months and will "not" switch back......ever!

 

Yeah I think I'm gonna be on that bandwagon too.  Everything seems to be working great, got my AA working properly now too, and getting 10-15% fps improvement with no issues other than a few funny strobe issues with default AC (some won't come on unless landing lights are on for example, but it's a default AC I can live with it).  ALL of my current addons seem to work well with DX10 and it seems like all the ones I'm interested in still getting (except UT2 not sure about that one) also work with DX10 such as the Realair Duke and the PMDG NGX.

Share this post


Link to post

......I have also noticed that the cars lights are black squares.........?

Share this post


Link to post

Been using DX10 for months and will "not" switch back......ever!

+1

Share this post


Link to post

Been using DX10 for months and will "not" switch back......ever!

What about grey runways at dusk and dawn? 

Share this post


Link to post

What about grey runways at dusk and dawn? 

 

Bit like the smell of napalm...I love em!

Share this post


Link to post

Hi Jim

 

   Maybe I missed a function on installation of Steve's files. You say

....as if I need to .exe something in his package. Could you elaborate please?

 

Thanks---chik---

Here's what my folder looks like....

 

3Crj.png

 

Yours should look exactly like this.  If not, you'll need to download the complete folder on one of PJ's links pinned above and try the fix again.

 

Best regards,

Jim

Share this post


Link to post

Bit like the smell of napalm...I love em!

That's what still keeps me in DX9 mode.

Where are you Steve? :(

Share this post


Link to post

What about grey runways at dusk and dawn? 

 

 

......I have also noticed that the cars lights are black squares.........?

 

 

Not seeing either of these two issues.  I checked car lights at dusk/night in both default and OrbX PNW areas (I believe OrbX uses their own cars but I may be wrong).  Not seeing any gray runways either.  The only thing I need to do is apparently make a custom water texture in REX because the default one in REX seems too light in DX10 mode.

 

Edit:  I think I found out part of what's up with my water.  I used FSWC to modify things a while back and just realized it doesn't work in DX10 mode.  Apparently there is a lite version that has one DX10 preset, so I'm going to check that out.

Share this post


Link to post

   Hi flyinion

  

 

I think I found out part of what's up with my water. I used FSWC to modify things a while back and just realized it doesn't work in DX10 mode. Apparently there is a lite version that has one DX10 preset, so I'm going to check that out.

    This is one area REX/ FSWC Lite that I am very familiar with. I have incredible looking water. I'd be glad to give you any tips. REX water needs to be just a little tweaked to be a dirty, tad bit darker for both inland blue and inland brown. That hard glue and hard brown they give you looks aweful in DX10.

 

   In fact I just uploaded my DX10 theme to REX and you can find it by looking for "Beautiful Summer Day". I hope the water tweak sticks when it's uploaded. I had downloaded a couple of themes from users a while back and teh inland water was always default. Give that a whirl.

 

PS: I am also working on a SweetFX file too and will share that as well...............soon.

Share this post


Link to post

Could you try posting your water settings in case it doesn't come down with the theme?  I'd love better water.  I have my P3D water looking amazing but DX10 water in FSX still looks awful.

 

-stefan

Share this post


Link to post

Thanks I'll look for the theme and check the water out!  Once I confirm my suspicions about SweetFX causing FSX to randomly disappear to the desktop with no errors in DX9 mode by completing a flight without it and in DX10 mode, I'm going to re-introduce it and see how it behaves in DX10.

Share this post


Link to post

Not seeing either of these two issues.  I checked car lights at dusk/night in both default and OrbX PNW areas (I believe OrbX uses their own cars but I may be wrong).  Not seeing any gray runways either.  The only thing I need to do is apparently make a custom water texture in REX because the default one in REX seems too light in DX10 mode.

 

This issue is most of Aerosoft and Flytampa addon airports.

Share this post


Link to post

   Hi flyinion

  

    This is one area REX/ FSWC Lite that I am very familiar with. I have incredible looking water. I'd be glad to give you any tips. REX water needs to be just a little tweaked to be a dirty, tad bit darker for both inland blue and inland brown. That hard glue and hard brown they give you looks aweful in DX10.

 

   In fact I just uploaded my DX10 theme to REX and you can find it by looking for "Beautiful Summer Day". I hope the water tweak sticks when it's uploaded. I had downloaded a couple of themes from users a while back and teh inland water was always default. Give that a whirl.

 

PS: I am also working on a SweetFX file too and will share that as well...............soon.

 

I just went looking for your file and can't seem to find it.  I browsed through the list and saw nothing with that name?

Share this post


Link to post

Ok so I fixed my water problem.  I had run FSWC Lite which has a demo of a DX10 water from their upcoming new version of FSWC.  After playing with my own REX water texture settings a bit things just still weren't looking right.  Did some looking and found a suggestion to clear the water cache when using FSWC Lite.  I removed the water texture cache files and bam I had amazing looking water using the FSWC Lite DX10 profile even with the default set of water textures that come with REX.  Ocean is a nice deep blue, etc.

Share this post


Link to post

Yup you nailed it fly'  You have to delete that (C/users/yourusername/AppData/Local/FSX/Shaders10 folder everytime you change anything shader wise. Particularily in DX10.

   Did I hear a shutter?......................

Share this post


Link to post
×
×
  • Create New...