Jump to content

Archived

This topic is now archived and is closed to further replies.

kaloska

I have major stuttering close to bigger airports, if My Traffic Ai enabled

Recommended Posts

Hi Folks !

 

I have heavy stuttering for several seconds closing to a bigger Airports with traffic enabled. Without "My Traffic" Ai the approach is smooth. This happen 2-3 miles from an airport like KPAE and I think when the Ai will be active in those airports. This is natural or my system can not handle it very well ? If I oc my processor, this problem is remaining too, and my PC is optimised with cfg tweeks naturally. This stutters are not micro stutters and several seconds long . Any help would be good from You . THX

 

My rig: i5-750, Ati 4890/1g, 4 GB ram.

Share this post


Link to post
Share on other sites

Your video card is holding your system back I believe.

Share this post


Link to post
Share on other sites

Using UTII here - Since UTII gives you a hotkey to disable AI I will usually use it when approaching a heavy AI airport like KSFO.  It is the only way I can get decent frames when landing.  Anyway AI is probably the #1 FPS killer on my system.  

 

Cheers

jja

Share this post


Link to post
Share on other sites

 

 


AI is probably the #1 FPS killer on my system.

That's true, and Snohomish is in Seattle area, which isn't the easiest on frames either. Maybe cutting back on scenery (autogen density) can help a bit, too?

Share this post


Link to post
Share on other sites

Thanks for responds !

 

As I sad, this several seconds long heavy stutter are only appear in a specific distance (4-5 miles) from a bigger airport than dissapear. I don't think  that my gfx card is cause of my stutters therefore. Any other idea ? My ai setting is only 10 % ga and airliners , and disabled every other ai. And I disabled the "exits for ground animations" option in My Traffic setup  too.

Share this post


Link to post
Share on other sites

What happens if you turn off all the AI traffic?

Share this post


Link to post
Share on other sites

Without ai I have not any big stutters as closing a bigger airport like KPAE. KPAE because I testing everything on KSEA-KPAE route.

Share this post


Link to post
Share on other sites

If it's only restricted to the proximity of any city with many highly frequented airports, like Seattle, London or Paris, this is normal, because many airports with high amounts of traffic will put an extra load to your computer!

It may be especially bad in/around Seattle, because MS chose to depict Seattle as closely to the real one as it was possible within the limits of the sim in 2006, which sadly has the result that this area is really performing badly on most systems, so I guess you'll have to cut back on some settings.

 

I agree with Jim's first answer to your question, the video card might indeed be the problem, because as you can see I think my computer has quite similar specs, yet I'm able to run FSX in that area without severe stutters (this doesn't mean stutters don't occur at all, though!).

Share this post


Link to post
Share on other sites

Yes I understand, that these heavy for the system, but I dont understand perfectly why gfx is the bottleneck, because when I closing 4 miles to an airport, the ai planes not appears to me yet, therefore only the cpu working with it, not the gpu, only when ai planes visible with there higher polygons. This is not true ?

Share this post


Link to post
Share on other sites

Hi !

 

Please help me !

I tested today.

Removed all unnecessary tweeks from my config file, and I keep only AffinityMask14 and Highmemfix. The performance in the test flight was very good, no stutter, 40-50 FPS from KSEA to KPAE with C172 without any Ai activated. No texture and autogen loading problem too. It was very nice flight. After this I set 10% Ai and minimal airport traffic and fair weather. The flight was very good with 45-55 FPS, but 3 miles from KPAE I had 3-4 sec heavy stutters and the steady 45-50 FPS go down in this short period to 5 FPS and jumping too. After this short period my FPS went back 45-50, and the whole approach was wery stable and stutter free again to the runway. My processor was OC-ed to 3.4 GHz.

This is very annoying to me, because the performance in FSX never was such stable and smooth, like now.

Any idea Folks ?

Share this post


Link to post
Share on other sites

Set the in game frame rate limiter to 24fps. Setting it to unlimited can easily cause stutters as your system wastes CPU cycles trying to render all those extra frames.

Share this post


Link to post
Share on other sites

Outer FPS limiter will be good, because inner limiter cause lesser fps, than an outer limiter ?

I will try it now.

Share this post


Link to post
Share on other sites

The PAE to KSEA corridor is like a black hole, as far as performance goes...

for everyone, not just you..

 

Just ignore what happens there and go fly where you really want to fly ^_^

Share this post


Link to post
Share on other sites

Thanks Pieke !

The problem happen with limiter too.

Ramdisk not enough good to me, because I have only 4GB ram, and Ramdisk can create only 4GB too for me (limited in system ram size), and Mytraffic aircraft folder 10GB.

Share this post


Link to post
Share on other sites

I think you are overthinking this - you have a nice system.. stop finding new things to try.

 

Instead go fly!!

Share this post


Link to post
Share on other sites

Outer FPS limiter will be good, because inner limiter cause lesser fps, than an outer limiter ?

I will try it now.

Yeah use external FPS limiter set to 30 and set internal limiter to unlimited, at least on my system which also has an ATI card using internal limiter gave much lower FPS and longer loading times.

 

I wonder if this might have something to do with differences between ATI and Nvidia... Most users suggesting to use internal FPS limiter seem to be using Nvidia cards while many ATI users find external limiter to work better.

Share this post


Link to post
Share on other sites

The area around PAE can be killer on your system. I'd suggest to pick another favorite area.

Share this post


Link to post
Share on other sites

It's textures, turn down your texture resolution. I'll wager the distance is pretty much exactly 4.5nm or whatever your LOD radius is set to, and what's happening is your system is having to load textures for the airport and bogging down on IO.

 

There MAY be technical things that could help (make sure you're using AHCI mode, etc) but they're far too complex to walk someone through on a forum, and they probably wouldn't help that much anyway.

Turn the textures down, maybe reduce the LOD radius a little if it still persists, and think about a SSD for the future.

Share this post


Link to post
Share on other sites

Ah, ATI I finally notice, that is a problem also. I had ATI but switched because FSX was way smoother on nvidia.

Share this post


Link to post
Share on other sites

I would recommend you get a new video card, you are on a year 2008/09 product:

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16814150359

 

Otherwise turn down your settings, or fly somewhere else, as other more knowledgeable people here suggests to you. IMHO FSX is a headache, we forget to fly, but it´s so very easy, just turn down the settings, so your system can cope.

He threw out that idea a long time ago.

Share this post


Link to post
Share on other sites

Yes Jim, but if we repeat it a few, or more times, maybe he´ll get it??! 

 

:unsure:

Share this post


Link to post
Share on other sites

×
×
  • Create New...