Jump to content

Archived

This topic is now archived and is closed to further replies.

FlyIce

Ghost shadows

Recommended Posts

Back to the shadows again... Anyone has these ghost shadows in P3D v2? I highlighted a few by red circles, but you can see there are lots of them, particularly along the roads.

 

I have FTX Global + Iceland demo installed and this is over Reykjavik. But the same ghost shadows appear outside Iceland demo regions too. I forgot whether I saw them in P3D2 only, but I kind of believe they're there maybe in different shapes. I set shadow at High but they appear in any settings. I can confirm this has nothing to do with shadow draw distance.

Share this post


Link to post

I'm not saying it's Aliens but...  

 

They look like plotting markers someone forgot to remove before exporting..

Share this post


Link to post

Or maybe tree shadows for trees that aren't there?

Share this post


Link to post

I set vegetation to the highest but still get them. May be RoboRay's guess is more likely, those are night lighting objects? I can't be the one first seeing these ghost shadows. They're right there on your face...

 

I'll do a quick experiment tonight to see what kind of shadows they're: sim objects, vegetation, buildings, or terrains.

 

I believe I saw square ghost shadows in vanilla P3D2 too, they are mostly on road intersections.

Share this post


Link to post

That shadow setting for something like "show shadows for objects flagged to not cast shadows"...  Do you have it enabled?

Share this post


Link to post

No, just checked, the option is "NoShadow Flagged Content", and I'm sure I didn't tick on "Cast" option. So that shouldn't be the reason...

Share this post


Link to post

Ok, just to add that once I disable vegetation shadow cast, there ghost shadows are gone. So they're apparently cast by invisible trees....

Share this post


Link to post

I believe the shadow are cast by the invisible 3d lights introduced in FTX Global, since the 3d lights are autogen, they are invisible during daytime but still cast shadow now..

Share this post


Link to post

I think you could just be right. I'm no expert in these scenery components though. I think they're invisible trees only b/c the shadows are gone when I turn of shadows on vegetation.

 

Since there is a "NoShadow Flagged Content" option in the menu, I wonder whether FTX can easily remove these shadows by flagging theose day-time invisible structures as  "NoShadow Content"?

Share this post


Link to post

There's a formal acknowledgement now on the FTX Prepar3d v2 Support forum - its in the pinned Global v1.2 patch thread (sorry I don't know how to link the thread in using Tapatalk!).

 

The "ghost" shadows are caused by Global lights - the lights are made using tree models (probably how they are now so fps friendly) BUT they advise it may not be fixable if they can't disable shadows on these "tree" models!!!

 

Fingers crossed they can sort it cos it could be a biggie if they can't!

 

Regards

 

Steve

 

 

Share this post


Link to post

Thanks, Steve! I just looked at their forum and it's good to see that FTX is working on this issue. Hope it can be fixed easily...

Share this post


Link to post
×
×
  • Create New...