Archived

This topic is now archived and is closed to further replies.

BuzzyB

Scenery Library Error:"you must have Admin permission to modify the Scenery Library etc"

Recommended Posts

I have been using FSX with Acceleration for several years and got the above error message a few weeks ago.

What causes it and how do I fix it ?

I have managed to fix it, but only temporarily, by using FSXRegistry Fix; it fixes it for that session, but after I shut down then later restart, the error comes back. (I AM logged on as Administrator ).

TIA

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have been using FSX with Acceleration for about 3 years; about a week ago, I got the above error message.

What causes it and how do I fix it ?

I can fix it , but only temporarily, using FSXRegisry Fix (I can see the path in HKEY_CURRENT_USER\Microsoft\Microsoft Games, but not in .....LOCAL_MACHINE, even though RegistryFix says it's there; when I put it there it works ,but only for that session )

TIA

David

Share this post


Link to post
Share on other sites

I don't know if this will fix the problem or not but the first thing I'd try would be right clicking on the FSX icon and selecting Run as Administrator.

Share this post


Link to post
Share on other sites

IIRC this error will occur if you install FSX in the default location of "program files", it should be installed in the root of the drive. That error will show if you try to add scenery to FSX.

 

Having said that if you have been able to add additional scenery before and you have not reinstalled FSX then I can't offer a remedy.

Share this post


Link to post
Share on other sites

Thanks Anthony so simple (and obvious ) - Run as Admin fixed it, but only for the current session.

I have to Run as Admin every time I start FSX, but that's no prob - much easier than re-installing FSX.

(I still wonder what causes the prob )

Thanks

David

Share this post


Link to post
Share on other sites

Thanks for the replies:

1. Anthony: Run as Admin worked - so simple (and obvious ), but only for that session; I have to Run as Admin every time I start FSX (but that's much easier than re-installing ).

2. Vulcan: I have FSX on a separate drive (SSD) and haveadded  lots of Addon Scenery and Orbx Scenery with no previous probs, although I did add MegaScenery Earth for Mass and CT just before the problem occurred and neither would work - I have since removed them, but that didn't fix the prob.

Thanks again

Cheers

Share this post


Link to post
Share on other sites

Can you right click the FSX.exe then Properties, and set it to permanently "run as admin"?

Share this post


Link to post
Share on other sites

What Ryan means is right the FSX shortcut, select Properties and then click on the Security tab then start messing about with the security permissions. For example, check the write permission is set to Allow. Have a look at the attached screenshot (yes my computer is called Sparkles, anyone have a problem with that?)

 

It's peculiar that it only works for just that session though. I'd be worried that it points to a deeper problem (although what that is is beyond my knowledge).

post-234822-0-46485700-1386545155.jpg

Share this post


Link to post
Share on other sites

FSX->Properties->Security looks just as yours does Anthony - both me and Administrators with full permissions.

 

Run as Admin is no big deal and I, or more likely someone else, might have an inspiration as to the problem.

 

Thanks for the help.

Cheers


On a previous post on the same subject (which somehow I managed to lose ) I mentioned that I was able to "fix" the problem using FSXRegistryFix, but again only for the current session.

(I could find the path to FSX in HKEY_CURRENT_USER (via Software\Microsoft\Microsoft Games ), but not in ....LOCAL_MACHINE, even though FSX RegistryFix said it was there; after I put the path into LOCAL_MACHINE it worked, but only for that session ).

Cheers

David

Share this post


Link to post
Share on other sites

What Ryan means is right the FSX shortcut, select Properties and then click on the Security tab then start messing about with the security permissions. For example, check the write permission is set to Allow. Have a look at the attached screenshot (yes my computer is called Sparkles, anyone have a problem with that?)

 

It's peculiar that it only works for just that session though. I'd be worried that it points to a deeper problem (although what that is is beyond my knowledge).

 

In addition to Anthony's post.  In the same popup, look at the "Compatibility" tab - and at the bottom check the box 'run this program as an administrator'

Share this post


Link to post
Share on other sites

Do not mess with the permissions.

Change the properties permanently like this

 

Admin-1_zps85201fd8.jpg

 

Admin-2_zpsb0ffcc5a.jpg

 

 

Then OK and OK and the change is set.

 

Regards,

Nick.

Share this post


Link to post
Share on other sites

Sorry to take another view on this but rather than run programs as Admin, it is better to set the file permissions on the progfiles\FSX directory. In Explorer Right click on the folder and choose properties, security, edit permissions, choose the "Users" group, and check "Write" and "Modify", Apply, allow to update subfolders. After that any other addon needing permission gets it without using run as admin.

 

When FSX is installed in a new folder created by the user the folder and the file permissions are already set since they inherit the permissions of the users group, and so already have Write and Modify checked.

 

regards

steve

Share this post


Link to post
Share on other sites

..oh yeah, I forgot to add that some programs (not many) might read/write a secure part of the registry and there's no answer to them other than "always Run as Admin". Of course, setting the proper folder permissions may not help with this particular problem, but can't hurt applying the proper permissions anyway. All the best.

Share this post


Link to post
Share on other sites

In fsx.exe, Properties-> Compatibility, in the Privileges Level box, I clicked on  "Run this program as an administrator " which seems to have fixed the problem.

However, for possible future reference (!) it is not (to me ) obvious how to use Permissions-> Security: the Permissions (Full Control, Modify, Read & execute etc) sometimes come up in boxes, sometimes shaded boxes and some time no boxes at all (with some checks grey, some black ) and all different from what comes up initially (which is usually black checks inside white boxes with black borders ) and whatever I do, "Apply" in bottom RHC is always grey and won't do anything.

The General box has in Attributes Read only !

 

Thanks for all your help

David

Share this post


Link to post
Share on other sites

Steve: That is wonderful - a complete tutorial; thank you very much.

 

I haven't been through it yet, but will a bit later.

Thanks again

David

Share this post


Link to post
Share on other sites

You'll be fine David. If it doesn't help your particular issue, at least any addons you subsequently get that write their settings files to an FSX subfolder will have no trouble in future, since the permissions will be the same as if you did a root folder installation like the pro's. All the best.

 

Note: When the Modify box is checked, the Write box is automatically checked as Write is required to modify.

Share this post


Link to post
Share on other sites