Jump to content

Archived

This topic is now archived and is closed to further replies.

MDF86

Major FPS Issues

Recommended Posts

Hi Guys

 

I've recently done a total reinstall of FSX owing to a hardware change and have just about got everything set up how I think it should be.

 

I've just done my first flight - UK2000 EGGD to Aerosoft LFPO and was amazed at how bad my FPS was once I got to LFPO. I got around 8-11 FPS from about 10 miles out of the airport which wasn't enough for a smooth approach. Bear in mind this was with ZERO AI traffic (yet to install UT2) and only a light sprinkling of cloud. I can only imagine how bad it would be if I had a lot of traffic and a thunderstorm!

 

I don't have the latest super hardware but I would have thought my hardware would be more than sufficient to at least get kind of 15-18 FPS which I consider acceptable. Single figure FPS is not fun!!

 

It makes me wonder whether I'm missing something in my set up. I have tried to tweak as sparingly as possible for now as I used to get into the habit of chucking a load of tweaks into my fsx.cfg looking for the perfect set up, and this time I'm taking it slow!

 

My tweaks so far are

 

- Running in DX10 mode with the fixer (4X AA)

- HIGMEMFIX=1

- TEXTURE_MAX_LOAD=2048

- Frames limited to 30 inside FSX

- LOD RADIUS = 5.5

 

Anything look wildly out?

Share this post


Link to post
Share on other sites

OK just did another flight, this time into Aerosoft PANC and again, struggling to get over about 12 FPS on finals, this can't be normal surely?

Share this post


Link to post
Share on other sites

Try putting your texture max load to 1024, lod radius to 4.5, and run unlocked FPS rather than locked at 30. The popular locking fps at 30 doesn't always work well on all systems and flying situations. Even NickN in his guide says that when flying complex aircraft into FPS hungry airports you may need to run unlocked. Personally whenever I fly PMDG birds into big airports I always run unlocked FPS and usually get 25 FPS or more and fluid.


Avsim Board of Directors | Avsim Forums Moderator

Share this post


Link to post
Share on other sites

I think you are asking too much form your computer.

 

I'm guessing you are using high res rex clouds?

 

What airplane is this happening in?

 

If its a pmdg, or even another one, you are still experiencing expected performance imo.

 

I would start with lowering your max texture to 1024 and your LOD to 4.5 and see how that works out for you.

 

Also, I would highly recommend to set frames to unlimited within FSX and then to 32 in Nvidia inspector. 

 

When that is done, set up Vsync in inspector to 1/2 refresh rate. 

 

You also need to set an affinity mask:

 

I think your chip has no hyper threat, but just confirm in the bios that it is off.

 

Then add in you fsx.cfg: 

 

[JOBSCHEDULER]
AffinityMask=14

Share this post


Link to post
Share on other sites

And turn off road traffic to further lighten the load..


Bert

Share this post


Link to post
Share on other sites

Thanks all, I have set TML to 1024 and LOD_RADIUS to 4.5 and also unlocked frame rate, and have found that to be a big improvement. I just re-did the PANC approach and got 18-20FPS instead of the 10-12 before, so that's a big improvement.

 

I guess I will have to accept that I need to dial things down a little! I will miss the hi-res clouds though!

Share this post


Link to post
Share on other sites

Try this with that cpu

 

   [JOBSCHEDULER]
   AffinityMask=242

Rich Sennett

               

Share this post


Link to post
Share on other sites

 

Try this with that cpu

 

   [JOBSCHEDULER]
   AffinityMask=242

 

That only works if Hyperthreading is enabled - which is not recommended for FSX.


Bert

Share this post


Link to post
Share on other sites

Bert He has not mentioned he has it on or not but good point


Rich Sennett

               

Share this post


Link to post
Share on other sites

 

 


Bert He has not mentioned he has it on or not but good point

 

Doesn't matter.

 

The 3570(K) doesn't have HT to begin with.

 

You have to be careful when telling others about this tweak, because most people just copy whatever someone tells them to do in a guide or a forum, without knowing what it does. 

 

You would have more than halved his CPU usage.

Share this post


Link to post
Share on other sites

"The 3570(K) doesn't have HT to begin with"

 

Learn something new every day


Rich Sennett

               

Share this post


Link to post
Share on other sites

×
×
  • Create New...