Sign in to follow this  
jamesman8

777 Doesnt work with DX9?

Recommended Posts

The ONLY Way I can get the 777 to run is if I run it in DX10 preview mode. BUT THAN, the problem is scenery, other payware addons, don't work. So I know its a problem only with the Triple Seven.

 

Also whenever I run it in DX10 mode, I always crash after about 10 minutes, so I can never fly the plane on real flights.

 

Here is what the triple seven looks like in DX9:

 

hv28D3l.jpg

 

 

Here's what it looks like in DX10.

GjjZ0CH.jpg

THE REASON I WANT IT TO WORK IN DX9 IS SO EVERY OTHER AIRCRAFT WORKS.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It works just fine in DX9 mode!

 

I suggest you read the manual.

I did in fact read the manual. It does not work in DX9 mode, AS I am showing you. I added highmefix=1 to the cfg and NO ONE, has had this problem. I've tried almost every solution and cannot find one.

Share this post


Link to post
Share on other sites

Your machine is the problem, not DX9.  How about posting your specs and FSX.cfg?

Share this post


Link to post
Share on other sites

Your machine is the problem, not DX9.  How about posting your specs and FSX.cfg?

 

[LANGUAGE]

DLL=C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\language.dll
[GRAPHICS]
HIGHMEMFIX=1
SHADER_CACHE_PRIMED_10=1693500672
SHADER_CACHE_PRIMED=1693500672
TEXTURE_MAX_LOAD=1024
MultiSamplesPerPixel=8
MultiSampleQuality=8
ForceFullScreenVSync=1
NUM_LIGHTS=8
AIRCRAFT_SHADOWS=1
AIRCRAFT_REFLECTIONS=1
COCKPIT_HIGH_LOD=1
LANDING_LIGHTS=1
AC_SELF_SHADOW=0
EFFECTS_QUALITY=1
GROUND_SHADOWS=0
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
D3D10=0
[sOUND]
AmbientUIMusicVolume=-6.000000
PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=0
SOUND_QUALITY=2
SOUND_LOD=0
UISound=1
AmbientUI=0
[Display]
ChangeTime=4.000000
TransitionTime=4.000000
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
BLOOM_EFFECTS=0
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=80
TextureMaxLoad=12
UPPER_FRAMERATE_LIMIT=90
WideViewAspect=False
[Main]
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
ProcSpeed=13746
PerfBucket=7
HideMenuNormal=0
HideMenuFullscreen=1
Maximized=2
Location=444,133,1476,904,\\.\DISPLAY1
SimObjectPaths.6=aircraft
[PANELS]
IMAGE_QUALITY=1
QUICKTIPS=1
PANEL_OPACITY=100
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
DEFAULT_VIEW=0
[Weather]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherServerAddress=fs2k.zone.com
WeatherServerPort=80
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=0
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=3
DETAILED_CLOUDS=1
CLOUD_COVERAGE_DENSITY=5
THERMAL_VISUALS=0
[DISPLAY.Device.NVIDIA GeForce GTX 650.0]
Mode=1280x768x32
[AccelerationPack]
ControlsFirstRun=0
HomePageFirstRun=0
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
[slewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[slewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
[Trusted]
Removed for Privacy*

 

 

SHOW_WEATHERSYSTEMS=1
SHOW_DATATAGS=1
SHOW_TERRAIN=1
show_flight_history=1
[RWW_WEATHER_MAP]
SHOW_AIRPORTS=0
SHOW_VORS=0
SHOW_NDBS=0
SHOW_APPROACHES=0
SHOW_INTERSECTIONS=0
SHOW_VICTOR=0
SHOW_JET=0
SHOW_AIRSPACE=0
SHOW_FLIGHTPLAN=1
SHOW_WEATHERSTATIONS=1
SHOW_WEATHERSYSTEMS=1
SHOW_DATATAGS=1
SHOW_TERRAIN=1
[DISPLAY.Device.NVIDIA GeForce GTX 650.0.0]
Mode=1280x720x32
TriLinear=1
AntiAlias=1
[MULTIPLAYER]
HostPortFirst=6112
HostPortLast=6122
ConnectionLostTimeOut=50.000000
AccountLogin=0
condAccoutPassword=0
AccoutPassword="(null)"
LanUsername="James"
ReservedForFriends=2
AllowChangeRealism=0
AllowPauseLocalSim=1
EnableShare=0
PasswordForSharingAircraft="1234"
WeatherString="Weather Theme: Fair Weather"
IP1=23
IP2=255
IP3=207
IP4=47
 

 

 

Specs,

Just before you say: Oh Windows 8.1 is the problem! I have used other PMDG products with no issues before. This is the only plane giving me a problem.

uvRh4YA.jpg

GTX 650, ASRock Motherboard, no idea which one.

Share this post


Link to post
Share on other sites

Not wanting to sound offensive here, but as you said: no one has brought this problem up before. As such, I highly suspect it's something to do with some kind of setting on your machine.

If, after this long, nobody has reported a certain "bug", "issue" or "problem", chances are very high that it's something that's off on your configuration, not PMDG's fault.

Plenty of people run the 777 in DX9, probably a LOT more than DX10.

Share this post


Link to post
Share on other sites

Not wanting to sound offensive here, but as you said: no one has brought this problem up before. As such, I highly suspect it's something to do with some kind of setting on your machine.

If, after this long, nobody has reported a certain "bug", "issue" or "problem", chances are very high that it's something that's off on your configuration, not PMDG's fault.

Plenty of people run the 777 in DX9, probably a LOT more than DX10.

I understand what your saying. I WANT To run it in DX9, I currently am, but DX9 is showing a skeleton plane, while DX10 is not, but DX10 doesnt allow any-other aircraft and causes crashes for FSX and scenery doesnt work e.t.c

Share this post


Link to post
Share on other sites

So much wrong in that cfg, I'm only going to name a few things. You have shot yourself in the foot using Win8, as far as i know PMDG wont touch it.

 

Anyway, never install FSX under the x86 folder unless you know what you are doing.  It's just not worth the hassle.

 

Switch off AA in the sim, you have a low end GPU and are killing it. follow Ryan's advise regarding NVIDIA inspector.

 

Check your background services, the 777 is pretty demanding. It's likely it is showing up how poorly optimized the machine is.

Share this post


Link to post
Share on other sites

So much wrong in that cfg, I'm only going to name a few things. You have shot yourself in the foot using Win8, as far as i know PMDG wont touch it.

 

Anyway, never install FSX under the x86 folder unless you know what you are doing.  It's just not worth the hassle.

 

Switch off AA in the sim, you have a low end GPU and are killing it. follow Ryan's advise regarding NVIDIA inspector.

 

Check your background services, the 777 is pretty demanding. It's likely it is showing up how poorly optimized the machine is.

As far as my brother is concerned(Majoring in computer science), he says my specs are pretty dang good and should easily be able to run any aircraft. I disabled AA, and that did nothing, still skeleton. My brother installed my FSX for me, so I honestly have no idea what he did to install it.

Share this post


Link to post
Share on other sites

Display.device entry is showing twice in your text above and maybe more flaws.

 

Backup your FSX.cfg and start FSX, wait for it to load and close FSX.

 

Start with a fresh one and add Highmemfix=1 and whatever else is stated in the manual and report back.

Share this post


Link to post
Share on other sites

Display.device entry is showing twice in your text above and maybe more flaws.

 

Backup your FSX.cfg and start FSX, wait for it to load and close FSX.

 

Start with a fresh one and add Highmemfix=1 and whatever else is stated in the manual and report back.

Ok Ill try that.

 

High me fix did nothing, still a skeleton.

Share this post


Link to post
Share on other sites

If you're seeing a skeleton like that at all times (and not just when memory usage is high) then you have much bigger problems and HIGHMEMFIX isn't going to solve them. I would recommend reinstalling FSX from scratch following our guide here:

 

http://support.precisionmanuals.com/kb/a87/how-to-uninstall-and-reinstall-fsx

 

I would also make 100% certain all of your hardware drivers are up to date - GPU, motherboard chipset, sound etc.

 

As others have stated, you're essentially "at your own risk" by using Windows 8/8.1 - we do not officially support it and that's very clearly stated on the purchase page for the airplane. You could not have purchased without seeing that text indicating this.

Share this post


Link to post
Share on other sites

So much wrong in that cfg, I'm only going to name a few things. You have shot yourself in the foot using Win8, as far as i know PMDG wont touch it.

 

Anyway, never install FSX under the x86 folder unless you know what you are doing.  It's just not worth the hassle.

 

Switch off AA in the sim, you have a low end GPU and are killing it. follow Ryan's advise regarding NVIDIA inspector.

 

Check your background services, the 777 is pretty demanding. It's likely it is showing up how poorly optimized the machine is.

Rob, I think "shot in the foot" is a bit harsh - while not supported, I think this is more a config issue than a Windows issue, although putting it in (x86) could have something to do with it. Many people including me use 8.1 AND DX10 with no issues - BUT it does require tinkering and precise cfg settings. Also, many general consumers who don't know about IT buy a new PC and are never given a choice of Win 7.

 

That .cfg file is not properly optimized.

Share this post


Link to post
Share on other sites

No problems with win8.1 so far in DX9 or DX10 mode. It shouldn't be any problem either as the kernel has just some minor updates and most errors are user produced or results from misconfigured windows.

Share this post


Link to post
Share on other sites

If you're seeing a skeleton like that at all times (and not just when memory usage is high) then you have much bigger problems and HIGHMEMFIX isn't going to solve them. I would recommend reinstalling FSX from scratch following our guide here:

 

http://support.precisionmanuals.com/kb/a87/how-to-uninstall-and-reinstall-fsx

 

I would also make 100% certain all of your hardware drivers are up to date - GPU, motherboard chipset, sound etc.

 

As others have stated, you're essentially "at your own risk" by using Windows 8/8.1 - we do not officially support it and that's very clearly stated on the purchase page for the airplane. You could not have purchased without seeing that text indicating this.

I did see that it says it may not work in 8.1, but my other friends who have 8.1 are having no issues. I got a new FSX CFG, running FSX In Compatability mode, and this only happens in DX9, not DX10. I want to run in DX9 Though.

Share this post


Link to post
Share on other sites

unning FSX In Compatability mode,

Do NOT run FSX in  Comparability mode. I don't have a computer science degree, but I can tell you, never run in that mode.

I would suggest following Ryan's advice and re install FSX, you need to start again, from scratch.

 

All you doing is going around a continuous loop going nowhere.

Share this post


Link to post
Share on other sites

Do NOT run FSX in  Comparability mode. I don't have a computer science degree, but I can tell you, never run in that mode.

I would suggest following Ryan's advice and re install FSX, you need to start again, from scratch.

 

All you doing is going around a continuous loop going nowhere.

The only change to the run options of FSX I use is RUN AS ADMINISTRATOR. Not compatibility mode...

 

Also, make sure user account control is OFF.

Share this post


Link to post
Share on other sites

 

 


The only change to the run options of FSX I use is RUN AS ADMINISTRATOR

Yes Wes, that is all that is needed.

Share this post


Link to post
Share on other sites

Yes Wes, that is all that is needed.

To clarify, that's all that's needed on the FSX.exe run options - there is still a lot of fsx.cfg tweaking to do however.

 

With my new build, I carried over my fsx.cfg and dll.xml, the only change was to delete the audio part of fsx.cfg so it would recognise my new sound chip. Everything else left the same.

Share this post


Link to post
Share on other sites

As far as my brother is concerned(Majoring in computer science), he says my specs are pretty dang good and should easily be able to run any aircraft. I disabled AA, and that did nothing, still skeleton. My brother installed my FSX for me, so I honestly have no idea what he did to install it.

FSX has a way humbling even the highest ranking computer "experts"

 

My advise is forget what your brother told and pay attention to whats being explained to you here. Re installing FSX using the guide provided by Tabs. This an un checking compatibility mode would be a great start 

Share this post


Link to post
Share on other sites

Wait you don't have to uninstall!

 

This looks like a problem with the shaders.

 

Did you try out the shader 3 mod at one time?

 

I'd recommend uninstalling the shader 3 mod so it puts back the default shader folders. Then fsx should work fine with dx9

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this