Sign in to follow this  
STUART_H

DX10 Preview check box disappeared... help?

Recommended Posts

I had tried DX10 Preview in the past and decided to give it another try with the Shader fixes from Steve on Avsim. However, the DX10 check box in FSX is no longer present.

After reading some similar posts here on Avsim, re needing FSX SP2/Acceleration.

 

I decided to do a repair on both FSX and Acceleration. However this hasn't resolved the issue.

I edited FSX.cfg to include the line D3D10=1.

I then downloaded the latest DirectX from Microsoft.

I checked dxdiag programme and it says there are no problems and I am running latest DX11 version.

But when starting FSX there is still no DX10 check box!

 

Does anyone know why I have lost this option and how to restore it?

 

BTW, My graphics card is I believe DX10 compatible - its an XFX GForce GTX260 2mb card.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What OS are you running?

 

Win 7 should give you the option, Win XP: not..

Share this post


Link to post

Sorry, I should have said.

I am running Windows 7 64bit home edition.

 

Stuart

Share this post


Link to post

D3D10=1  change to D3D10=0 and see if it appears.

Share this post


Link to post

I can't try it again until Thursday, but I thought that the D3D10= setting in the cfg simply indicated whether the check box was set or not. Since I don't even see the check box not sure that would help.

 

I remember sometime back trying SweetFX, and reading various forums there may have been issue where SweetFX corrupted something. I no longer have it installed, but wonder if that could be the cause. Just not sure how to resolve.

Share this post


Link to post

This happens frequently for some reason. Simply reinstall Acceleration or SP2, as appropriate (no need to repair as a repair will change all of your fsx settings). Nothing will change in your fsx.cfg, dll.xml, or other settings but it will fix this problem. Make sure you right click the install program and run as administrator.

 

Your video card is DX10 compliant.

 

Best regards,

Share this post


Link to post

Jim, thanks for that. I had already run a 'Repair' of Acceleration, but it didn't help. Should I uninstall Acceleration and do a complete reinstall?

 

Cheers,

Stuart

Share this post


Link to post

Thanks Guenseli,

I'll see if I can find that file and remove it, and see what happens before uninstalling Acceleration.

Cheers,

 

Stuart

Share this post


Link to post

Jim, thanks for that. I had already run a 'Repair' of Acceleration, but it didn't help. Should I uninstall Acceleration and do a complete reinstall?

 

Cheers,

Stuart

When it happened to me a couple of weeks ago, I simply reinstalled Acceleration and the problem was fixed. Acceleration and SP2 are the products that bring you DX10 Preview. You can try uninstalling Acceleration (go to the Add/Remove Programs and uninstall Acceleration). It will not uninstall FSX or FSX SP1 when you do this. Then reinstall Acceleration. Make sure you run as Administrator.

 

Best regards,

Share this post


Link to post

Just to let everyone know my resolution seemed to be to delete the shortcut to a file dxgi.dll.

However, after finding my DX10 Checkbox was back and FSX operating, I then proceeds to follow instructions in the "DX10 How to..." document. But now when I fire up FSX all the menu text has disappeared to be replaced with blanks or random lines.

 

Anybody else seen this and know how to resolve?

 

Stuart

Share this post


Link to post

This is only the beginning... if you want to have a "normal life" stay with DX9... that is the way FSX was written - and it works well.

 

If you want to go down the DX10 road, buy some supplies for late night tuning and debugging sessions, you are going to need them ^_^

Share this post


Link to post

Most likely a corruption in the dll.xml.

 

Best regards,

Share this post


Link to post

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "DX-10 Discussions, Hints and Help". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this