Sign in to follow this  
CordoganAir

Disappearing Taxiways!

Recommended Posts

I never noticed this in FSX but I've noticed this at several stock airports in P3D 2.4 that the taxiways disappear into the ground mesh. They don't flicker or reappear any advice on how to fix this? Thanks.

 

2014-11-17_7-21-7-52.jpg

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

(Edit: The picture didn't load the first time I saw the thread, so my initial recommendation might not have been applicable)

 

I've seen this issue when taxiways of different materials intersect in both FSX and P3D... the "main" taxiway appears to be asphalt or concrete, and the spurs in this case might be dirt or grass. The FSX/P3D rendering engine tries to make it a smooth transition, but doesn't realize the mess it is making by rounding out the intersection with the hard surface.

 

What airport is it?

 

-Greg

Share this post


Link to post

Seems to be a common P3D problem and would also love a solution!

Share this post


Link to post

Ok people here is the solution. I was cursed with this for I don't know how long. First you need ADE 165 (the latest I think). You will also need the p3d sdk which is available on the LM site. Install it. There are  paths in the ADE editor for program's that are in the SDK directory. They must be set in the ADE. One is a compiler and not sure of the other but it will be in the ADE. Once you have that set open the ADE editor and open the stock airport your having trouble with missing taxiways. It will appear in ADE. In the ADE near the upper right top you will see a button that says " compile " Hit that button and you will see a pop up that say's airport compiled. Now before leaving the ADE (important) make sure you save the airport. That's it. Very simple once things are set up. This has worked for me for every airport I have found that has missing taxiways. As someone mentioned is there a batch file to do all airports  NO at least I haven't seen one. You have to do every airport individually or more simply just the ones you fly into. This is a solution, maybe not the best but it sure works. Have fun

 

Cheers

 

Nelson


Oh yea, Toronto Pearson in Canada was really bad. This fixed it real quick :lol:

 

Nels

Share this post


Link to post

This is what I feared having to go into each affected airport individually with ADE...yeeesh

Share this post


Link to post

If your looking for a quick fix there isn't any, sorry. As I find them I fix them

 

Nelson

Share this post


Link to post

Somebody want to go through all 25000 airports and check them for us? Be greatly appreciated. :) Hopefully "they" find a comprehensive answer for this.

Share this post


Link to post

Somebody want to go through all 25000 airports and check them for us? Be greatly appreciated. :) Hopefully "they" find a comprehensive answer for this.

Wford I saw your name at the top of the signup sheet for p3d airport repairs. See you in a few years lol

Share this post


Link to post

I mean really! Do you fly to all 25000 airports?? Not likely. Fix the ones you use and get on with it. This is obviously an LM problem that they seem in no hurry to fix. All I did was give you a solution. Use it or loose it, simple as that

 

Cheers

 

Nelson

Share this post


Link to post

Shot in the dark, but are you by any chance using MyTraffic 5.4?  If so, the disappearing taxiways are a known issue and this is the fix until a fully P3D v2-compatible version is released.

 

If not, apologies for the interruption and I'm sure you're already in good hands.

Share this post


Link to post

I mean really! Do you fly to all 25000 airports?? Not likely. Fix the ones you use and get on with it. This is obviously an LM problem that they seem in no hurry to fix. All I did was give you a solution. Use it or loose it, simple as that

 

Cheers

 

Nelson

We were joking and thanks for your solution

Share this post


Link to post

Thanks Paul. ref the above I am using My Traffic 5.4. I didn't know this was an issue. Thanks  Alan, will read the link. Any one else???

 

Nelson

Share this post


Link to post

I mean really! Do you fly to all 25000 airports?? Not likely. Fix the ones you use and get on with it. This is obviously an LM problem that they seem in no hurry to fix. All I did was give you a solution. Use it or loose it, simple as that

 

Cheers

 

Nelson

kind of difficult to determine which ones I will use or have used but is many more than I have time to stop and fix. A comprehensive repair would be much more logical. Not really a big deal just a little annoying.

Share this post


Link to post

Considering that it is a previously ignored flag in the airport facilities database that is now required, it's a bit unreasonable to expect anyone, much less L-M to open and fix those airports that are affected.

Share this post


Link to post

The fix is there. You either use it or not. You want taxiways fix the airport. Takes 10 sec and two mouse clicks. Sounds very reasonable to me and you only do it once

No one is going to do it  but you!!

 

Nelson

Share this post


Link to post

Have used this fix to fix several airports.  However, I still have airports where the taxiway surfaces are not showing, yet, when I look at the airport in ADE the taxi links are set to "true".

 

KAST is one of theses airports.  I don't have MyTraffic or anyother program installed that adds ADEs.

 

Any other ideas?????

 

Thanks

 

Danny

Share this post


Link to post

Well, I finally fixed the invisible taxiways.  If the taxiway flags were set to "true" there had to be another bgl conflicting with the scenery.  And, there was.  It seems all of the bgls in the Lands End freeware have the taxiway flags set to false.  Once I changed them to "true" and placed them in the Addon/Scenery folder everything worked as it should.

 

Just thought I would let everyone know the solution.

 

Regards,

Share this post


Link to post

Ok people here is the solution. I was cursed with this for I don't know how long. First you need ADE 165 (the latest I think). You will also need the p3d sdk which is available on the LM site. Install it. There are  paths in the ADE editor for program's that are in the SDK directory. They must be set in the ADE. One is a compiler and not sure of the other but it will be in the ADE. Once you have that set open the ADE editor and open the stock airport your having trouble with missing taxiways. It will appear in ADE. In the ADE near the upper right top you will see a button that says " compile " Hit that button and you will see a pop up that say's airport compiled. Now before leaving the ADE (important) make sure you save the airport. That's it. Very simple once things are set up. This has worked for me for every airport I have found that has missing taxiways. As someone mentioned is there a batch file to do all airports  NO at least I haven't seen one. You have to do every airport individually or more simply just the ones you fly into. This is a solution, maybe not the best but it sure works. Have fun

 

Cheers

 

Nelson

Oh yea, Toronto Pearson in Canada was really bad. This fixed it real quick :lol:

 

Nels

Apparently, this issue is due to the program that compiled the airport originally.  Any older airport could potentially suffer from this condition.  My hope is that most airports will be upgraded eventually.  Original freeware authors, please, please give your blessings and help with the cause.  The more people that are included, and allowed to enjoy your work, the more our community will prosper.  I fully expect most scenery developers want to show off their work, let's keep rolling it forward as long as we can.  If it only takes a minor tweak like a recompile, to make some work in the next-gen sim then lets do it!  

 

Gentlemen of MAIW,  Your collective work is amazing!  It doesn't have to die.  It can keep living, a whole new generation can enjoy it, build and add to it.  FS2004 is 11 years old now.  It's successor FSX is 9 years old.  FSX' successor, is now working on a version 3.  Your beautiful creations, will work with some minor updates.  Please please think about your current policy, and re analyze if it still makes sense.  I dream of the day, I go to the MAIW site, and see an FSX or P3d download button next to a desired scenery.  Sincerely, -Woog   

Share this post


Link to post

One of the problems that may be encountered during the recompile process is that some areas designated as aprons may display in a different texture ie concrete instead of grass.

If this is the case use ADE to list the aprons and then edit those that are incorrect as in the way described for taxiways. When you double click to edit an apron it will highlight the apron area being edited which makes it handy for ensuring it is the correct apron.

Share this post


Link to post

I found an even simpler solution:  make sure that your ADE taxiway and other drawn surfaces properties are set to: "Draw Surface", because the default is that box is unchecked and P3D doesn't know the difference and only supplies the underlying surface.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this