Sign in to follow this  
RanDeMan

Pauses gone! (Is it just me?)

Recommended Posts

Hi gents,

 

From day 1 and even after SP1 (and updates) I'd been suffering the same dreaded pauses (sim freezes from 5 up to 10 mins., after which it continues from where the pause started, but with fuel burned) some other people reported.

 

On longer flights (longer than 6 hrs.) they would vary from 3 up to 5 pauses per flight. It never was a real show-stopper for me and sure didn't keep me from enjoying this magnificent bird, but it was annoying.

 

Now the strange thing is that since the last number of flights the pauses seem to be entirely gone! Strange because I didn't make any big changes to my system or FSX at all. The only thing I could think of that has changed was ASN, which I updated to SP1B (Build 5410).

 

No complaints, of course. Just checking if there are other users with similar experiences. If it's not ASN then it has to be a another great mystery in the world of FSX.

 

A nice weekend to you all and may all your pauses be gone!

 

Cheers.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yes, the dreaded "appHang."  Mine would typically last 8 - 10 min and I started watching the CPU activity in each of my 4 cores. During normal operation all four cores would be busy (90-100%) but during appHang they were very quiet.. activity less than 30%.  I played with this problem seriousely for several months and finally convinced myself that it was a VISTA problem.  Since then I have done a rebuild and installed Win 7 and I have not had an appHang in a month of daily heavy use.  Do you have VISTA?

Share this post


Link to post
Share on other sites

I chased it to the last ASN update. When I dropped back to the next previous update all the stutters and lags went away. I haven't reloaded the SP1b yet, I'm waiting for ASN to check things out. ASN flags the older update but I just ignore their update suggestion at loading.

Share this post


Link to post
Share on other sites

I've been running ASN B5410 for a couple of weeks with no problem. One of the things Ryan had me check when I was troubleshooting the problem was DPC Latency.  There is a free and safe tester here: http://www.thesycon.de/deu/latency_check.shtml

 

In my case I did not have a significant problem with DPC Latency but replacing my board-mounted sound card with a Soundblaster improved the numbers. In fact, almost anything in your system can be causing these delays and the test can help you track it down.

Share this post


Link to post
Share on other sites

My freezing is back, I don't know what to do. Had no problems on 2 legs yesterday for 12 hours, now today can't get farther than 3 hours. Latest version of ASN, no other airplane does this.

 

My onboard sound is disabled I have a Sound blaster pci-express.

 

I thought it was my overclock so I'm back to stock speeds on Windows 7 64-bit

 

Last ditch effort is I removed the affinity mask setting. Starting a flight now for 2 hours hope it doesn't freeze

Share this post


Link to post
Share on other sites

I never really had huge problems with min long freezes.

 

In my opinion the more stuff you ask FSX to do the more freezes you get.

Anything you can do to reduce the load on core 0 will help (just my opinion/experience).

- reduce Autogen settings

- reduce that slider above Autogen....eeeeh texture complexity?..a notch

- reduce UTX (or ORBX) settings (that freed huge amounts of VAS for me as well).

- reduce AI traffic settings

- move FSX addons away from CPU core 0

- no 4096 textures (there are also claims that setting 4096 in the FSX.cfg WITHOUT actually having 4096 textures installed helps prevent OOMs)

- etc

 

But the other day I had a 10-20sec freeze during a 10min test flight (testing some OPUS FSX weather settings).

 

Maybe because I have recently installed FSGenesis world wide mesh?

I have reduced the sliders from very dense to dense....will see what happens.

 

I never tried ASN and have allways been on Win7.

My freezing is back, I don't know what to do. Had no problems on 2 legs yesterday for 12 hours, now today can't get farther than 3 hours. Latest version of ASN, no other airplane does this.

 

My onboard sound is disabled I have a Sound blaster pci-express.

 

I thought it was my overclock so I'm back to stock speeds on Windows 7 64-bit

 

Last ditch effort is I removed the affinity mask setting. Starting a flight now for 2 hours hope it doesn't freeze

Affinity will rob FSX from a core......core 0.

 

So according to my theory (above) trying to make FSX work with only three cores (core 1,2,3) instead of four cores (core 0,1,2,3) would increase the change of freezes.

 

Definately try without that.....in fact, try with a clean FSX.cfg if you can with minimal/no tweaks other than Highmemfix (if needed to prevent skeleton airports or aircraft) and Wideviewaspect.

Share this post


Link to post
Share on other sites

Thanks for your elaborate reply, Rob.

 

The thing in my case is that I didn't ask FSX to do anything more (or less) to have the pauses totally disappear on me like that.

 

Again, not complaining. Just baffled by these kind of enigma's.

 

Cheers.

Share this post


Link to post
Share on other sites

The short freezes, less than a minute, are a different problem from the 8-10 min pauses in my opinion. The long pause, or appHang, has nothing to do with the amount of 'work' you are asking FSX to do for you.  For example, the short freeze or stutter is not accompanied by sudden lower CPU loading but the appHang is and CPU loading can decrease to almost nil. If you end the FSX.exe task during a freeze it will exit normally. If you end the FSX.exe task during the long pause you will get a Windows error message with the event name 'appHang.'

Share this post


Link to post
Share on other sites

Ok yes, that is possible that they are different things.

 

I never had minute long freezes (knock on wood) so I cant compare.

Share this post


Link to post
Share on other sites

I used to have 5 minute freezes and solved them a long time ago by using an AffinityMask that would leave my core0 always free for the OS. I never believed AffinityMask would do anything to my sim until i tried it and solved the issue for me.

 

Might be worth a shot for some of you, i made quite a few tests (10+ hour flights) to make sure this was solved but your mileage might differ.

Share this post


Link to post
Share on other sites

The Introduction recommends the AffinityMask solution for the appHangs (pg 0.00.35) and it works for many.  Didn't work for me using Vista, which is one of the reasons I became convinced that it was a Vista problem.  Problem gone with Win7, and yes, I am using AffinityMask for 4 cores/8 threads.

Share this post


Link to post
Share on other sites

I just remembered that pmdg support told me to try affinity  mask 14, even though I have a 6 core processor. I will put that in and see if the freezing stops.

 I don't know why it worked compared to affinity mask setting based on my number of cores.

Share this post


Link to post
Share on other sites

 

 


I am using AffinityMask for 4 cores/8 threads.

I also have WIN7 64 with i7 4core (HT on).

Here are the most important settings for OOM/CTD and stutter free FSX ("solid as a rock"-) OPS on my "little PC":

[JOBSCHEDULER]
AffinityMask=244

[bufferPools]
UsePools=0

[GRAPHICS]
HIGHMEMFIX=1

[Main]
FIBER_FRAME_TIME_FRACTION=0.15

[Display]

TEXTURE_BANDWIDTH_MULT=15

UPPER_FRAMERATE_LIMIT=0

 

I use the Nvidia Inspector for external FSX framelock via the vsyncinterval 1/3 setting. This delivers fluent framerates (with most FSX sliders between 66% and 75%) at 20 FPS.

I did not make any changes to my fsx.cfg for the last 7 days; I am simply enjoying the T7F on a world tour. Leg of the day: WSSS (Singapore) to WADD (Bali). B) 

Share this post


Link to post
Share on other sites

I also have WIN7 64 with i7 4core (HT on).

Here are the most important settings for OOM/CTD and stutter free FSX ("solid as a rock"-) OPS on my "little PC":

[JOBSCHEDULER]

AffinityMask=244

[bufferPools]

UsePools=0

[GRAPHICS]

HIGHMEMFIX=1

[Main]

FIBER_FRAME_TIME_FRACTION=0.15

[Display]

TEXTURE_BANDWIDTH_MULT=15

UPPER_FRAMERATE_LIMIT=0

 

I use the Nvidia Inspector for external FSX framelock via the vsyncinterval 1/3 setting. This delivers fluent framerates (with most FSX sliders between 66% and 75%) at 20 FPS.

I did not make any changes to my fsx.cfg for the last 7 days; I am simply enjoying the T7F on a world tour. Leg of the day: WSSS (Singapore) to WADD (Bali). B)

 

Why such a low texture multiplier? 15? Default is 40 and websites say you can make it 80 or 120

I wonder if I should set fsx to unlimited currently it is locked at 30

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this