Jump to content

Sign in to follow this  
Howellerman

Head First Down the Rabbit Hole

Recommended Posts

Borrowing from Rob Ainscough's web page banner, I installed my Christmas gift to myself and went head first down the P3D V2 rabbit hole. Also did a complete face plant when I hit bottom, since the installation was corrupted (still not sure why) and it destroyed my scenery libraries in P3D V1.4!!! 

 

So, I am fully committed to moving forward and have spent the last two days working on perfecting the box-stock simulation using the Mooney Acclaim (I fly pretty much all GA). Using Rob's suggestions (I have an almost high-end system, 4770K @ 4.2 GHz, 8GB Corsair Vengeance, EVGA GTX 780 AC, ASUS 2560x1440 HDMI display, Samsung Extreme Pro 480 SSD) , and the recent FIBER and TEXTURE mods, I have everything working pretty well. Smooth, locked at 30 fps, no jaggies, and no shimmering. I find the "windowed" mode to be a real benefit, as I can seamlessly switch back and forth between P3D and Chrome to compare settings, and I am impressed with the light CPU loads (so far!).

 

The single exception are shadows - they are horrible, and look like 8-bit renderings. Cockpit shadows have constant shimmering even when sitting on the tarmac, and terrain shadows twitch and quiver as well. Seeing the crisp lines in Rob's screenshots it is clear that something is amiss, but since I matched the P3D (dialing some back just a notch in some cases) and Inspector settings, I don't see where I went wrong!

 

If I can get this shadow problem figured out, and can incrementally start building my world. Until then, though, I will be just chasing my tail. Any suggestions for fixing shadows?

Share this post


Link to post

If I can get this shadow problem figured out, and can incrementally start building my world. Until then, though, I will be just chasing my tail. Any suggestions for fixing shadows?

 

John find this line in p3d.cfg and set to 2048 or 4096.

 

GROUND_SHADOW_TEXTURE_SIZE=

 

This should sharpen them up, especially in the VC but might not stop them quivering externally.

 

gb.

Share this post


Link to post

Im also coming back from a break in flightsimming after seeing the flat out gorgeous videos of P3D on youtube. That got me interested. I made P3D my Christmas gift to myself. And Orbx Global. And Orbx Vector. And Orbx PNW. And cant forget Active Sky Next. Now im about to get REX Soft Clouds and thats it! (for this paycheck at least!)

 

After some MILD tinkering (a shadow of what i used to put myself through with FSX) i am getting a solid 33 fps. Thats good enough for me.

 

I honestly cannot believe how smooth this sim runs. It does have its quirks that take some getting used to, but it is truly leaps and bounds above FSX.

Share this post


Link to post

 

 


John find this line in p3d.cfg and set to 2048 or 4096.
 
GROUND_SHADOW_TEXTURE_SIZE=

 

Heya GB. I have to admit when I saw your recommendation I kind of flinched: I have never seen a requirement for higher than 2048 for any texture in FSX/P3D V1.4, let alone a "shadow". Turns out it did not help: I still have 8-bit shadows.

 

I did generate a new *.cfg file, and am in the process or comparing line for line. However, when I substituted the Mooney for the Raptor, same thing: 8-bit shadows. 

 

Thanks for the assist, but I think there is something else, potentially fundamentally wrong, lurking in the configuration somewhere...   :(


Im also coming back from a break in flightsimming after seeing the flat out gorgeous videos of P3D on youtube. That got me interested. I made P3D my Christmas gift to myself. And Orbx Global. And Orbx Vector. And Orbx PNW. And cant forget Active Sky Next. Now im about to get REX Soft Clouds and thats it! (for this paycheck at least!)

 

After some MILD tinkering (a shadow of what i used to put myself through with FSX) i am getting a solid 33 fps. Thats good enough for me.

 

I honestly cannot believe how smooth this sim runs. It does have its quirks that take some getting used to, but it is truly leaps and bounds above FSX.

Heya Ken-Michael-Ken,    :)

 

Yes, I agree: P3D V2 is the "future". I had V1.4 singing along quite well, but even then I realized it was a "done" technology, comparable to FSX with regards to potential future development.

 

Make sure you make (and test) incremental changes. That is why I haven't done a single addon until I get this pesky shadow problem solved. Then I will add Global, Vector, and all the regions that I have (PNW is a favorite).

Share this post


Link to post

one thing that is bugging me is how P3d reindexes the scenery everytime i start the sim. Is there a fix for this? Do others experience this?

Share this post


Link to post

Heya GB. I have to admit when I saw your recommendation I kind of flinched: I have never seen a requirement for higher than 2048 for any texture in FSX/P3D V1.4, let alone a "shadow". Turns out it did not help: I still have 8-bit shadows.

 

Just guessing here...

 

Try

TEXTURE_MAX_LOAD=4096

GROUND_SHADOW_TEXTURE_SIZE=4096

 

There might be something else going on but the value of GROUND_SHADOW_TEXTURE_SIZE= definitely makes an obvious difference on my system.

 

gb.

Share this post


Link to post

How about the shadow quality settings? Did you make sure those matched as well?

Share this post


Link to post

I had similar experience as you trying to upgrade. I gave up, uninstalled everything and did a complete new download of the complete version 2.4 and installed it. VIOLA! Problem solved. For you, as you have not installed any addons yet, it should not take very long and could save you lots of time in the end. Other people have had the same experience and did what I did with complete satisfaction. I don't know why, but there may be something strange going on when trying to upgrade with some computers.

Share this post


Link to post

Just guessing here...

 

Try

TEXTURE_MAX_LOAD=4096

GROUND_SHADOW_TEXTURE_SIZE=4096

 

There might be something else going on but the value of GROUND_SHADOW_TEXTURE_SIZE= definitely makes an obvious difference on my system.

 

gb.

 

 

 

You might want to consider this post when changing the config file ...    http://forum.avsim.net/topic/451959-do-not-use-ground-shadow-texture-size4096/

Share this post


Link to post

I use ORBX and increasing the TML to 4096 I don't believe does anything if the Textures are 1024 and that would be the same with Global as well as the default I believe.

Please let me know if this is incorrect.

 

Bob

Share this post


Link to post

+100 for Stratocruiser1, I have had the same experience here. Originally, I had tried the upgrade from 2.3 to 2.4, and wound up with a jagged, shimmering mess. The clean install worked beautifully, and I will do a clean install again for v2.5.

    As for using 2048 textures for ground shadows, that will just cause you more grief in the form of OOM-city.

 

Happy New Year,

Craig

Share this post


Link to post

one thing that is bugging me is how P3d reindexes the scenery everytime i start the sim. Is there a fix for this? Do others experience this?

 

Are you using SimLauncher? They way it inserts the flight model into the simulator causes a re-index. Oh, wait - I just tried it, and I too get the re-index message. Being on a brand new SSD, though, it is just a flash! Love the new SSD!!!

I had similar experience as you trying to upgrade. I gave up, uninstalled everything and did a complete new download of the complete version 2.4 and installed it. VIOLA! Problem solved. For you, as you have not installed any addons yet, it should not take very long and could save you lots of time in the end. Other people have had the same experience and did what I did with complete satisfaction. I don't know why, but there may be something strange going on when trying to upgrade with some computers.

 

I think I am going to try this, Stratocruiser. Maybe start with the "Repair" option first, and if that does not work, do a complete mind-wipe. I already erased V1.4, so maybe things will be cleaner. Thanks!

Share this post


Link to post

Are you using SimLauncher? They way it inserts the flight model into the simulator causes a re-index. Oh, wait - I just tried it, and I too get the re-index message. Being on a brand new SSD, though, it is just a flash! Love the new SSD!!!

Nope, not using SimLauncher. I too am on a SSD, so the reindex thing is not a huge deal, just a P3d quirk i guess. 

 

Now i need to find a list of the best freeware planes...lol

Share this post


Link to post

The reindexing is a known issue with P3D. No answers for it as yet. I would guess it's not high on the priority list.

 

Vic

Share this post


Link to post

Don't waste your time on the Repair thing. I tried that too. Just bite the bullet and do a complete uninstall and put in the new version. Make sure you use a good search and remove tool to get rid of all the associated files that you don't normally see or use with the product.

Share this post


Link to post

Don't waste your time on the Repair thing. I tried that too. Just bite the bullet and do a complete uninstall and put in the new version. Make sure you use a good search and remove tool to get rid of all the associated files that you don't normally see or use with the product.

 

Oh, so now you tell me!    :P

 

Yup, didn't do a goldarn thing... 

 

Just by coincidence, reading the comics this morning I glanced at my horoscope, first time in a long time. "It is time to move out of the past and embrace the future". Okaaaaay - if the future could fix my shadow problems!!!

 

Will report back after a full re-install. I wonder how many re-installs does Lockheed Martin allow?

Share this post


Link to post

 

 


I wonder how many re-installs does Lockheed Martin allow?

 

  As long as you uninstall P3D using their installer, you should not have any issues. 

 

As for the reindexing of scenery, I only got this after installing Orbx scenery. On a clean install, P3D just loaded up without any delays.

 

  Craig

Share this post


Link to post

Well, still no love from the shadows. After a complete uninstall/reinstall the 8-bit shadows prevail.

 

I am going to just turn them off completely - got by for two years without them with FSX and V1.4 - and start building my "world". This is at least fun!

Share this post


Link to post
Guest

Hi John,

 

Sorry for delay in seeing this, just super busy working on my GoFlight programming/mapping.

 

Here are my shadow settings in prepar3d.CFG:

 

[Graphics]

SHADOW_QUALITY=4
TERRAIN_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_CAST_DISTANCE=6
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=1
CLOUD_SHADOWS_CAST=1
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=1
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=2048
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
 
Not exactly sure why you aren't seeing good quality shadows ... but those two settings above will have a significant impact on shadow quality ... you can use values 256, 512, 1024, 2048, 4096 ... but be warned setting any to 4096 will have a significant performance impact during dusk and/or dawn (any time sun position that creates LONG shadows as it will be very hard on the GPU).
 
Happy new year.
 
Cheers, Rob.

Share this post


Link to post

Here's a few screen shots showing VC shadow quality at 4096/2048/1024/512 values of

GROUND_SHADOW_TEXTURE_SIZE=

Notice how the shadow of some cargo meshing at the rear of the plane disappears at 1024/512.

These were all taken with TEXTURE_MAX_LOAD=1024
so that value seems to have no effect here.


https://www.dropbox.com/s/0jpgkmg75vvlg4k/A2015-1-1_14-24-25-420-4096.jpg?dl=0

https://www.dropbox.com/s/hyrk3wnst5o57v1/B2015-1-1_14-21-45-956-2048.jpg?dl=0

https://www.dropbox.com/s/96j0h69fovsc9wh/C2015-1-1_14-18-35-161-1024.jpg?dl=0

https://www.dropbox.com/s/y4w7nsu4ywgf3nm/D2015-1-1_14-14-5-641-512.jpg?dl=0


However I'm not convinced this is the full story due to some inconsistencies I have seen in the past.
I'm sure the OP would agree.

gb

Share this post


Link to post

Heya GB, 

 

Thanks for the samples! My shadows looks exactly like your 1024 shot - jagged edges (the "8-bit" effect I alluded to), soft, ill-defined, etc. However, I think your 512 and 4096 shots are both 4096? That 512.jpg is really clear!

 

Heya Rob, 

 

No worries, and Happy New Year to you as well. I will check all of my shadow settings against your list and verify I have them correctly set.

 

And I was kidding myself when I said I would "just turn them off". Even with 8-bit shadows it is just amazing to have the shadows turn inside the cockpit during a lazy late-afternoon flight. Tessellation is pretty darn cool, too!

 

Thanks for the assistance, guys - I will report back!

Share this post


Link to post

Heya GB, 

 

Thanks for the samples! My shadows looks exactly like your 1024 shot - jagged edges (the "8-bit" effect I alluded to), soft, ill-defined, etc. However, I think your 512 and 4096 shots are both 4096? That 512.jpg is really clear!

 

 

 

Hmmmm.....that is strange as I put all 4 shots on 4 tabs and jumped between them.  On my setup (680) the 512 looks very poor and the 4096 looks "so perfect" it looks fake.

For me the 2048 looks the most lifelike.

 

Ken

Share this post


Link to post
Guest

gb,

 

TEXTURE_MAX_LOAD  isn't used to govern shadow quality so it shouldn't have any affect.

 

John,

 

Not sure what you mean ... I see a significant difference between 512 and 4096 images posted by gb?

 

But like I said, be warned, 4096 at dawn/dusk will have a huge impact on FPS ... at least it does on my system (Titan Blacks).

 

Cheers, Rob.

Share this post


Link to post

I swear my computer is getting increasingly non-deterministic everyday - I just clicked on the link again and 512 looks properly poorly...

 

So, I had previously matched Rob's settings pretty much to the dot, the exception being SHADOW_QUALITY was set at 2, and I reset it to 4. Here is my current set of definitions.

 

[GRAPHICS]
MIPMAP_VC_PANELS=1
TESSELLATION=1
TEXTURE_MAX_LOAD=2048
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=0
BLOOM_LEVEL=2
SHADOW_QUALITY=4
TERRAIN_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_CAST_DISTANCE=3
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=1
CLOUD_SHADOWS_CAST=1
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=1
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=2048
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=2
EFFECTS_DISTANCE=2
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
 
With these settings I still have jagged edges, and shown in the screenshots in the links.
 
This first link is sitting on the tarmac at KMRY. While the screenshot is not bad, what is missing from the JPG is all the "crawling" for the shadows, particularly around the avionics.
 
This is an exterior shot, same scenariou. Nice crisp shadow.
 
This is in flight. As you can see, my frame rate is taking a hit from the overcast conditions (I think I will disable the DX11 option for REX weather - kills the graphics card and my frame rate).
 
Finally, we have a good frame rate (I told OPUS to load clear day), and my GTX 780 is rolling along about 75-percent busy with 1.6 GB memory load. You can really see the "8-bit" feeling in this shot.
 
P3D V2.4 is my Christmas gift to myself, and it truly is a remarkable improvement over FSX and V1.4, but these pesky shadows really stand out as the sole detriment!
 
Thanks for the help, guys!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...