Sign in to follow this  
Guest BeaverDriver

Citation Not Tracking GTN?

Recommended Posts

I thought this was working before, but in all the confusion over the past few days, maybe it wasn't. I did a flight plan in the GTN 750 as such:  CYXC --> ANTAK --> COE --> KSFF (and entered the ILS approach for 22 after the fact). Everything showed fine on the GTN. I took off, engaged the FD, NAV and ALT SEL. The airplane immediately went into a climbing left turn (my departure runway gave me basically a straight out departure) and reversed course. When we were flying northbound it settled on a heading (can't tell you which one - EADI not readable) going away from the course. So I rebooted FSX in case there was a problem there, and redid the flight. Same thing so before it got turned very far I went to heading mode and tracked the route to ANTAK manually. After passing over ANTAK, I turned via the heading selector so we were right on course, then engaged the NAV. This time it started a hard right turn and kept going. It finally stopped turning when it was going away from the WP, but I don't think it was tracking anything in particular. See screenshots below:

 

CitGTN1.jpg

In this shot, you can see I'm tracking AWAY from COE. Note the course info in the GTN says ANTAK > COE, not the other way around. I'm going opposite to the direction I should be going in.

 

CitGTN2.jpg

In this you can see how my autopilot is set up. Now, it does say "ARM" but originally when I switched over to NAV from HDG, the "CAP" annunciator was lit as I was right on course. The aircraft turned away anyway and started heading in more or less the opposite direction. That's when it switched to "ARM". I flew right through the course in the process.

 

I've circled the pertinent locations so you can see if I had something not set up correctly, but I've done this a lot and have not run into a problem with this before. That said, I've not flown the Citation a whole lot on the GTN. Anyone got any ideas here?

 

Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If you have tooltips on, mouse over the SD card slot on the GTN.

 

It will show you the "active navigation device".

 

Toggle by right clicking on the card slot.

Share this post


Link to post
Share on other sites

Thanks Bert. Don't have them on, but I'll turn them on to see if I can figure this out. That's probably it though. Appreciate the help (going to make a macro so I don't have to type that each time - it would be worth it given the number of times I've said that in the past few days!).

Share this post


Link to post
Share on other sites

If you are not using the FMC, remove all references to it in the panel.cfg file or it can interfere.

Share this post


Link to post
Share on other sites

OK, thanks. I'm pretty sure it was the GTN 750 that it was using as that's what came up on the default load just now. I have TT's turned on now though so I'll check that in the future.

 

Now, I still have the FMC installed, but it was never turned on. Can it interfere regardless (I'll still remove the references but it would be good to know anyway)?

 

Thanks.

Share this post


Link to post
Share on other sites

I commented mine out... the unit which shows up first in the panel.cfg file

is typically assigned by FSX as the active navigation unit.

Share this post


Link to post
Share on other sites

It appears there's no CDI on your EHSI.... Maybe I'm imagining things but I'm pretty sure there is one on mine with GTN integrated.

 

Edit: meh that's probably not it

 

Maybe the GTN just got screwed up. Try reflying same route after a reboot?

Share this post


Link to post
Share on other sites

Hi Ryan, yeah the needle is gone because I am too far off course. Even so, it should still display off to the side so you know which way to turn (yet ANOTHER bug). I tried another flight after rebooting to a different destination with the same results. The aircraft turns to a hdg of 0 degrees and stays there. I have no idea of what's going on with this thing at this point. It really acts like it's simply not recognizing that there is a course in there to follow and is defaulting to a 0 degree course absent any other input. I still think this is finger troubl on my part though. I will remove the FMC as Bert suggested tomorrow even thohough it is not turned on for these flights and see if that works.

 

Many thanks for the input. Much appreciated.

Share this post


Link to post
Share on other sites

My GTN Nav source is defaulting to FSX default GPS although there is not one installed. I still have my UNS-1 installed but it may or may not be rem out in the panel.cfg.

 

I have just gotten use to checking the Nav Source as a routine when using the GTNs. A simple right click on the SD card slot will tell you what is doing the navigating and another click or two and all is well.

 

Happy flying.

 

Regards,

 

Ray

Share this post


Link to post
Share on other sites

Thanks Ray. Yup, checked that and it was the 750 that was the primary source.

 

However, I did find the source of the problem. I ran the F1 GTN Configurator (not to install the gauge, but to check the options). Sure enough, there was no entry in the Autopilot section (it was blank) and I think the Radios were set to Com2/Nav2 for the 750 and the 650. As such, there was no GPS signal going to the autopilot. I reset everything in the Options windows and all was good after that (just finished the check flight). I don't know where or how it lost it's focus in that, but likely I did it accidentally why trying to get something else that wasn't working, fixed.

 

Anyway, for anyone reading this, if the A/P is switched to GPS but doesn't seem to be following the course, and you have the GTN installed, check (via the Configurator) your Options settings for each unit you have installed. Hopefully that will save you a lot of grief.

 

Thanks to all who helped out. Much appreciated!

Share this post


Link to post
Share on other sites

Hi Glenn,

 

Glad to hear you solved the problem.  I have a question though.  Before you found the fix I was going to try to duplicate your flight to see what would happen.  However, when inputting the waypoints in the 750 it would not accept ANTAK.  Said "No matches found".  How did you load this waypoint?

Thanks.

 

Jim

Share this post


Link to post
Share on other sites

That's odd Jim. I had no trouble inputting it. It took it right away. Now, does this instrument use Navigraph? I can't remember but I think it does, and I'm using Cycle 1501 I believe (the latest, or within one of the latest). If you are using a very old dbase, then it may not be in that one.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Hi Glenn,

 

Well this is getting weird. My Navigraph was outdated so I updated to the latest (1501). Still couldn't load ANTAK into the 750. Now the weird part.

 

I loaded the flight plan into the G1000 in the Citation Mustang. It accepted ANTAK ok. Took off, engaged Nav and it did just like you described. It made an immediate left turn and headed due north even though it showed ANTAK as the next wp.

 

Have no idea what is going on here. Different plane and all. Maybe somebody smarter than me can figure this out. Must be having a major brain cramp.

 

Jim

Share this post


Link to post
Share on other sites

Make sure your nav source is the GPS in the Mustang. Not sure what else that could be but it sounds like the a/p wasn't receiving a nav course to follow (same thing that happened to me).

Share this post


Link to post
Share on other sites

Just tried it with the F1 B200 Kingair.  Same thing happens.  Did you retry that flight after you found fixed the autopilot in the GNS config?

 

I'll keep checking my autopilot function on other flights and planes and see what happens.

 

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this