Sign in to follow this  
karim_

fsx time too fast!

Recommended Posts

Hello all,

 

I am having big problems in relation to FSX time.

When I clock 1 minute on my stopwatch, the FSX program gives me 52 seconds!

 

Thats 8 seconds less than 1 minute as you noticed!

 

This is very annoying because I have to use FSUIPC time sync, and it requires the  ''load 100%'' popup to appear every time again.

 

Anyone who had the same problem?

 

Thank you!

 

Best regards

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just a wild guess.  Maybe the stutters?  Everytime FSX stutters or has a hiccup, it kinda freezes for a fraction of a second and maybe, the clock freezes there too?

Share this post


Link to post
Share on other sites

It's around 50 seconds per minute for everyone on the planet no matter what the system, performance, hardware, software, or anything else. That is why there are the time sync options out there!!

Share this post


Link to post
Share on other sites

Just checked FSX-MS and FSX-SE, I found both keep good time on my systems.

Share this post


Link to post
Share on other sites

Hello all,

I am having big problems in relation to FSX time.

When I clock 1 minute on my stopwatch, the FSX program gives me 52 seconds!

Thats 8 seconds less than 1 minute as you noticed!

This is very annoying because I have to use FSUIPC time sync, and it requires the  ''load 100%'' popup to appear every time again.

Anyone who had the same problem?

Thank you!

Best regards

I had this problem after overclocking this solved it for me:

Open up a command line window and type in this.

bcdedit /set useplatformclock true

If you ever want to restore Windows to use the default timer then you can open a command window and type in this.

bcdedit /deletevalue useplatformclock

Download: WinTimerTester & test, that should do it  ^_^

 

Share this post


Link to post
Share on other sites

It MAY be your frame rates.  Can you post what your frame rates are set to and what you're getting in the sim?

 

I've seen poor frame rates /; micro stutters result in longer time (1 min actual becomes more than a minute in sim time), and though I've seen the opposite result I suppose it could be possible.

Share this post


Link to post
Share on other sites

I tried two machines timed over ten minutes kept perfect time, one with FSX-SE, the other with FSX-MS. So the first thing to do is run the sim without any addons or changes to the cfg.

Share this post


Link to post
Share on other sites

My frames are OK, I get a steady 30 frames (locked at 30).

 

My problem is that the time is not right (52 seconds in fsx, when I clock 1 minute).

 

The FSX is not too slow (due to low frames), but too fast and I really like to think its the overclocking that causes this.

( I overclocked the cpu from 3.7ghz to 4.0ghz.)

 

Thanks for your help!

Share this post


Link to post
Share on other sites

It's not the overclock...this issue was around in the FS9 days and was never fixed in FSX.  That's why there are time keeper programs out there like FSRealTime.

 

The problem is, in FS9 the time sync was transparent, and the sim did not do reloads.  In FSX, because of how SimConnect works, a time update results in the sim reloading the textures.

 

If it was an overclocking issue, your Windows Time would be off too.

 

So, in short, this is an old bug from even the pre-FSX days.

Share this post


Link to post
Share on other sites

Hello all,

 

I am having big problems in relation to FSX time.

When I clock 1 minute on my stopwatch, the FSX program gives me 52 seconds!

 

Thats 8 seconds less than 1 minute as you noticed!

 

This is very annoying because I have to use FSUIPC time sync, and it requires the  ''load 100%'' popup to appear every time again.

 

Anyone who had the same problem?

 

Thank you!

 

Best regards

 

Try this! I use it and it works great. Checks the FSX clock and adjusts it if needed.

 

http://www.3dsoftworks.net/products/fsrealtime/

 

/Per W

Share this post


Link to post
Share on other sites

When I clock 1 minute on my stopwatch, the FSX program gives me 52 seconds

Since two of my systems keep perfect time over 10 minutes flight, what process of elimination have you investigated? Have you timed the system clock to see if the system time is correct? If the system keeps time, have you turned off your addons to test without them?

Share this post


Link to post
Share on other sites

It will still cause the scenery refresh window to run though.

Yes if you set it to wait for long between checks/adjusts. I have never seen any scenery refresh, I've set it to check every 4/5 min and if the time differs 4 sec or more it adjusts. That small

adjustment does not cause any scenery refresh

 

If it did cause a refresh the whole time it would have been a dead prod by now.

 

/per

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this